Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#33009 closed defect (duplicate)

cairo build fails

Reported by: sarma72@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: cairo

Description (last modified by ryandesign (Ryan Schmidt))

Hi there, my first time here and a newby also with MacPort. Can anyone help me with this?

After typing "sudo port install texlive" and my password, after long I run into this problem

...
...
...
--->  Configuring cairo
--->  Building cairo
Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Failed to install cairo
Log for cairo is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_cairo/cairo/main.log
Error: The following dependencies were not installed: texlive-basic texlive-bin poppler gtk2 pango cairo shared-mime-info xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto lcms openjpeg jbigkit lcms2 poppler-data t1lib texlive-common texlive-common xorg-libXaw groff netpbm psutils texinfo xorg-libXmu xpm xorg-libXp xorg-printproto texlive-bin texlive-documentation-base texlive-basic texlive-bin-extra detex dvipng gd2 latexmk texlive-latex texlive-latex pdfjam texlive-latex-recommended pgf texlive-latex-recommended texlive-context texlive-fonts-recommended texlive-math-extra texlive-metapost texlive-xetex texlive-generic-recommended texlive-documentation-english texlive-fontutils texlive-lang-czechslovak texlive-lang-dutch texlive-lang-english texlive-lang-french texlive-lang-german texlive-lang-italian texlive-lang-polish texlive-lang-portuguese texlive-lang-spanish texlive-luatex
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Please note that I have brand new MacBook Pro, with X11 and a freshly installed XCode 4.1 . I have not messed up with much else.

Thanks a lot in advance,

Marc

Attachments (1)

main.log (52.5 KB) - added by sarma72@… 9 years ago.
log of problem with installing texlive, probably related to cairo

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Port: cairo added
Summary: problem with installing texlive with macportcairo build fails

You will need to attach the aforementioned cairo main.log file for us to be able to see what went wrong. But before you do so, please clean and try again.

sudo port clean cairo

P.S: Remember WikiFormatting when writing here in Trac.

P.P.S: Note that the current version of Xcode is 4.2.1. You don't have to update, but if you want to, you can get 4.2.1 for free on the Mac App Store.

Changed 9 years ago by sarma72@…

Attachment: main.log added

log of problem with installing texlive, probably related to cairo

comment:2 Changed 9 years ago by sarma72@…

Wow that was quick, thanks. I have "cleaned cairo" and I'm attaching the log of the subsequent, inevitable failure. Yes, I've installed the latest xCode, 4.2.1, sorry, forgot the .2 in the middle. Error messages are the same.

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Thanks. Duplicate of #32087.

comment:4 in reply to:  3 Changed 9 years ago by sarma72@…

Replying to ryandesign@…:

Thanks. Duplicate of #32087.

Cheers!

Note: See TracTickets for help on using tickets.