Opened 9 years ago

Closed 9 years ago

#33017 closed defect (duplicate)

i386-elf-gcc @4.3.2 Build failure - cannot compute suffix of object files (10.7.2 Lion)

Reported by: pugiox@… Owned by: stepan@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: i386-elf-gcc

Description (last modified by mf2k (Frank Schima))

Lion 10.7.2, Xcode 4.2, new install of Mac Ports:

sudo port install i386-elf-gcc

Installs all dependencies fine, then fails with:

Error: Target org.macports.build returned: shell command failed (see log for details)
Log for i386-elf-gcc is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cross_i386-elf-gcc/i386-elf-gcc/main.log
Error: Status 1 encountered during processing.

The actual error, in the log, is:

:info:build checking for i386-elf-gcc... /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cross_i386-elf-gcc/i386-elf-gcc/work/build/./gcc/xgcc -B/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cross_i386-elf-gcc/i386-elf-gcc/work/build/./gcc/ -nostdinc -B/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cross_i386-elf-gcc/i386-elf-gcc/work/build/i386-elf/newlib/ -isystem /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cross_i386-elf-gcc/i386-elf-gcc/work/build/i386-elf/newlib/targ-include -isystem /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cross_i386-elf-gcc/i386-elf-gcc/work/gcc-4.3.2/newlib/libc/include -B/opt/local/i386-elf/bin/ -B/opt/local/i386-elf/lib/ -isystem /opt/local/i386-elf/include -isystem /opt/local/i386-elf/sys-include
:info:build checking for suffix of object files... configure: error: cannot compute suffix of object files: cannot compile
:info:build See `config.log' for more details.
:info:build make[1]: *** [configure-target-libgcc] Error 1

Based on some searches it seems that this may be a problem with the install not noticing the 'gmp' and 'mpfr' packages. The recommended fix of explicitly adding the path to those packages in LD_LIBRARY_PATH (I tried LD_LIBRARY_PATH=/opt/local/lib:/opt/local/include) doesn't seem to have any effect.

Attached is the full log.

Attachments (1)

main.log (1001.7 KB) - added by pugiox@… 9 years ago.
Build log

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by pugiox@…

Attachment: main.log added

Build log

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to stepan@…
Port: i386-elf-gcc added

comment:2 Changed 9 years ago by pugiox@…

Apologies, it appears I have duplicated this ticket: https://trac.macports.org/ticket/28912 Temporarily changing the gcc and cc symlinks in /usr/bin to gcc-4.2 (instead of the llvm one) solved the problem, as mentioned in that ticket.

comment:3 Changed 9 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

Duplicate of #28912.

Note: See TracTickets for help on using tickets.