Opened 9 years ago

Closed 9 years ago

#33029 closed defect (fixed)

fcgi build failure: ld: library not found for -lfcgi

Reported by: 542.dan@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: fcgi

Description

I can't install fcgi.

$ sudo port install fcgi  
--->  Computing dependencies for fcgi
--->  Fetching archive for fcgi
--->  Attempting to fetch fcgi-2.4.0_3.darwin_11.x86_64.tbz2 from http://packages.macports.org/fcgi
--->  Fetching fcgi
--->  Verifying checksum(s) for fcgi
--->  Extracting fcgi
--->  Applying patches to fcgi
--->  Configuring fcgi
--->  Building fcgi
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for fcgi is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_fcgi/fcgi/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

I'm attaching /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_fcgi/fcgi/main.log

Attachments (1)

main.log (45.7 KB) - added by 542.dan@… 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Don't forget to attach the log file.

Changed 9 years ago by 542.dan@…

Attachment: main.log added

comment:2 Changed 9 years ago by 542.dan@…

Oh, I'm sorry, I had some trouble uploading the log, now it's uploaded.

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Summary: Can't install fcgifcgi build failure: ld: library not found for -lfcgi

The error...

:info:build ld: library not found for -lfcgi

...makes this feel like a parallel build failure to me. I can't reproduce it on my system, but parallel build failures can be hard to reproduce, especially since I don't have the same hardware you have.

Could you try building with just one job, instead of the four MacPorts was starting? Like this:

sudo port clean fcgi
sudo port install fcgi build.jobs=1

If that fails, please attach the new main.log; if it succeeds, we can turn off parallel building in the port.

comment:4 Changed 9 years ago by 542.dan@…

It worked! So it was parallel build failure.

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Thanks. Fixed in r89480.

Note: See TracTickets for help on using tickets.