Opened 9 years ago

Closed 9 years ago

#33082 closed defect (fixed)

gv: Segmentation fault at launch

Reported by: johnhcg2@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: su-v, majoc-at-astro (majoc-at-astro), rosgen@…, basmac, jjstickel (Jonathan Stickel), rklein@…, williamlockman@…, nicholas.clark@…, skymoo (Adam Mercer), llt003@…
Port: gv

Description (last modified by ryandesign (Ryan Schmidt))

Since upgrading from gv @3.7.2_0 to @3.7.3_0, gv exits immediately with a warning and then a segmentation fault:

Warning: Representation size 4 must match superclass's to override highlightedFrameStyle
Segmentation fault

Change History (39)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Summary: Segmentation faultgv: Segmentation fault at launch

Yes, there have been other reports of that, and I see it too. I don't know how to fix it. I will ask the developer of gv.

comment:2 Changed 9 years ago by su-v

Cc: suv-sf@… added

Cc Me!

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

comment:4 Changed 9 years ago by majoc-at-astro (majoc-at-astro)

Cc: majoc@… added

Cc Me!

comment:5 Changed 9 years ago by rosgen@…

Cc: rosgen@… added

Cc Me!

comment:6 Changed 9 years ago by basmac

Cc: barry.j.mcinnes@… added

Cc Me!

comment:7 Changed 9 years ago by jjstickel (Jonathan Stickel)

Cc: jjstickel@… added

Cc Me!

comment:8 Changed 9 years ago by rklein@…

Cc: rklein@… added

Cc Me!

comment:9 in reply to:  description Changed 9 years ago by williamlockman@…

Replying to johnhcg2@…:

Since upgrading from gv @3.7.2_0 to @3.7.3_0, gv exits immediately with a warning and then a segmentation fault:

Warning: Representation size 4 must match superclass's to override highlightedFrameStyle
Segmentation fault

I am not a developer of gv. However, I see the same problem running gv 3.7.3. Here is the traceback from running gdb (the gnu debugger)

Warning: Representation size 4 must match superclass's to override highlightedFrameStyle

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: 13 at address: 0x0000000000000000
0x000000010022039c in XtWindowOfObject ()
(gdb) where
#0  0x000000010022039c in XtWindowOfObject ()
#1  0x000000010018f3f0 in SetValues ()
#2  0x000000010022f816 in CallSetValues ()
#3  0x000000010022f7ce in CallSetValues ()
#4  0x000000010022eeec in XtSetValues ()
#5  0x00000001000170d9 in main ()

The problem is a null pointer is being dereferenced, apparently in XtWindowOfObject.

Hopefully this information will be useful to the developers.

comment:10 Changed 9 years ago by williamlockman@…

Cc: williamlockman@… added

Cc Me!

comment:11 Changed 9 years ago by nicholas.clark@…

I'm having this problem too.

comment:12 Changed 9 years ago by nicholas.clark@…

Cc: nicholas.clark@… added

Cc Me!

comment:13 Changed 9 years ago by skymoo (Adam Mercer)

Cc: ram@… added

Cc Me!

comment:14 Changed 9 years ago by veedeehjay@…

Cc Me!

comment:15 Changed 9 years ago by veedeehjay@…

hi,
I googled a bit and, in case this is not yet clear, it seems that the problem arises due to an incompatibility of gv with Xaw3d-1.6.1. from a fedora mailing list:

8<===================================
=> gv-3.7.3 + Scrollbar.c patch + Xaw3d-1.6
   ----------------------------------------
   gv builds and runs fine on both 32 and 64 bit machines
=> gv-3.7.3 + Scrollbar.c patch + Xaw3d-1.6.1
   ------------------------------------------
...
 gv does not start either and says:

        Warning: Representation size 4 must match superclass's to override 
highlightedFrameStyle"
8<===================================

maybe, as a work around, gv could be linked against the older library (Xaw3d-1.6)?

regards,
joerg

comment:16 Changed 9 years ago by llt003@…

cc me please! thanks!

comment:17 in reply to:  16 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: llt003@… added

Replying to llt003@…:

cc me please! thanks!

I have Cc'd you, but in future, please Cc yourself by clicking the "CcMe!" button.

comment:18 in reply to:  15 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

comment:19 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

Two users have indicated to me by email that this did not fix the problem for them.

comment:20 Changed 9 years ago by skymoo (Adam Mercer)

It worked for me.

comment:21 in reply to:  19 Changed 9 years ago by rklein@…

Replying to ryandesign@…:

Two users have indicated to me by email that this did not fix the problem for them.

I cannot start gv either after the "fix". Now I am getting the following fatal error message while starting up gv:

dyld: Library not loaded: /opt/local/lib/libXaw3d.8.dylib
  Referenced from: /opt/local/bin/gv
  Reason: Incompatible library version: gv requires version 9.0.0 or later, but libXaw3d.8.dylib provides version 8.0.0
Trace/BPT trap

comment:22 Changed 9 years ago by ryandesign (Ryan Schmidt)

@ram: it worked for me too.

@rklein: that's a different error. Try reinstalling Xaw3d and gv. Open a new ticket if the issue persists since it is unrelated to this ticket.

comment:23 Changed 9 years ago by su-v

Works for me (OS X 10.7.2, Xcode 4.2.1, MacPorts 2.0.4):

  gv @3.7.3.90_0 (active)
  Xaw3d @1.6.1_0 (active)

comment:24 Changed 9 years ago by ryandesign (Ryan Schmidt)

Then what I need is for anyone still experiencing the problem with 3.7.3.90_0 is for you to attach the crash log.

comment:25 in reply to:  22 Changed 9 years ago by rklein@…

Replying to ryandesign@…:

@rklein: that's a different error. Try reinstalling Xaw3d and gv. Open a new ticket if the issue persists since it is unrelated to this ticket.

I reinstalled Xaw3d and gv and I am back to the original error:

Warning: Representation size 4 must match superclass's to override highlightedFrameStyle
Segmentation fault

These are the freshly installed versions:

gv @3.7.3.90_0 (active)
Xaw3d @1.6.1_0 (active)

comment:26 Changed 9 years ago by ryandesign (Ryan Schmidt)

@rklein: Please remember to use WikiFormatting when you write in Trac, and to preview before submitting. Please attach the crash log that OS X generated for this segmentation fault. The log should be in ~/Library/Logs/DiagnosticReports.

comment:27 in reply to:  26 Changed 9 years ago by rklein@…

Replying to ryandesign@…:

@rklein: [...] Please attach the crash log that OS X generated for this segmentation fault. The log should be in ~/Library/Logs/DiagnosticReports.

Here is the crash log:

Process:         gv [51912]
Path:            /opt/local/bin/gv
Identifier:      gv
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  bash [51704]

Date/Time:       2012-03-07 09:47:37.172 -0800
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000029
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libXt.6.dylib                 	0x00000001002319d8 XtWindowOfObject + 8
1   libXaw3d.8.dylib              	0x000000010019a7cd SetValues + 221
2   libXt.6.dylib                 	0x000000010024199f CallSetValues + 191
3   libXt.6.dylib                 	0x0000000100241959 CallSetValues + 121
4   libXt.6.dylib                 	0x0000000100242256 XtSetValues + 1542
5   gv                            	0x00000001000196e2 main + 11586
6   gv                            	0x0000000100001684 start + 52

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000001  rbx: 0x00000001005422c0  rcx: 0x00007fff5fbff530  rdx: 0x00000001005422c0
  rdi: 0x00000001005422c0  rsi: 0x00007fff5fbfe870  rbp: 0x00007fff5fbfe6f0  rsp: 0x00007fff5fbfe6f0
   r8: 0x00007fff5fbfe73c   r9: 0x0000000000000001  r10: 0x0000000000000000  r11: 0x0000000000000000
  r12: 0x00007fff5fbfeb90  r13: 0x0000000000000001  r14: 0x00007fff5fbff530  r15: 0x00000001005422c0
  rip: 0x00000001002319d8  rfl: 0x0000000000010246  cr2: 0x0000000000000029

Binary Images:
       0x100000000 -        0x100058fff +gv ??? (???) <F78A166A-E7E9-52DC-364E-43C74B26C9AE> /opt/local/bin/gv
       0x100086000 -        0x100184fef +libiconv.2.dylib 8.1.0 (compatibility 8.0.0) <065A36D7-5F15-7B4C-C3F4-D9B23DFC36A3> /opt/local/lib/libiconv.2.dylib
       0x100192000 -        0x100193ff7 +libXinerama.1.dylib 2.0.0 (compatibility 2.0.0) <8EDB2C4E-11A8-3AEB-A0E2-505FF76FCA28> /opt/local/lib/libXinerama.1.dylib
       0x100196000 -        0x1001d4fef +libXaw3d.8.dylib 9.0.0 (compatibility 9.0.0) <280B43D8-E200-5B57-0252-D52360D5F45D> /opt/local/lib/libXaw3d.8.dylib
       0x1001ee000 -        0x1001fbfff +libXpm.4.dylib 16.0.0 (compatibility 16.0.0) <38B39623-0C56-3494-92BF-937444780F95> /opt/local/lib/libXpm.4.dylib
       0x100200000 -        0x100212fff +libXmu.6.dylib 9.0.0 (compatibility 9.0.0) <2263EA34-7577-5BA5-FDF5-761113C68793> /opt/local/lib/libXmu.6.dylib
       0x10021b000 -        0x100268fff +libXt.6.dylib 7.0.0 (compatibility 7.0.0) <56B1E5A5-D53E-79DE-8EB1-5DCEB423D042> /opt/local/lib/libXt.6.dylib
       0x100280000 -        0x10028ffff +libXext.6.dylib 11.0.0 (compatibility 11.0.0) <F4A3E680-6371-6C74-EFE1-E32EEEED3850> /opt/local/lib/libXext.6.dylib
       0x100295000 -        0x10029afff +libSM.6.dylib 7.1.0 (compatibility 7.0.0) <0F880B2D-0B3A-0D89-3E38-4CEFCB83FA83> /opt/local/lib/libSM.6.dylib
       0x10029e000 -        0x1002b0ff7 +libICE.6.dylib 10.0.0 (compatibility 10.0.0) <AAB78FA1-8A23-802F-7368-8ED6B6F42F08> /opt/local/lib/libICE.6.dylib
       0x1002ba000 -        0x1003d9ff7 +libX11.6.dylib 10.0.0 (compatibility 10.0.0) <757E973C-8672-B5A4-22E5-FFC8703E157B> /opt/local/lib/libX11.6.dylib
       0x1003fd000 -        0x100411fff +libxcb.1.dylib 3.0.0 (compatibility 3.0.0) <1CF695A1-E4E4-D1C7-B59F-2080395B40E1> /opt/local/lib/libxcb.1.dylib
       0x10041e000 -        0x10041ffff +libXau.6.dylib 7.0.0 (compatibility 7.0.0) <E93A095B-3A82-9464-2526-69AF0A59E563> /opt/local/lib/libXau.6.dylib
       0x100422000 -        0x100425fef +libXdmcp.6.dylib 7.0.0 (compatibility 7.0.0) <7033E072-72DB-88EA-4B5F-95E7AD66FE3F> /opt/local/lib/libXdmcp.6.dylib
       0x100428000 -        0x100431ff7 +libintl.8.dylib 10.1.0 (compatibility 10.0.0) <D1004391-54AA-C4FD-47A1-80B94415BD62> /opt/local/lib/libintl.8.dylib
    0x7fff5fc00000 -     0x7fff5fc3bdef  dyld 132.1 (???) <B536F2F1-9DF1-3B6C-1C2C-9075EA219A06> /usr/lib/dyld
    0x7fff81261000 -     0x7fff81422fef  libSystem.B.dylib 125.2.11 (compatibility 1.0.0) <9AB4F1D1-89DC-0E8A-DC8E-A4FE4D69DB69> /usr/lib/libSystem.B.dylib
    0x7fff843f8000 -     0x7fff84409ff7  libz.1.dylib 1.2.3 (compatibility 1.0.0) <FB5EE53A-0534-0FFA-B2ED-486609433717> /usr/lib/libz.1.dylib
    0x7fff85514000 -     0x7fff85560fff  libauto.dylib ??? (???) <F7221B46-DC4F-3153-CE61-7F52C8C293CF> /usr/lib/libauto.dylib
    0x7fff85f72000 -     0x7fff86028ff7  libobjc.A.dylib 227.0.0 (compatibility 1.0.0) <03140531-3B2D-1EBA-DA7F-E12CC8F63969> /usr/lib/libobjc.A.dylib
    0x7fff88851000 -     0x7fff88855ff7  libmathCommon.A.dylib 315.0.0 (compatibility 1.0.0) <95718673-FEEE-B6ED-B127-BCDBDB60D4E5> /usr/lib/system/libmathCommon.A.dylib
    0x7fff88eec000 -     0x7fff88f69fef  libstdc++.6.dylib 7.9.0 (compatibility 7.0.0) <35ECA411-2C08-FD7D-11B1-1B7A04921A5C> /usr/lib/libstdc++.6.dylib
    0x7fff8979b000 -     0x7fff89959fff  libicucore.A.dylib 40.0.0 (compatibility 1.0.0) <4274FC73-A257-3A56-4293-5968F3428854> /usr/lib/libicucore.A.dylib
    0x7fff8a29d000 -     0x7fff8a414fe7  com.apple.CoreFoundation 6.6.6 (550.44) <BB4E5158-E47A-39D3-2561-96CB49FA82D4> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    0x7fffffe00000 -     0x7fffffe01fff  libSystem.B.dylib ??? (???) <9AB4F1D1-89DC-0E8A-DC8E-A4FE4D69DB69> /usr/lib/libSystem.B.dylib

comment:28 Changed 9 years ago by johnhcg2@…

Here's a crash log. I started fresh before doing this, deleting /opt/local, reinstalling macports, and installing gv again.

Process:         gv [18737]
Path:            /opt/local/bin/gv
Identifier:      gv
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  tcsh [3511]

Date/Time:       2012-03-07 13:23:42.232 -0700
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000001028
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libXt.6.dylib                       0x000000010023197d _XtWindowedAncestor + 45
1   libXt.6.dylib                       0x00000001002319e3 XtWindowOfObject + 19
2   libXaw3d.8.dylib                    0x000000010019a7cd SetValues + 221
3   libXt.6.dylib                       0x000000010024199f CallSetValues + 191
4   libXt.6.dylib                       0x0000000100241959 CallSetValues + 121
5   libXt.6.dylib                       0x0000000100242256 XtSetValues + 1542
6   gv                                  0x00000001000196e2 main + 11586
7   gv                                  0x0000000100001684 start + 52

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000001000  rbx: 0x00000001005367c0  rcx: 0x00007fff5fbff2d0  rdx: 0x000000010052002a
  rdi: 0x00000001005367c0  rsi: 0x00007fff5fbfe610  rbp: 0x00007fff5fbfe480  rsp: 0x00007fff5fbfe470
   r8: 0x00007fff5fbfe4dc   r9: 0x0000000000000001  r10: 0x0000000000000000  r11: 0x0000000000000000
  r12: 0x00007fff5fbfe930  r13: 0x0000000000000001  r14: 0x00007fff5fbff2d0  r15: 0x00000001005367c0
  rip: 0x000000010023197d  rfl: 0x0000000000010202  cr2: 0x0000000000001028

Binary Images:
       0x100000000 -        0x100058fff +gv ??? (???) <F78A166A-E7E9-52DC-364E-43C74B26C9AE> /opt/local/bin/gv
       0x100086000 -        0x100184fef +libiconv.2.dylib 8.1.0 (compatibility 8.0.0) <065A36D7-5F15-7B4C-C3F4-D9B23DFC36A3> /opt/local/lib/libiconv.2.dylib
       0x100192000 -        0x100193ff7 +libXinerama.1.dylib 2.0.0 (compatibility 2.0.0) <8D3F8173-A5CC-2688-0595-9AA815713BB0> /opt/local/lib/libXinerama.1.dylib
       0x100196000 -        0x1001d4fef +libXaw3d.8.dylib 9.0.0 (compatibility 9.0.0) <280B43D8-E200-5B57-0252-D52360D5F45D> /opt/local/lib/libXaw3d.8.dylib
       0x1001ee000 -        0x1001fbfff +libXpm.4.dylib 16.0.0 (compatibility 16.0.0) <020751F8-A763-7E67-5BBF-FFFBD40D0E4C> /opt/local/lib/libXpm.4.dylib
       0x100200000 -        0x100212fff +libXmu.6.dylib 9.0.0 (compatibility 9.0.0) <AAAFCD7B-F00C-6A86-5D44-2C911A568603> /opt/local/lib/libXmu.6.dylib
       0x10021b000 -        0x100268fff +libXt.6.dylib 7.0.0 (compatibility 7.0.0) <9188B95A-D6C5-A41B-F0EE-A03BDF8B3863> /opt/local/lib/libXt.6.dylib
       0x100280000 -        0x10028ffff +libXext.6.dylib 11.0.0 (compatibility 11.0.0) <76756504-48DD-A142-CD72-12347F56CC19> /opt/local/lib/libXext.6.dylib
       0x100295000 -        0x10029afff +libSM.6.dylib 7.1.0 (compatibility 7.0.0) <0F880B2D-0B3A-0D89-3E38-4CEFCB83FA83> /opt/local/lib/libSM.6.dylib
       0x10029e000 -        0x1002b0ff7 +libICE.6.dylib 10.0.0 (compatibility 10.0.0) <AAB78FA1-8A23-802F-7368-8ED6B6F42F08> /opt/local/lib/libICE.6.dylib
       0x1002ba000 -        0x1003d9ff7 +libX11.6.dylib 10.0.0 (compatibility 10.0.0) <757E973C-8672-B5A4-22E5-FFC8703E157B> /opt/local/lib/libX11.6.dylib
       0x1003fd000 -        0x100411fff +libxcb.1.dylib 3.0.0 (compatibility 3.0.0) <7B49D519-1837-8CA0-C161-BC7A5084B011> /opt/local/lib/libxcb.1.dylib
       0x10041e000 -        0x10041ffff +libXau.6.dylib 7.0.0 (compatibility 7.0.0) <BE9C7BA9-5188-F427-D438-15728ADE0129> /opt/local/lib/libXau.6.dylib
       0x100422000 -        0x100425fef +libXdmcp.6.dylib 7.0.0 (compatibility 7.0.0) <4CED5993-D100-4B8B-3B20-45A6A8BD65C6> /opt/local/lib/libXdmcp.6.dylib
       0x100428000 -        0x100431ff7 +libintl.8.dylib 10.1.0 (compatibility 10.0.0) <C692173B-95FB-957F-CC25-32BC5E3A89EC> /opt/local/lib/libintl.8.dylib
    0x7fff5fc00000 -     0x7fff5fc3bdef  dyld 132.1 (???) <486E6C61-1197-CC7C-2197-82CE505102D7> /usr/lib/dyld
    0x7fff80332000 -     0x7fff804f0fff  libicucore.A.dylib 40.0.0 (compatibility 1.0.0) <4274FC73-A257-3A56-4293-5968F3428854> /usr/lib/libicucore.A.dylib
    0x7fff80529000 -     0x7fff80575fff  libauto.dylib ??? (???) <F7221B46-DC4F-3153-CE61-7F52C8C293CF> /usr/lib/libauto.dylib
    0x7fff80ae3000 -     0x7fff80ae7ff7  libmathCommon.A.dylib 315.0.0 (compatibility 1.0.0) <95718673-FEEE-B6ED-B127-BCDBDB60D4E5> /usr/lib/system/libmathCommon.A.dylib
    0x7fff80d92000 -     0x7fff80e0ffef  libstdc++.6.dylib 7.9.0 (compatibility 7.0.0) <35ECA411-2C08-FD7D-11B1-1B7A04921A5C> /usr/lib/libstdc++.6.dylib
    0x7fff82c6f000 -     0x7fff82d25ff7  libobjc.A.dylib 227.0.0 (compatibility 1.0.0) <03140531-3B2D-1EBA-DA7F-E12CC8F63969> /usr/lib/libobjc.A.dylib
    0x7fff884ac000 -     0x7fff8866dfef  libSystem.B.dylib 125.2.11 (compatibility 1.0.0) <9AB4F1D1-89DC-0E8A-DC8E-A4FE4D69DB69> /usr/lib/libSystem.B.dylib
    0x7fff8866e000 -     0x7fff887e5fe7  com.apple.CoreFoundation 6.6.6 (550.44) <BB4E5158-E47A-39D3-2561-96CB49FA82D4> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    0x7fff89e0d000 -     0x7fff89e1eff7  libz.1.dylib 1.2.3 (compatibility 1.0.0) <97019C74-161A-3488-41EC-A6CA8738418C> /usr/lib/libz.1.dylib
    0x7fffffe00000 -     0x7fffffe01fff  libSystem.B.dylib ??? (???) <9AB4F1D1-89DC-0E8A-DC8E-A4FE4D69DB69> /usr/lib/libSystem.B.dylib

comment:29 in reply to:  19 ; Changed 9 years ago by majoc-at-astro (majoc-at-astro)

Replying to ryandesign@…:

Two users have indicated to me by email that this did not fix the problem for them.

Question to the Assembled: Might I be right in thinking that this fault is fixed under Lion, but not under Snow Leopard? All our tests here so far have been on SL.

comment:30 in reply to:  29 Changed 9 years ago by rosgen@…

Replying to majoc@…:

Question to the Assembled: Might I be right in thinking that this fault is fixed under Lion, but not under Snow Leopard? All our tests here so far have been on SL.

It is sadly not so simple. I am running OS X 10.6.8, Xcode 3.2.6, and MacPorts 2.0.4, and the update has fixed gv for me. Versions are:

gv @3.7.3.90_0 (active)
Xaw3d @1.6.1_0 (active)

comment:31 Changed 9 years ago by basmac

uninstall/install of gv on Lion 10.7.3, after updating to 2.0.4 made gv work for us

port info gv
gv @3.7.3.90 (print)
Variants:             letter, universal

Description:          gv is a X11 PostScript and PDF previewer based on Tim Theisen's ghostview-1.5. It uses the Xaw3d widget set, thus providing a much nicer look and it's said to be a bit faster.
Homepage:             http://www.gnu.org/software/gv/

Library Dependencies: xorg-libXinerama, libiconv, Xaw3d, bzip2
Runtime Dependencies: ghostscript
Platforms:            darwin
License:              GPL-3+
Maintainers:          ryandesign@macports.org, openmaintainer@macports.org

comment:32 in reply to:  31 ; Changed 9 years ago by majoc-at-astro (majoc-at-astro)

Replying to barry.j.mcinnes@…:

uninstall/install of gv on Lion 10.7.3, after updating to 2.0.4 made gv work for us

Bingo: uninstalling, then building from source ("port -vfs install gv"), gives me a working gv under SL. I hereby declare myself a happy MaJoC, and leave it up to others to work out what's causing problems with the binary download (or whatever else it might be).

comment:33 in reply to:  32 Changed 9 years ago by johnhcg2@…

Replying to majoc@…:

Replying to barry.j.mcinnes@…: Bingo: uninstalling, then building from source ("port -vfs install gv"), gives me a working gv under SL. I hereby declare myself a happy MaJoC, and leave it up to others to work out what's causing problems with the binary download (or whatever else it might be).

Building from source worked for me as well, whereas the usual method did not. Thanks for that tip, hopefully this is a viable workaround until the problem is resolved.

comment:34 Changed 9 years ago by rklein@…

Now gv works for me too! I unistalled gv again and then used port -vfs intall gv to install again. Thanks!

comment:35 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: reopenedclosed

comment:36 in reply to:  35 ; Changed 9 years ago by majoc-at-astro (majoc-at-astro)

Resolution: fixed
Status: closedreopened

Replying to jeremyhu@…:

See #33420 r90886

Still not fixed in gv-3.7.3.90_0.darwin_10.x86_64.tbz2 from packages.macports.org, I'm afraid, at least for SL systems. Workaround as before is to remove and build from source.

Apologies for being the bearer of bad news.

comment:37 Changed 9 years ago by ryandesign (Ryan Schmidt)

I believe you. I haven't had a chance to try to determine what's different between the buildbot's version and the one you get when you build yourself.

comment:38 in reply to:  36 Changed 9 years ago by p.stevenson@…

Replying to majoc@…:

Still not fixed in gv-3.7.3.90_0.darwin_10.x86_64.tbz2 from packages.macports.org, I'm afraid, at least for SL systems. Workaround as before is to remove and build from source.

Just to add to the datapoints, I have the same problem in SL and can fix it the same way.

comment:39 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

The gv developer Markus Steinborn noticed that the port is missing a dependency on pkgconfig. He explained that Xaw3d 1.6+ has a pkgconfig file, and that the fallback mechanism in gv for when a pkgconfig file is not found is only meant to detect Xaw3d 1.5(E) and doesn't work right for 1.6+.

I added the pkgconfig dependency in r91413.

Note: See TracTickets for help on using tickets.