New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #33115 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Boost @1.4.8 +debug Build Error

Reported by: led@… Owned by: adfernandes@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Lion Xcode 4.2.1 gcc LLVM Cc: reko@…
Port: boost

Description

Installing the Boost Library using Macports fails, due to an unrecognized command line option. In particular, I tried to install the boost library using the command:

sudo port install boost +debug

Macports fails to install the port and provides the error message:

Error: Target org.macports.build returned: shell command failed (see log for details)
Log for boost is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_boost/boost/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

I'm using Mac OSX Lion 10.7.2 and XCode 4.2.1. The used compiler is LLVM-GCC-4.2.1

i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.1.00)
Copyright (C) 2007 Free Software Foundation, Inc.

From the logs: The cause of the error seems to be some unrecognized c++ options:

:info:build cc1plus: error: unrecognized command line option "-Wno-long-double"
:info:build cc1plus: error: unrecognized command line option "-fcoalesce-templates"

Is there an option to fix this bug?

Attachments

main.log (1.3 MB) - added by led@… 2 years ago.
Log file created during install
main.2.log (11.7 MB) - added by led@… 2 years ago.
GCC Log

Change History

Changed 2 years ago by led@…

Log file created during install

comment:1 Changed 2 years ago by led@…

  • Cc led@… added

Cc Me!

comment:2 Changed 2 years ago by led@…

Just as a side note: Trying to install the apple GCC42 as suggested in the hot topics also fails. From the logs:

:info:build ./gtyp-gen.h:2: error: expected identifier or '(' before string constant
:info:build ./gtyp-gen.h:8: error: expected identifier or '(' before string constant
:info:build ./gtyp-gen.h:139: warning: ISO C does not allow extra ';' outside of a function
:info:build ./gtyp-gen.h:140: error: expected identifier or '(' before string constant
:info:build ./gtyp-gen.h:178: warning: ISO C does not allow extra ';' outside of a function
:info:build ./gtyp-gen.h:179: error: expected identifier or '(' before string constant
:info:build ./gtyp-gen.h:188: warning: ISO C does not allow extra ';' outside of a function
:info:build ./gtyp-gen.h:189: error: expected identifier or '(' before string constant

Changed 2 years ago by led@…

GCC Log

comment:3 Changed 2 years ago by reko@…

I have the same issue, I've tried researching and fixing it for a while now, but can't seem to resolve it. Any help would be greatly appreciated!

comment:4 Changed 2 years ago by led@…

Just as an additional information. I just build the Boost library version 1.48 by hand using the sources from the boost website. I extracted the commands you used for the bootstrap.sh and the b2 install. Everything worked fine and boost compiled without any errors. Also the sources were copied in the right direction. As a results, I assume that the above mentioned issue is not caused by the Boost Library, but a failure in the macports script.

Thanks a lot for any help in advance.

Best,

Lars

comment:5 Changed 2 years ago by ryandesign@…

  • Owner changed from macports-tickets@… to adfernandes@…
  • Cc reko@… added; led@… removed
  • Port changed from Boost to boost
  • Keywords Boost removed

comment:6 Changed 2 years ago by adfernandes@…

  • Status changed from new to closed
  • Resolution set to fixed

Yep - bjam adds the wrong compiler options if a different sdkroot is selected. Fixed in r89555 (but keeps #33085 open).

Note: See TracTickets for help on using tickets.