Opened 9 years ago

Closed 9 years ago

#33176 closed defect (worksforme)

kdevelop: error: ui_custom_include_paths.h: No such file or directory

Reported by: pjnneves@… Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: pjnneves@…
Port: kdevelop

Description (last modified by ryandesign (Ryan Schmidt))

System: Mac OS X 10.6.8
XCode: 3.2.6 64b

Error description: while building kdevelop, on the last phase (i.e. after building all dependencies ok), during kdevelop build an error occured and building stopped, please check attached log file.

Thanks in advance for checking this!

Attachments (2)

main.log (1.4 MB) - added by pjnneves@… 9 years ago.
kdevelop build error log
KDevelop_terminal_output.txt (1.6 KB) - added by pjnneves@… 9 years ago.

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by pjnneves@…

Attachment: main.log added

kdevelop build error log

comment:1 Changed 9 years ago by pjnneves@…

Cc: pjnneves@… added

Cc Me!

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: pjnneves@… removed
Description: modified (diff)
Keywords: kdevelop qt4 snow leopard removed
Owner: changed from macports-tickets@… to nicos@…
Summary: kdevelop @4.2.3 QtCore compile error - build failurekdevelop: error: ui_custom_include_paths.h: No such file or directory

The log shows this error:

error: ui_custom_include_paths.h: No such file or directory

comment:3 Changed 9 years ago by NicosPavlov

It does not seem that this error is due to a missing dependency. The file ui_custom_include_paths.h should be automatically generated during build.

I typically have that during build (same config as the one in description)

[ 84%] Generating ui_custom_include_paths.h

which does not seem to appear in main.log, although my configuration step is strictly the same as the one shown in main.log.

comment:4 Changed 9 years ago by pjnneves@…

ok, but...any suggestions on how to fix this?

comment:5 Changed 9 years ago by pjnneves@…

Cc: pjnneves@… added

Cc Me!

comment:6 in reply to:  4 ; Changed 9 years ago by NicosPavlov

If you had been removed from the cc list, it is because as the reporter of the ticket, you anyway receive answers, so that it is redundant.

Replying to pjnneves@…:

ok, but...any suggestions on how to fix this?

Well, as a matter of fact, no. If I had, I would have done it.
What is surprising is that there are no cmake options at the level of the issue, so that in order to reproduce it, I must comment out parts of the scripts.
Just to be sure, can you indeed reproduce the problem if you try to recompile kdevelop ?

sudo port clean kdevelop
sudo port install kdevelop

comment:7 in reply to:  6 ; Changed 9 years ago by pjnneves@…

Replying to nicos@…:

If you had been removed from the cc list, it is because as the reporter of the ticket, you anyway receive answers, so that it is redundant.

ok, got it!

Replying to nicos@…:

Just to be sure, can you indeed reproduce the problem if you try to recompile kdevelop ?

sudo port clean kdevelop
sudo port install kdevelop

well, I was trying to avoid this, since to compile everything it takes about 24h... :P but ok, I'll do it and see what happens...

comment:8 in reply to:  7 Changed 9 years ago by pjnneves@…

Just recompiled...it actually took a very short time, I guess it didn't need to recompile the dependencies. However, when I tried to start the app in Finder, an error pop-up window appeared saying: "System Configuration Error" and displaying in the window title bar: "Could not find KTextEdit..."

:P

comment:9 Changed 9 years ago by NicosPavlov

Ok. So the issue of this ticket seems solved.

Did you run kbuildsycoca4 as indicated at the end of the build ?

comment:10 in reply to:  9 ; Changed 9 years ago by pjnneves@…

Replying to nicos@…:

Ok. So the issue of this ticket seems solved.

Well, yes...although in a very non-systematic way...

Did you run kbuildsycoca4 as indicated at the end of the build ?

yes and I also ran launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist as is indicated also.

I've tried doing a port search ktextedit but nothing was found, so I really don't know how to proceed from here :P

I also did a port search kdev and noticed that there is a kdevplatform @1.2.3 (kde, kde4)

KDE libraries for IDE programs

Is this necessary to run kdevelop?

comment:11 in reply to:  10 ; Changed 9 years ago by pjnneves@…

found in KDE Community Forums a thread with the same error dialog: "Could not find KTextEditor ::Factory". They recommended to install kate, which I did: kate works, but not kdevelop :P

Help!

comment:12 in reply to:  11 Changed 9 years ago by pjnneves@…

I guess it doesn't know that kate is installed because in Mac OS X kate is an app bundle and therefore it is not located in /opt/local/bin/ but rather in /Applications/MacPorts/. Is there a way to tell a port to search for other apps/libs also in /Applications/MacPorts/ (besides from /opt/local/bin/)? Sort of a classpath envvar for MacPorts? (I searched in MacPorts documentation and could not discover how... :P)

comment:13 in reply to:  10 Changed 9 years ago by NicosPavlov

Replying to pjnneves@…:

Well, yes...although in a very non-systematic way...

True, but according to the information in the ticket, the issue happened once to one user. It is hardly considered a bug, and there is no systematic way to deal with something not reproducible.

Although it is not linked to the previous issue, Kate is indeed a missing dependency of the port, and has been added to the Portfile in r89802. Kbuildsycoca4 must be run again to allow kdevelop to link with it, though.

comment:14 Changed 9 years ago by pjnneves@…

ok, besides kate I have also installed kde4-runtime @4.8.0_0 and kde4-baseapps @4.8.0_0 (another forums thread also mentioned these) and I have run Kbuildsycoca4 again as you indicated.

Now KDevelop starts (yey!), but as soon as it starts an error window appears saying "Process exited with status 0" and the window title bar displays "Process error KDevelop". Also, the it doesn't allow me to define any preferences (the Preferences item in KDevelop menu is dimmed). This happens if I start it by double-clicking it in the finder. If I start it in terminal, the error window does not appear, but the Preferences issue still happens. I'm attaching the terminal output, maybe it helps.

Another issue that I've noticed (don't know if it has any relation to this though) is that the first time I go to the About menu, when I close the about (credits) window, the application also closes. This happens with kate too.

Changed 9 years ago by pjnneves@…

comment:15 Changed 9 years ago by NicosPavlov

Resolution: worksforme
Status: newclosed

I could not find any evidence that kde4-runtime or kde4-baseapps were needed, and after testing, they do not seem to be needed. Are you sure of it ?

The Preferences... and About menu are Mac-specific, and not always available or well integrated on KDE apps. See typically Settings for Kdevelop. Anyway, these issues should be discussed on the mailing list and not on a technical ticket.

Note: See TracTickets for help on using tickets.