Opened 9 years ago

Closed 9 years ago

#33182 closed defect (duplicate)

gtk3: --enable-quartz-backend should replace --with-gdktarget=quartz

Reported by: gui-dos (Guido Soranzio) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: haspatch Cc: singingwolfboy@…
Port: gtk3

Description

The option --with-gdktarget=quartz is not supported by the configure script in Gtk 3 anymore and --enable-quartz-backend should be used instead.

The official OS X version of jhbuild uses the two different options in fact:

  <autotools id="gtk+" autogen-sh="configure"
             autogenargs="--with-gdktarget=quartz --enable-quartz-relocation">
...

  <autotools id="gtk+-3.0" autogen-sh="configure"
             autogenargs="--enable-quartz-backend --enable-quartz-relocation">

<http://git.gnome.org/browse/gtk-osx/tree/modulesets-stable/gtk-osx.modules>

Change History (1)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Keywords: haspatch added; gnome removed
Resolution: duplicate
Status: newclosed

Duplicate of #29063.

Note: See TracTickets for help on using tickets.