Opened 9 years ago

Closed 9 years ago

#33462 closed defect (worksforme)

Mongrel2 needs libranlib

Reported by: robbyt@… Owned by: anddam (Andrea D'Amore)
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc:
Port: mongrel2

Description (last modified by anddam (Andrea D'Amore))

I'm using xcode 4.3, Lion.

Before I can build mongrel2, I need to manually install libranlib. Additionally, I need to run port install mongrel2 twice before the build passes all tests.

Attached first and second builds' output, respectively failing and successful.

Attachments (2)

output_1_failed.txt (111.9 KB) - added by anddam (Andrea D'Amore) 9 years ago.
output_2_success.txt (40.8 KB) - added by anddam (Andrea D'Amore) 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 in reply to:  description Changed 9 years ago by robbyt@…

Clarification, I needed to install libranlib via sudo port install libranlib

comment:2 Changed 9 years ago by raimue (Rainer Müller)

Owner: changed from macports-tickets@… to and.damore@…

Assigning to maintainer.

comment:3 Changed 9 years ago by raimue (Rainer Müller)

Port: mongrel2 added

Changed 9 years ago by anddam (Andrea D'Amore)

Attachment: output_1_failed.txt added

Changed 9 years ago by anddam (Andrea D'Amore)

Attachment: output_2_success.txt added

comment:4 in reply to:  description ; Changed 9 years ago by anddam (Andrea D'Amore)

Description: modified (diff)
Status: newassigned

Replying to robbyt@…:

Before I can build mongrel2, I need to manually install libranlib.

That seems odd to me, libranlib is not ranlib(1), i.e. a libtool alias, it's a library from netlib project to generate random numbers. Also I cannot see any -lranlib reference in build output, nor mine or yours.

Additionally, I need to run port install mongrel2 twice before the build passes all tests.

So you actually can build mongrel2 but have to run install action twice. I assume you are not cleaning between the two runs.

I'll check the issue.

I've attached the content of two pastebins to the ticket to keep all info in one place.

comment:5 in reply to:  4 Changed 9 years ago by robbyt@…

Replying to and.damore@…:

Replying to robbyt@…:

Before I can build mongrel2, I need to manually install libranlib.

That seems odd to me, libranlib is not ranlib(1), i.e. a libtool alias, it's a library from netlib project to generate random numbers. Also I cannot see any -lranlib reference in build output, nor mine or yours.

There is a good chance that I could be wrong about libranlib.

Additionally, I need to run port install mongrel2 twice before the build passes all tests.

So you actually can build mongrel2 but have to run install action twice. I assume you are not cleaning between the two runs.

I'll check the issue.

However, yes I had to install mongrel2 twice (yes, no cleaning between runs)

comment:6 Changed 9 years ago by anddam (Andrea D'Amore)

Resolution: worksforme
Status: assignedclosed

I cannot reproduce, closing as worksforme.

Note: See TracTickets for help on using tickets.