Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#33751 closed defect (worksforme)

sqlite3 3.7.11_0 upgrade breaks subversion's svnversion

Reported by: braden@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc: danielluke (Daniel J. Luke), blair (Blair Zajac), nils.hjelte@…, dmeyer@…, florian@…, drkp (Dan Ports)
Port: sqlite3, subversion

Description

After upgrading from sqlite3 3.7.10_0 to sqlite 3.7.11_0, attempts to use svnversion produce the following error:

$ svnversion my-wc
svn: E200030: sqlite: callback requested query abort
svn: E200030: sqlite: callback requested query abort

Change History (23)

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

  • Cc dluke@… blair@… added
  • Owner changed from macports-tickets@… to mww@…
  • Port subversion added
  • Summary changed from sqlite3 3.7.11_0 upgrade breaks svnversion to sqlite3 3.7.11_0 upgrade breaks subversion's svnversion

comment:2 follow-up: Changed 5 years ago by danielluke (Daniel J. Luke)

I'm not seeing this on my 10.7 box:

% sqlite3 --version 3.7.11 2012-03-20 11:35:50 00bb9c9ce4f465e6ac321ced2a9d0062dc364669 % svnversion macports 91213M

comment:3 in reply to: ↑ 2 Changed 5 years ago by danielluke (Daniel J. Luke)

Replying to dluke@…:

I'm not seeing this on my 10.7 box:

% sqlite3 --version
3.7.11 2012-03-20 11:35:50 00bb9c9ce4f465e6ac321ced2a9d0062dc364669
% svnversion macports
91213M

sorry (WikiFormatting fail)

comment:4 Changed 5 years ago by pixilla (Bradley Giesbrecht)

On OS X 10.6:

$ sqlite3 --version
3.7.11 2012-03-20 11:35:50 00bb9c9ce4f465e6ac321ced2a9d0062dc364669
$ svnversion .
91229M
$ svnversion -q --version
1.7.3

comment:5 Changed 5 years ago by braden@…

I'm using svn 1.7.4 on Mac OS X 10.7. This is quite repeatable for me; that is, reactivating sqlite3 3.7.10_0 resolves the problem; doing the upgrade to 3.7.11_0 breaks it again.

I have tried rebuilding subversion after upgrading sqlite3; but that doesn't help.

comment:6 Changed 5 years ago by nils.hjelte@…

  • Cc nils.hjelte@… added

Cc Me!

comment:7 Changed 5 years ago by dmeyer@…

  • Cc dmeyer@… added

Cc Me!

comment:8 Changed 5 years ago by florian@…

  • Cc florian@… added

Cc Me!

comment:9 Changed 5 years ago by braden@…

Some more poking at this suggests that working copies checked out when using sqlite3 3.7.10_0 exhibit the problem after upgrading to 3.7.11_0. Working copies checked out after upgrading to 3.7.11_0 do not exhibit the problem.

Significantly, a working copy checked out when using sqlite3 3.7.10_0 cannot be "repaired" by using svn up after upgrading to 3.7.11_0.

comment:10 Changed 5 years ago by danielluke (Daniel J. Luke)

My working copy [from the above example] was checked out prior to 3.7.11 and works fine with 3.7.11 now (it's actually a pre-1.7 working copy that was successfully upgrade to the 1.7 wc format with whatever version of sqlite was current at the time...)

So ... there is perhaps some other thing different between your non-working system and my working one.

comment:11 Changed 5 years ago by danielluke (Daniel J. Luke)

have you checked your sqlite3 db?

sqlite3 .svn/wc.db "pragma integrity_check"

comment:12 Changed 5 years ago by braden@…

I've observed the behavior I described on more than one machine, FWIW.

Doing the integrity check you describe comes back with "ok" for a working copy checked out when using sqlite3 3.7.10_0 that no longer works with svnversion.

comment:13 Changed 5 years ago by danielluke (Daniel J. Luke)

I don't know what to say, it works fine for me and for one other macports committer... It's pretty difficult to determine what is going on when we can't reproduce the issue...

comment:14 Changed 5 years ago by florian@…

Please revision-bump port subversion to revision 1. This fixed the issue for me.

comment:15 Changed 5 years ago by danielluke (Daniel J. Luke)

The original reporter says that rebuilding subversion doesn't fix the issue, though.

We've got three scenarios, I guess:

  1. Subversion still working fine (as on my machines and pixilla's)
  2. Subversion not working with sqlite3 3.7.11, but rebuilding fixes it
  3. Subversion not working with sqlite3 3.7.11 but rebuilding does not fix it

comment:16 Changed 5 years ago by drkp (Dan Ports)

  • Cc dports@… added

Cc Me!

comment:17 Changed 5 years ago by drkp (Dan Ports)

I'm seeing the same thing on a working copy that was checked out with an earlier version of sqlite. Integrity check is ok, and rebuilding subversion doesn't seem to fix it either.

comment:18 Changed 5 years ago by drkp (Dan Ports)

Interestingly, this only seems to happen with four out of about 75 working copies I have sitting around; the others work just fine. I don't know what's special about those four...

Unfortunately, one of them is the project I need to be working on right now, so I've reverted to sqlite3 3.7.10 for now. I may be able to take a closer look at what's going on tomorrow.

comment:19 Changed 5 years ago by danh337@…

In case this helps anybody, "svn cleanup" fixed this problem for me.

comment:20 Changed 5 years ago by braden@…

I can confirm that works.

comment:21 Changed 5 years ago by danielluke (Daniel J. Luke)

  • Resolution set to worksforme
  • Status changed from new to closed

comment:22 Changed 5 years ago by blair (Blair Zajac)

Has anybody observed this issue with fresh 1.7 checkouts? I've only seen it with 1.6 checkouts that were upgraded using 'svn upgrade'.

Note: See TracTickets for help on using tickets.