Opened 9 years ago

Closed 9 years ago

#33901 closed defect (fixed)

qtoctave 0.10.1 -- does not create spreadsheet in Tables window

Reported by: cdenman@… Owned by: anddam (Andrea D'Amore)
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: qtoctave, octave, qt4 Cc:
Port: qtoctave-mac

Description (last modified by anddam (Andrea D'Amore))

MacBookPro OSX 10.7.3 Xcode 4.3.2 -- installation process complains that the proper SDK does not exist.

Installation completes and qtoctave runs and appears to correctly work except that when a new variable is created and the variable Table is displayed in its own sub-window the area where the spreadsheet is normally at is only blank white.

When I run qtoctave using Ubuntu, a spreadsheet is displayed in this window and I can paste my variables into the spreadsheet as needed. In qtoctave-mac, since there is no spreadsheet, when I try to paste my variable values into the Tables window, the items are pasted as shown in the command window, but erroneously placed into a "zero" element.

Proper path for SDKs is shown when using Xcode-select commands. I found a suggested patch to fix the "not found SDK" error, but did not know how to apply.

Change History (3)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to and.damore@…

comment:2 in reply to:  1 Changed 9 years ago by cdenman@…

Replying to ryandesign@…: I should have added the comment that the suggested patch was for qt4-mac, since the SDK error occurred during its installation. I had to "clean" and then reinstall -- the second attempt continued through until complete installation. Another keyword might also be to include: qt4-mac

comment:3 Changed 9 years ago by anddam (Andrea D'Amore)

Description: modified (diff)
Resolution: fixed
Status: newclosed

Description rearranged to be more readable.

Replying to cdenman@…:

MacBookPro OSX 10.7.3 Xcode 4.3.2 -- installation process complains that the proper SDK does not exist.

I cannot reproduce this, my build output has no errors. If you want to check this, assuming the complaint is still happening when building, attach a debug ouput using -d option to port command.

Installation completed and qtoctave runs and all appears to work except that when a new variable is created and the variable Table is displayed in its own sub-window the area where the spreadsheet is normally at is only blank white.

You should describe exact steps to reproduce the issue. I created a 2x3 matrix by typing using foo=[1,2,3;4,5,6] in command line field, a foo variable appeared in Variable's List palette and doubleclicking this new row spawns a Table: foo floating window with the behavior you described.

When I run qtoctave using Ubuntu, a spreadsheet is displayed in this window and I can paste my variables into the spreadsheet as needed. In qtoctave-mac, since there is no spreadsheet, when I try to paste my variable values into the Tables window, the items are pasted as shown in the command window, but erroneously placed into a "zero" element.

I cannot reproduce this zero element behavior, I just get empty cell for the local variable in Size column of Variable's List.

Notice that qtoctave development has stopped mainstream.

That said the issue is due to the assumption on type size, fix committed r93257.

Note: See TracTickets for help on using tickets.