Opened 8 years ago

Closed 8 years ago

#34044 closed defect (fixed)

webkit-gtk 1.6.3 fails with ‘is protected within this context' error

Reported by: jovo@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc: dbevans (David B. Evans), jeremyhu (Jeremy Huddleston Sequoia)
Port: webkit-gtk

Description (last modified by ryandesign (Ryan Schmidt))

Upgrade webkit-gtk 1.6.3 results in:

error: ‘static void JSC::AbstractMacroAssembler<AssemblerType>::repatchPointer(JSC::CodeLocationDataLabelPtr, void*) [with AssemblerType = JSC::X86Assembler]’ is protected.

This on intel iMac with OS X 10.5.8. Details in the log attached.

Attachments (2)

main.log (123.3 KB) - added by jovo@… 8 years ago.
2012-04-16 Webkit-gtk.txt (415.8 KB) - added by jovo@… 8 years ago.
Installation using gcc-4.2

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by jovo@…

Attachment: main.log added

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: devans@… jeremyhu@… added; devan@… removed
Description: modified (diff)

comment:2 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Owner: changed from macports-tickets@… to jeremyhu@…
Status: newassigned

I built it just fine on Leopard (i386, x86_64, ppc), but my Leopard is using gcc-4.2. Can you please try:

sudo port -v clean webkit-gtk
sudo port -v install webkit-gtk configure.compiler=gcc-4.2

Changed 8 years ago by jovo@…

Attachment: 2012-04-16 Webkit-gtk.txt added

Installation using gcc-4.2

comment:3 in reply to:  2 ; Changed 8 years ago by jovo@…

Replying to jeremyhu@…:

I built it just fine on Leopard (i386, x86_64, ppc), but my Leopard is using gcc-4.2. Can you please try:

sudo port -v clean webkit-gtk
sudo port -v install webkit-gtk configure.compiler=gcc-4.2

That combination was successful. Attached the clean and installation log. Thanks

comment:4 in reply to:  3 Changed 8 years ago by jovo@…

Replying to jovo@…:

Replying to jeremyhu@…:

I built it just fine on Leopard (i386, x86_64, ppc), but my Leopard is using gcc-4.2. Can you please try:

sudo port -v clean webkit-gtk
sudo port -v install webkit-gtk configure.compiler=gcc-4.2

That combination was successful. Attached the clean and installation log. Thanks

That was a bit too hastily as Gnucash now crashes with:

Dyld Error Message:
  Symbol not found: _UCNV_FROM_U_CALLBACK_SUBSTITUTE_48
  Referenced from: /opt/local/lib/libwebkitgtk-1.0.0.dylib
  Expected in: dynamic lookup

As this is one of my critical applications I once more downgrade to webkit 1.2.7 and recompile Gnucash.

comment:5 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Ok, the gcc issue is addressed with r92056

epiphany ran for me just fine when I tested it earlier, but I forget which box that was on. I do see your symbol issue on my Leopard machine, so I'm looking into it.

comment:6 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Ah, I think the problem is that it's linking against /usr/lib/libicucore.A.dylib instead of ${prefix}/lib/libicuuc.48.dylib

comment:7 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

r92058 fixes the icu bug.

comment:8 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.