Opened 8 years ago

Closed 7 months ago

#34063 closed defect (fixed)

pear-XML_Util- installer/bin/pear: No such file or directory

Reported by: maosmurf (Adam Zielinski) Owned by: pmetzger (Perry E. Metzger)
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc: cooljeanius (Eric Gallager)
Port: pear-XML_Util

Description (last modified by ryandesign (Ryan Schmidt))

sudo port install pear-Archive_Tar

fails with

:debug:configure Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/packagesource" && /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/installer/bin/pear -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/installer/pear.conf -C /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/installer/pear.conf config-set auto_discover 1 
:info:configure sh: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/installer/bin/pear: No such file or directory
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/packagesource" && /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/installer/bin/pear -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/installer/pear.conf -C /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/installer/pear.conf config-set auto_discover 1 " returned error 127
:error:configure Target org.macports.configure returned: shell command failed (see log for details)
:debug:configure Backtrace: shell command failed (see log for details)
    while executing
"$procedure $targetname"
:info:configure Warning: the following items did not execute (for pear-Archive_Tar): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Log for pear-Archive_Tar is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/main.log

the directory /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_pear-Archive_Tar/pear-Archive_Tar/work/Archive_Tar-1.3.7/installer does indeed not contain a directory "bin", only the directory pear, which itself only contains the empty directory "php"

about the sytem:

  • OSX 10.7.3 (all up to date)
  • macports 2.0.4
  • php5 @5.3.10_0+apache2+pear (active) # error also occurs without +pear variant)
  • php5-pear @20110901_2 (active)

PHP cli starts without errors

Attachments (3)

main.log (35.9 KB) - added by maosmurf (Adam Zielinski) 8 years ago.
main.log on installation
main.v2.log (42.4 KB) - added by maosmurf (Adam Zielinski) 8 years ago.
main.log on installation, v2
console.v2.log (1.5 KB) - added by maosmurf (Adam Zielinski) 8 years ago.
console in/output to reproduce error logged to main.v2.log

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by maosmurf (Adam Zielinski)

Attachment: main.log added

main.log on installation

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to pixilla@…
Port: pear-XML_Util added
Summary: pear-Archive_Tar - installer/bin/pear: No such file or directorypear-XML_Util- installer/bin/pear: No such file or directory

The "Skipping completed" lines in the log show this was not a clean build attempt. Please "sudo port clean pear-XML_Util", try again, then attach the new main.log file.

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

Changed 8 years ago by maosmurf (Adam Zielinski)

Attachment: main.v2.log added

main.log on installation, v2

Changed 8 years ago by maosmurf (Adam Zielinski)

Attachment: console.v2.log added

console in/output to reproduce error logged to main.v2.log

comment:3 Changed 8 years ago by maosmurf (Adam Zielinski)

php5-pear (re)installs fine, pear-XML_Util still cannot finish (see console.v2.log to reproduce my steps)

Now I found a new possible source of error

:msg:archivefetch --->  Attempting to fetch pear-XML_Util-1.2.1_0.darwin_11.noarch.tbz2 from http://packages.macports.org/pear-XML_Util
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404

comment:4 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:5 Changed 17 months ago by mf2k (Frank Schima)

Owner: pixilla deleted
Status: newassigned

See #57827

comment:6 Changed 7 months ago by pmetzger (Perry E. Metzger)

Owner: set to pmetzger
Resolution: fixed
Status: assignedclosed

In a161124315ae59e99481271f6b087b4e42b3d527/macports-ports (master):

Remove PHP PEAR modules and PortGroup

Per https://github.com/macports/macports-ports/pull/4192, which after
nine months received no objections. Manually committed because of
merge conflicts.

Closes: #56424
Closes: #34063
Closes: #35228
Closes: #37119
Closes: #37524
Closes: #37683
Closes: #38910
Closes: #39869
Closes: #46688
Closes: #53510
Closes: #53632
Closes: #57316
Closes: #57318
Closes: #57320
Closes: #57321
See: #54839

Note: See TracTickets for help on using tickets.