New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #34089 (closed defect: fixed)

Opened 2 years ago

Last modified 17 months ago

php5-magickwand 1.0.9 fails due to missing reference.

Reported by: ldl@… Owned by: ryandesign@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc:
Port: php5-magickwand

Description (last modified by ryandesign@…) (diff)

  • OS 10.6.8 Snow Leopard
  • Port Authority 4.1.0
  • php5 @5.3.10
  • ImageMagick @6.7.6-0
  • php5-magickwand @1.0.9

Everything compiles properly: Apache, PHP 5.3, extensions. Repeated update all and cleaning shows no errors.

On Apache launch the following in the PHP Error Log:

[16-Apr-2012 22:52:17 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/local/lib/php/extensions/no-debug-non-zts-20090626/magickwand.so' - dlopen(/opt/local/lib/php/extensions/no-debug-non-zts-20090626/magickwand.so, 9): Symbol not found: _zif_magicksetimageendian
  Referenced from: /opt/local/lib/php/extensions/no-debug-non-zts-20090626/magickwand.so
  Expected in: flat namespace
 in /opt/local/lib/php/extensions/no-debug-non-zts-20090626/magickwand.so in Unknown on line 0

The extension is there but the problem is in "Symbol not found: _zif_magicksetimageendian"

Googling reveals this to be a known, recent problem:

"As far I am concerned MagickWandForPHP 1.0.9 is broken -> fails to compile."

Change History

comment:1 follow-up: ↓ 2 Changed 2 years ago by ryandesign@…

  • Cc ryandesign@… added
  • Description modified (diff)

comment:2 in reply to: ↑ 1 Changed 2 years ago by ldl@…

Replying to ryandesign@…:

If I read the recent change (last link in the post) right, someone commented out the function in question for whatever reason.

Might be that uncommenting the function will return it so the compile will find the reference.

But that all has to do with ImageMagick's pile of problems, which are outside my fence.

comment:3 follow-up: ↓ 4 Changed 2 years ago by ryandesign@…

I think it's outside our fence too, since (as you point out with your links above) the problem is not MacPorts-specific. You should work with the developers of MagickWand for PHP and/or ImageMagick to fix this; once it's fixed, we'll be happy to update the MacPorts php5-magickwand port with the fix.

comment:4 in reply to: ↑ 3 Changed 2 years ago by ldl@…

Replying to ryandesign@…:

I think it's outside our fence too, since (as you point out with your links above) the problem is not MacPorts-specific. You should work with the developers of MagickWand for PHP and/or ImageMagick to fix this; once it's fixed, we'll be happy to update the MacPorts php5-magickwand port with the fix.

I would hope they are aware of it. Do you concur that the last mode registered commented out the code? I don't read that language well.

If so, I'd be tempted to Un-Comment it in my source (behind your back) and do an update and see if that would not solve the problem for the time being. I don't see what would be wrong with doing that in the interim just to get everything to work.

Is there any down-side you can see from your perspective?

I live life up a level at my PHP in Drupal.

comment:5 Changed 2 years ago by ryandesign@…

I don't have an opinion on what a likely fix for the issue would be, and defer to the developers of the respective software.

comment:6 follow-up: ↓ 7 Changed 2 years ago by ryandesign@…

According to this post the problem is fixed in ImageMagick 6.7.7-1. I updated ImageMagick to 6.7.7-2 in r93683 and the problem with php-magickwand remains, even if I rebuild it.

comment:7 in reply to: ↑ 6 Changed 21 months ago by pixilla@…

Replying to ryandesign@…:

According to this post the problem is fixed in ImageMagick 6.7.7-1. I updated ImageMagick to 6.7.7-2 in r93683 and the problem with php-magickwand remains, even if I rebuild it.

IM v6.7.8-4 still has this problem.

comment:8 Changed 21 months ago by jmr@…

  • Cc ryandesign@… removed
  • Owner changed from macports-tickets@… to ryandesign@…

comment:9 Changed 17 months ago by ryandesign@…

  • Status changed from new to closed
  • Keywords ImageMagick, Magickwand removed
  • Resolution set to fixed

The developers of php-magickwand performed a stealth update in October which fixed this. Updated port in r100011.

Note: See TracTickets for help on using tickets.