Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#34102 closed defect (invalid)

configure: error: Could not find a working Foundation implementation

Reported by: cquiter@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.0.4
Keywords: Cc: cooljeanius (Eric Gallager)
Port:

Description (last modified by ryandesign (Ryan Schmidt))

Craigs-MacBook-Pro:MacPorts-2.0.4 cquiter$ ./configure
checking build system type... x86_64-apple-darwin11.3.0
checking host system type... x86_64-apple-darwin11.3.0
checking target system type... x86_64-apple-darwin11.3.0
checking MacPorts version... 2.0.4
checking for sw_vers... /usr/bin/sw_vers
checking for defaults... /usr/bin/defaults
checking for xcode-select... /usr/bin/xcode-select
checking Mac OS X version... 10.7.3
checking Xcode location... /
checking Xcode version... 4.3.2
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for gcc... gcc
checking whether we are using the GNU Objective C compiler... yes
checking whether gcc accepts -g... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets $(MAKE)... yes
checking whether ln -s works... yes
checking for mtree... /usr/sbin/mtree
checking for chown... /usr/sbin/chown
checking for cp... /bin/cp
checking for cpio... /usr/bin/cpio
checking for diff... /usr/bin/diff
checking for dscl... /usr/bin/dscl
checking for dseditgroup... /usr/sbin/dseditgroup
checking for file... /usr/bin/file
checking for bzr... no
checking for cvs... /usr/bin/cvs
checking for svn... /usr/bin/svn
checking for git... /usr/bin/git
checking for hg... no
checking for gzip... /usr/bin/gzip
checking for lipo... /usr/bin/lipo
checking for patch... /usr/bin/patch
checking for rmdir... /bin/rmdir
checking for rsync... /usr/bin/rsync
checking for openssl... /usr/bin/openssl
checking for sed... /usr/bin/sed
checking for tar... /usr/bin/tar
checking for unzip... /usr/bin/unzip
checking for zip... /usr/bin/zip
checking for bsdmake... /usr/bin/bsdmake
checking for make... /usr/bin/make
checking for hdiutil... /usr/bin/hdiutil
checking for launchd... yes
checking for launchctl... /bin/launchctl
checking for xcodebuild... /usr/bin/xcodebuild
checking for gnutar... /usr/bin/gnutar
checking for gnumake... /usr/bin/gnumake
checking for gnupatch... no
checking for gpatch... no
checking for bzip2... /usr/bin/bzip2
checking for lzma... no
checking for xz... no
checking for lsbom... /usr/bin/lsbom
checking for mkbom... /usr/bin/mkbom
checking for pax... /bin/pax
checking for xar... /usr/bin/xar
checking for open... /usr/bin/open
checking for sed... (cached) /usr/bin/sed
checking which sed flag to use for extended regexp... -E (BSD)
checking for tar... (cached) /usr/bin/tar
checking whether tar supports -q... yes (bsdtar)
checking for tar... (cached) /usr/bin/tar
checking for gnutar... (cached) /usr/bin/gnutar
checking for which tar variant to use... /usr/bin/gnutar
checking for /usr/bin/gnutar --no-same-owner support... yes
checking for patch... (cached) /usr/bin/patch
checking for gpatch... no
checking for GNU (FSF) patch... /usr/bin/patch
checking how to mark unused variables... 
checking for gcc symbol visibility attribute... __attribute__((visibility("hidden")))
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... -D_THREAD_SAFE
checking how to run the Objective C preprocessor... gcc -E
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking objc/objc.h usability... yes
checking objc/objc.h presence... yes
checking for objc/objc.h... yes
checking if linking libobjc requires pthreads... no
checking for Apple Objective-C runtime... yes
checking for GNU Objective C runtime... no
configure: Using Apple Objective-C runtime
checking for Apple Foundation library... no
configure: WARNING: GNUSTEP_SYSTEM_ROOT is not defined in your environment, preventing the use of GNUstep's Foundation library
configure: error: Could not find a working Foundation implementation

Attachments (1)

config.log (29.4 KB) - added by cquiter@… 7 years ago.
config.log

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by cquiter@…

Attachment: config.log added

config.log

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Component: portsbase
Description: modified (diff)
Summary: Error on build, please help. configure: error: Could not find a working Foundation implementationconfigure: error: Could not find a working Foundation implementation

Please remember to use WikiFormatting.

"Could not find a working Foundation implementation" has been reported to us a couple times before (#28452, #30298) but we were never able to find out why it happened.

Do you have anything in /usr/local? If so, that might be interfering; try moving it aside.

Do you have /System/Library/Frameworks/Foundation.framework? Do you have /System/Library/Frameworks/Foundation.framework/Headers/Foundation.h? If not, reinstall OS X.

Compiling MacPorts manually should of course work, but out of curiosity, why do you want to do so instead of using our pre-made disk images?

Since we are about to release MacPorts 2.1.0, you could also test whether version 2.1.0 beta 1 works better, but I don't recall us making any changes with regard to this configure check so I doubt it.

comment:2 in reply to:  1 Changed 7 years ago by cquiter@…

Thanks, I looked at (#28452, #30298) but noticed they had other errors in their config.log that I don't have. I tried moving /usr/local then building as well as installing with the disk image, but no luck.

Installing with the disk image causes a bash process to run at 33% CPU for at least an hour until I reboot the system.

I should note that MacPorts installed correctly and started acting up only after I tried to install python bindings for opencv. I tried to reinstall. Then I tried to uninstall/reinstall. However, I get the same result. I also tried removing MacPorts from the .profile.

I tried installing the 2.1.0 .pkg and the package says it installs (no CPU problems) but when I use port I get errors about /opt/local/etc/macports files. After copying defaults I get:

Craigs-MacBook-Pro:~ cquiter$ port
Warning: No index(es) found! Have you synced your source indexes?
port registry doesn't exist at "/opt/local/var/macports/registry/registry.db" and couldn't write to this location
    while executing
"registry::open $db_path"
    (procedure "mportinit" line 633)
    invoked from within
"mportinit ui_options global_options global_variations"
Error: /opt/local/bin/port: Failed to initialize MacPorts, port registry doesn't exist at "/opt/local/var/macports/registry/registry.db" and couldn't write to this location

I get the same error about the Foundation implementation when building 2.1.0-beta1.

Also, I have Foundation.framework but not Foundation.h. Reinstall OS X, really?!

Replying to ryandesign@…:

Please remember to use WikiFormatting.

"Could not find a working Foundation implementation" has been reported to us a couple times before (#28452, #30298) but we were never able to find out why it happened.

Do you have anything in /usr/local? If so, that might be interfering; try moving it aside.

Do you have /System/Library/Frameworks/Foundation.framework? Do you have /System/Library/Frameworks/Foundation.framework/Headers/Foundation.h? If not, reinstall OS X.

Compiling MacPorts manually should of course work, but out of curiosity, why do you want to do so instead of using our pre-made disk images?

Since we are about to release MacPorts 2.1.0, you could also test whether version 2.1.0 beta 1 works better, but I don't recall us making any changes with regard to this configure check so I doubt it.

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

It is normal for the installer to run a shell process at the end, to download and index the portfiles (we call this "sync"); if something went wrong with sync, it's possible this could account for the excessive CPU use and stalled install. Nevertheless, MacPorts should at that point be installed, albeit the portfiles might not be downloaded or indexed. If you show the installer log window, it might give you hints about what's going wrong.

Alternately, run "sudo port -v sync" on the command line.

Foundation.framework is a necessary part of OS X; if it's missing parts, then you should fix this, either by restoring a correct copy from your backups or by reinstalling OS X.

comment:4 Changed 7 years ago by cquiter@…

So, I basically got things working again. It's hard to say what the root cause was, but here's a basic rundown of what I did.

Reinstall OSX to get rid of bash hang - still no Framework.h

Install command line tools from https://developer.apple.com/downloads/index.action since installing through Xcode caused invalid checksum.

I had installed the OSX gcc installer as well, which may have been causing problems.

uninstall all: sudo port -fp uninstall --follow-dependents installed
clean all: sudo port clean all

I would recommend new users not install the osx gcc standalone product. Just go with Xcode and the command line tools. Initially, I hadn't used the command line tools and things seemed to work okay until I tried to install opencv.

run xcode-select -switch /Applications/Xcode.app/Contents/Developer/

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

What is "the osx gcc standalone product"?

comment:7 Changed 7 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed

So there's nothing wrong with MacPorts here; Foundation.h really was missing and the Xcode location was set to / which makes xcodebuild hang.

comment:8 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:9 Changed 4 years ago by geoff.fellows@…

If you get the above errors when compiling Macports for Yosemite try this
If not using XCode download Command-line tools from https://developer.apple.com/xcode/downloads/ then

xcode-select -r

to reset the path to the command-line tools path to /Library/Developer/CommandLineTools

Note: See TracTickets for help on using tickets.