Opened 7 years ago

Closed 6 years ago

#34108 closed defect (invalid)

python27: error: 'AE/AE.h' file not found

Reported by: fallbaby@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc:
Port: python27

Description (last modified by ryandesign (Ryan Schmidt))

Using lion 10.7.3 and Xcode 4.3.2

Error once it gets to Building python27. Saw a similar ticket that solved the problem by using

$ sudo port clean python27

This hasn't worked for me though. Originally encountered the error as a part of porting ImageMagick, where I got the

Warning: xcodebuild exists but failed to execute

and used

sudo xcode-select -switch /Applications/Xcode.app

which seemed to have corrected that error.

Attachments (1)

main.log (150.2 KB) - added by fallbaby@… 7 years ago.
log

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by fallbaby@…

Attachment: main.log added

log

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to jwa@…
Port: python27 added; Python27 removed
Summary: Python27 Build errorpython27: error: 'AE/AE.h' file not found

comment:2 Changed 7 years ago by jmroot (Joshua Root)

Do you in fact have /System/Library/Frameworks/CoreServices.framework/Frameworks/AE.framework/Headers/AE.h? If your CoreServices header is referencing it, it ought to exist.

comment:3 Changed 6 years ago by taoyge@…

got this same error, then installed xcode command line tools in xcode (Preferences -> Downloads -> Command Line Tools) and problem went away.

comment:4 Changed 6 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed

Closing due to comment 3. No response from the reporter anyway.

Note: See TracTickets for help on using tickets.