New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #34321 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

VLC @2.0.1 error: cannot find interface declaration

Reported by: nonstop.server@… Owned by: jeremyhu@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc: jeremyhu@…
Port: VLC

Description

First of all I would like to express my gratitude for upgrading this port to the latest version, thank you!
Secondly I would like to acknowledge that the upgrade from version 1.0.6 to 2.0.1 worked flawlessly on OSX 10.6 and 10.7.
Both audio and video are working correctly with the latest version.

When upgrading the port on OSX 10.5 from version 1.0.6 to 2.0.1 it fails with the following error message:

  OBJC     qtsound.lo
<command line>:1:23: warning: ISO C99 requires whitespace after the macro name
qtsound.m:74: error: cannot find interface declaration for 'QTCaptureDecompressedAudioOutput', superclass of 'VLCDecompressedAudioOutput'
qtsound.m:94: error: cannot find interface declaration for 'QTCaptureDecompressedAudioOutput', superclass of 'VLCDecompressedAudioOutput'
qtsound.m: In function '-[VLCDecompressedAudioOutput initWithDemux:]':
qtsound.m:97: error: no super class declared in @interface for 'VLCDecompressedAudioOutput'
qtsound.m: In function '-[VLCDecompressedAudioOutput dealloc]':
qtsound.m:110: error: no super class declared in @interface for 'VLCDecompressedAudioOutput'
qtsound.m: In function 'Open':
qtsound.m:347: warning: 'VLCDecompressedAudioOutput' may not respond to '+alloc'
qtsound.m:347: warning: (Messages without a matching method signature
qtsound.m:347: warning: will be assumed to return 'id' and accept
qtsound.m:347: warning: '...' as arguments.)
qtcapture.m: In function 'Open':
qtcapture.m:362: warning: 'VLCDecompressedVideoOutput' may not respond to '-setAutomaticallyDropsLateVideoFrames:'
qtcapture.m:362: warning: (Messages without a matching method signature
qtcapture.m:362: warning: will be assumed to return 'id' and accept
qtsound.m:482: warning: passing argument 1 of 'addOutput:error:' from distinct Objective-C type
qtcapture.m:362: warning: '...' as arguments.)
qtcapture.m:363: warning: 'VLCDecompressedVideoOutput' may not respond to '-setMinimumVideoFrameInterval:'
qtsound.m: In function 'Close':
qtsound.m:528: warning: 'VLCDecompressedAudioOutput' may not respond to '-performSelectorOnMainThread:withObject:waitUntilDone:'
qtcapture.m: In function 'Close':
qtcapture.m:411: warning: 'vlc_object_alive' is deprecated (declared at ../../include/vlc_objects.h:82)
make[5]: *** [qtsound.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
make[5]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.1/modules/access'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.1/modules/access'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.1/modules/access'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.1/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.1'
make: *** [all] Error 2
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.1'
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.1"
&& /usr/bin/make -j2 -w all DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.1/dest_ignore"
returned error 2
Error: Target org.macports.build returned: shell command failed (see log for details)
DEBUG: Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for VLC): org.macports.install org.macports.build org.macports.destroot
Log for VLC is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/main.log

See the attached log for additional information.
Version Information:

Mac OS Version:
Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386

Xcode Version:
Xcode 3.1.4
Component versions: DevToolsCore-1204.0; DevToolsSupport-1186.0
BuildVersion: 9M2809

Macports Version:
Version: 2.0.4

Attachments

main.log (177.5 KB) - added by nonstop.server@… 2 years ago.

Change History

Changed 2 years ago by nonstop.server@…

comment:1 Changed 2 years ago by jeremyhu@…

  • Status changed from new to assigned
  • Owner changed from macports-tickets@… to jeremyhu@…

Hmm. I built it on my Leopard machine (but admittedly didn't actually run it there).

VLC is not universal, so I only tested x86_64. It looks like the failure here is i386. I'll try rebuilding it as i386 (and might as well see about making it universal while I'm at it) to reproduce this.

comment:2 Changed 2 years ago by jeremyhu@…

Oh fail. What I tested building on my Leopard box was 1.0.6 ... sigh.

comment:3 follow-up: ↓ 4 Changed 2 years ago by jeremyhu@…

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:4 in reply to: ↑ 3 Changed 2 years ago by nonstop.server@…

Replying to jeremyhu@…:

r92694

The upgrade of VLC went smoothly on OSX 10.5 and the program is working perfect.
Thanks again for all your hard work on this port!

Note: See TracTickets for help on using tickets.