Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#34473 closed defect (invalid)

php5: checksum mismatch because HTML file

Reported by: charles@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.0
Keywords: Cc: ryandesign (Ryan Schmidt), jyrkiwahlstedt
Port: php5

Description (last modified by neverpanic (Clemens Lang))

Log:

:error:checksum Checksum (rmd160) mismatch for php-5.3.12.tar.bz2
:info:checksum Portfile checksum: php-5.3.12.tar.bz2 rmd160 5d91c2d16b54632aa123677f63776b312872997c
:info:checksum Distfile checksum: php-5.3.12.tar.bz2 rmd160 5aed4ca1702c326beb84c253de892a069ca8dcbc
:error:checksum Checksum (sha256) mismatch for php-5.3.12.tar.bz2
:info:checksum Portfile checksum: php-5.3.12.tar.bz2 sha256 91659fd645b03011e1620134fa2457fade1e502499111cef8c4e23f428ad16ac
:info:checksum Distfile checksum: php-5.3.12.tar.bz2 sha256 fa486cb09284c6814c8c6a7f02929cc545d13e4e31daa401bab02c95a90485ca
:info:checksum The correct checksum line may be:
:info:checksum checksums           rmd160  5aed4ca1702c326beb84c253de892a069ca8dcbc \
                    sha256  fa486cb09284c6814c8c6a7f02929cc545d13e4e31daa401bab02c95a90485ca
:notice:checksum ***
:notice:checksum The non-matching file appears to be HTML. See this page for possible reasons
:notice:checksum for the checksum mismatch:
:notice:checksum <https://trac.macports.org/wiki/MisbehavingServers>
:notice:checksum ***
:error:checksum org.macports.checksum for port php5 returned: Unable to verify file checksums
:debug:checksum Error code: NONE
:debug:checksum Backtrace: Unable to verify file checksums
    while executing

Attempting to access http://packages.macports.org/php5 with curl yields:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /php5 was not found on this server.</p>
</body></html>

Change History (2)

comment:1 Changed 7 years ago by neverpanic (Clemens Lang)

Cc: ryandesign@… jwa@… added
Description: modified (diff)
Resolution: invalid
Status: newclosed

Please remember to use WikiFormatting, preview your post and Cc the maintainer.

http://packages.macports.org/php5 is not the URL the tarball was downloaded from, but rather the URL where port(1) tries to find pre-built binaries. Since there aren't any for the php5 port MacPorts will fall back to building from source and starts downloading the source tarball, which apparently fails for you. The file you got instead of the source tarball appears to be HTML, which is commonly caused by misconfigured DNS servers or mirrors. See MisbehavingServers for some pointers on what to do in those cases.

Also, this bug report is useless without the main.log, so please attach it, if you can. Feel free to re-open if the problem persists and you can provide a main.log.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Summary: php5 port brokenphp5: checksum mismatch because HTML file

I do see that one of the servers in the php fetch group—id.php.net—does not resolve to an IP address; if you have a "helpful" DNS server, then this unresolvable server address could account for the problem. I updated the php fetch group to use a different Indonesian mirror in r93160. Please "sudo port clean --all php5", then "sudo port selfupdate", then try again.

Note: See TracTickets for help on using tickets.