Opened 9 years ago

Closed 8 years ago

#34599 closed defect (fixed)

evolution-data-server fails to autoreconf with automake-1.12

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: jim@…
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: Cc: dbevans (David B. Evans), jeremyhu (Jeremy Huddleston Sequoia), alexeiz@…, trog24 (Frank J. R. Hanstick), mww@…
Port: evolution-data-server

Description

After the upgrade to automake-1.12, evolution-data-server fails to build with automake errors:

...
autoreconf: running: /opt/local/bin/autoconf --force
autoreconf: running: /opt/local/bin/autoheader --force
autoreconf: running: automake --add-missing --copy --force-missing
automake: warnings are treated as errors
Makefile.am:15: warning: '%'-style pattern rules are a GNU make extension
Makefile.am:21: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendfile.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/file/Makefile.am:1:   while processing Libtool library 'libebookbackendfile.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendgoogle.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/google/Makefile.am:1:   while processing Libtool library 'libebookbackendgoogle.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendgroupwise.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/groupwise/Makefile.am:1:   while processing Libtool library 'libebookbackendgroupwise.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendldap.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/ldap/Makefile.am:1:   while processing Libtool library 'libebookbackendldap.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendvcf.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/vcf/Makefile.am:1:   while processing Libtool library 'libebookbackendvcf.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendwebdav.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/webdav/Makefile.am:1:   while processing Libtool library 'libebookbackendwebdav.la'
addressbook/libebook/Makefile.am:55: warning: '%'-style pattern rules are a GNU make extension
addressbook/libebook/Makefile.am:65: warning: '%'-style pattern rules are a GNU make extension
addressbook/libebook/Makefile.am:66: warning: subst -,_,$*: non-POSIX variable name
addressbook/libebook/Makefile.am:66: (probably a GNU make extension)
addressbook/libebook/Makefile.am:72: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebook-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/libebook/Makefile.am:6:   while processing Libtool library 'libebook-1.2.la'
addressbook/libedata-book/Makefile.am:2: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:3: warning: subst -,_,$*: non-POSIX variable name
addressbook/libedata-book/Makefile.am:3: (probably a GNU make extension)
glib-gen.mak:9: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:13: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:18: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:26: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:38: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:41: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
addressbook/libedata-book/Makefile.am:86: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:101: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libedata-book-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/libedata-book/Makefile.am:13:   while processing Libtool library 'libedata-book-1.2.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebook-test-utils.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/tests/ebook/Makefile.am:1:   while processing Libtool library 'libebook-test-utils.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendcaldav.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/caldav/Makefile.am:1:   while processing Libtool library 'libecalbackendcaldav.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendcontacts.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/contacts/Makefile.am:1:   while processing Libtool library 'libecalbackendcontacts.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendfile.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/file/Makefile.am:1:   while processing Libtool library 'libecalbackendfile.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendgoogle.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/google/Makefile.am:1:   while processing Libtool library 'libecalbackendgoogle.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendgroupwise.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/groupwise/Makefile.am:1:   while processing Libtool library 'libecalbackendgroupwise.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendhttp.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/http/Makefile.am:1:   while processing Libtool library 'libecalbackendhttp.la'
calendar/backends/weather/Makefile.am:44: warning: '%'-style pattern rules are a GNU make extension
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendweather.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/weather/Makefile.am:1:   while processing Libtool library 'libecalbackendweather.la'
calendar/libecal/Makefile.am:53: warning: '%'-style pattern rules are a GNU make extension
calendar/libecal/Makefile.am:61: warning: '%'-style pattern rules are a GNU make extension
calendar/libecal/Makefile.am:62: warning: subst -,_,$*: non-POSIX variable name
calendar/libecal/Makefile.am:62: (probably a GNU make extension)
calendar/libecal/Makefile.am:68: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecal-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/libecal/Makefile.am:6:   while processing Libtool library 'libecal-1.2.la'
calendar/libedata-cal/Makefile.am:5: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:6: warning: subst -,_,$*: non-POSIX variable name
calendar/libedata-cal/Makefile.am:6: (probably a GNU make extension)
glib-gen.mak:9: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:13: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:18: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:26: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:38: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:41: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
calendar/libedata-cal/Makefile.am:71: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:86: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libedata-cal-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/libedata-cal/Makefile.am:16:   while processing Libtool library 'libedata-cal-1.2.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecal-test-utils.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/tests/ecal/Makefile.am:1:   while processing Libtool library 'libecal-test-utils.la'
camel/Makefile.am:17: warning: '%'-style pattern rules are a GNU make extension
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamel-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/Makefile.am:30:   while processing Libtool library 'libcamel-1.2.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamel-provider-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/Makefile.am:30:   while processing Libtool library 'libcamel-provider-1.2.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelgroupwise.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/groupwise/Makefile.am:1:   while processing Libtool library 'libcamelgroupwise.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelhula.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/hula/Makefile.am:1:   while processing Libtool library 'libcamelhula.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelimap.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/imap/Makefile.am:1:   while processing Libtool library 'libcamelimap.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelimap4.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/imap4/Makefile.am:1:   while processing Libtool library 'libcamelimap4.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelimapx.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/imapx/Makefile.am:1:   while processing Libtool library 'libcamelimapx.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamellocal.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/local/Makefile.am:1:   while processing Libtool library 'libcamellocal.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelnntp.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/nntp/Makefile.am:1:   while processing Libtool library 'libcamelnntp.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelpop3.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/pop3/Makefile.am:1:   while processing Libtool library 'libcamelpop3.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelsendmail.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/sendmail/Makefile.am:1:   while processing Libtool library 'libcamelsendmail.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelsmtp.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/smtp/Makefile.am:1:   while processing Libtool library 'libcamelsmtp.la'
/opt/local/share/automake-1.12/am/library.am: warning: 'libcameltest-provider.a': linking libraries using a non-POSIX
/opt/local/share/automake-1.12/am/library.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/tests/lib/Makefile.am:1:   while processing library 'libcameltest-provider.a'
/opt/local/share/automake-1.12/am/library.am: warning: 'libcameltest.a': linking libraries using a non-POSIX
/opt/local/share/automake-1.12/am/library.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/tests/lib/Makefile.am:1:   while processing library 'libcameltest.a'
libebackend/Makefile.am:35: warning: '%'-style pattern rules are a GNU make extension
libebackend/Makefile.am:41: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebackend-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
libebackend/Makefile.am:1:   while processing Libtool library 'libebackend-1.2.la'
libedataserver/Makefile.am:91: warning: '%'-style pattern rules are a GNU make extension
libedataserver/Makefile.am:97: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libedataserver-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
libedataserver/Makefile.am:1:   while processing Libtool library 'libedataserver-1.2.la'
libedataserverui/Makefile.am:108: warning: '%'-style pattern rules are a GNU make extension
libedataserverui/Makefile.am:118: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libedataserverui-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
libedataserverui/Makefile.am:5:   while processing Libtool library 'libedataserverui-1.2.la'
servers/google/libgdata-google/Makefile.am:27: warning: '%'-style pattern rules are a GNU make extension
servers/google/libgdata-google/Makefile.am:33: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libgdata-google-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
servers/google/libgdata-google/Makefile.am:1:   while processing Libtool library 'libgdata-google-1.2.la'
servers/google/libgdata/Makefile.am:31: warning: '%'-style pattern rules are a GNU make extension
servers/google/libgdata/Makefile.am:37: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libgdata-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
servers/google/libgdata/Makefile.am:1:   while processing Libtool library 'libgdata-1.2.la'
servers/groupwise/Makefile.am:85: warning: '%'-style pattern rules are a GNU make extension
servers/groupwise/Makefile.am:91: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libegroupwise-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
servers/groupwise/Makefile.am:32:   while processing Libtool library 'libegroupwise-1.2.la'
autoreconf: automake failed with exit status: 1

It looks like automake-1.12 starts treating warnings as errors by default...

Attachments (1)

main.log (148.6 KB) - added by trog24 (Frank J. R. Hanstick) 9 years ago.
Failed build log.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Cc: devans@… jeremyhu@… added

comment:2 Changed 9 years ago by alexeiz@…

Cc: alexeiz@… added

Cc Me!

comment:3 in reply to:  2 Changed 9 years ago by alexeiz@…

Reverting to automake 1.11.5 makes possible to build evolution-data-server.

comment:5 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

patchwork shows it better: http://patches.openembedded.org/patch/28383/

but the submitter said to ignore as it's incomplete. You should probably check that list or followup with the submitter for the fix if it's not yet in git...

comment:6 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Has dupe #34825

comment:7 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Workaround pushed: r94167

comment:8 Changed 9 years ago by trog24 (Frank J. R. Hanstick)

Cc: trog24@… added

Cc Me!

comment:9 Changed 9 years ago by trog24 (Frank J. R. Hanstick)

The same failure resulted after:

--->  Computing dependencies for evolution-data-server
--->  Cleaning evolution-data-server
--->  Unable to uninstall evolution-data-server @2.30.3_2, the following ports depend on it:
--->  	gnome-panel @2.30.2_3+python27
--->  	gnome-panel @2.30.2_4+python27
--->  	gnome-panel @2.30.2_5+python27
Warning: Uninstall forced.  Proceeding despite dependencies.
--->  Deactivating evolution-data-server @2.30.3_2
--->  Unable to deactivate evolution-data-server @2.30.3_2, the following ports depend on it:
--->  	gnome-panel @2.30.2_5+python27
Warning: Deactivate forced.  Proceeding despite dependencies.
--->  Cleaning evolution-data-server
--->  Uninstalling evolution-data-server @2.30.3_2
--->  Cleaning evolution-data-server
--->  Computing dependencies for evolution-data-server
--->  Fetching distfiles for evolution-data-server
--->  Verifying checksum(s) for evolution-data-server
--->  Extracting evolution-data-server
--->  Applying patches to evolution-data-server
--->  Configuring evolution-data-server
Error: org.macports.configure for port evolution-data-server returned: autoreconf failure: command execution failed
Please see the log file for port evolution-data-server for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_evolution-data-server/evolution-data-server/main.log

comment:10 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Well it builds here. Make sure you actually *have* the change, and if you do, please:

sudo port -v clean evolution-data-server
sudo port -v install evolution-data-server

Then attach the log file that is referenced.

comment:11 Changed 9 years ago by trog24 (Frank J. R. Hanstick)

The run:

Franks-Power-Mac-G4:~ frank$ sudo port -v clean evolution-data-server
Password:
--->  Cleaning evolution-data-server
--->  Removing work directory for evolution-data-server
Franks-Power-Mac-G4:~ frank$ sudo port -v install evolution-data-server
--->  Computing dependencies for evolution-data-server.
--->  Fetching archive for evolution-data-server
--->  evolution-data-server-2.30.3_2.darwin_9.ppc.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/verified
--->  Attempting to fetch evolution-data-server-2.30.3_2.darwin_9.ppc.tbz2 from http://packages.macports.org/evolution-data-server
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
--->  Fetching distfiles for evolution-data-server
--->  Verifying checksum(s) for evolution-data-server
--->  Checksumming evolution-data-server-2.30.3.tar.bz2
--->  Extracting evolution-data-server
--->  Extracting evolution-data-server-2.30.3.tar.bz2
--->  Applying patches to evolution-data-server
--->  Applying patch-configure.ac.diff
patching file configure.ac
--->  Applying patch-m4-evo_krb5_support.m4.diff
patching file m4/evo_krb5_support.m4
--->  Configuring evolution-data-server
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4
/opt/local/share/aclocal/gtkglextmm-1.2.m4:225: warning: underquoted definition of AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD
/opt/local/share/aclocal/gtkglextmm-1.2.m4:225:   run info Automake 'Extending aclocal'
/opt/local/share/aclocal/gtkglextmm-1.2.m4:225:   or see http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
configure.ac:234: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2661: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2678: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1022: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:4161: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5236: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:138: _LT_SETUP is expanded from...
m4/libtool.m4:67: LT_INIT is expanded from...
configure.ac:234: the top level
configure.ac:234: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2661: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2678: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:4161: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5236: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:138: _LT_SETUP is expanded from...
m4/libtool.m4:67: LT_INIT is expanded from...
configure.ac:234: the top level
autoreconf: configure.ac: tracing
configure.ac:234: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2661: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2678: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:1022: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:4161: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5236: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:138: _LT_SETUP is expanded from...
m4/libtool.m4:67: LT_INIT is expanded from...
configure.ac:234: the top level
configure.ac:234: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2661: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2678: AC_LINK_IFELSE is expanded from...
m4/libtool.m4:4161: _LT_LINKER_SHLIBS is expanded from...
m4/libtool.m4:5236: _LT_LANG_C_CONFIG is expanded from...
m4/libtool.m4:138: _LT_SETUP is expanded from...
m4/libtool.m4:67: LT_INIT is expanded from...
configure.ac:234: the top level
autoreconf: running: glibtoolize --copy --force
glibtoolize: putting auxiliary files in `.'.
glibtoolize: copying file `./ltmain.sh'
glibtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
glibtoolize: copying file `m4/libtool.m4'
glibtoolize: copying file `m4/ltoptions.m4'
glibtoolize: copying file `m4/ltsugar.m4'
glibtoolize: copying file `m4/ltversion.m4'
glibtoolize: copying file `m4/lt~obsolete.m4'
/opt/local/share/aclocal/gtkglextmm-1.2.m4:225: warning: underquoted definition of AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD
/opt/local/share/aclocal/gtkglextmm-1.2.m4:225:   run info Automake 'Extending aclocal'
/opt/local/share/aclocal/gtkglextmm-1.2.m4:225:   or see http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
autoreconf: running: /opt/local/bin/autoconf --force
autoreconf: running: /opt/local/bin/autoheader --force
autoreconf: running: automake --add-missing --copy --force-missing
automake: warnings are treated as errors
Makefile.am:15: warning: '%'-style pattern rules are a GNU make extension
Makefile.am:21: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendfile.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/file/Makefile.am:1:   while processing Libtool library 'libebookbackendfile.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendgoogle.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/google/Makefile.am:1:   while processing Libtool library 'libebookbackendgoogle.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendgroupwise.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/groupwise/Makefile.am:1:   while processing Libtool library 'libebookbackendgroupwise.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendldap.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/ldap/Makefile.am:1:   while processing Libtool library 'libebookbackendldap.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendvcf.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/vcf/Makefile.am:1:   while processing Libtool library 'libebookbackendvcf.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebookbackendwebdav.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/backends/webdav/Makefile.am:1:   while processing Libtool library 'libebookbackendwebdav.la'
addressbook/libebook/Makefile.am:55: warning: '%'-style pattern rules are a GNU make extension
addressbook/libebook/Makefile.am:65: warning: '%'-style pattern rules are a GNU make extension
addressbook/libebook/Makefile.am:66: warning: subst -,_,$*: non-POSIX variable name
addressbook/libebook/Makefile.am:66: (probably a GNU make extension)
addressbook/libebook/Makefile.am:72: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebook-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/libebook/Makefile.am:6:   while processing Libtool library 'libebook-1.2.la'
addressbook/libedata-book/Makefile.am:2: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:3: warning: subst -,_,$*: non-POSIX variable name
addressbook/libedata-book/Makefile.am:3: (probably a GNU make extension)
glib-gen.mak:9: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:13: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:18: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:26: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:38: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
glib-gen.mak:41: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:5:   'glib-gen.mak' included from here
addressbook/libedata-book/Makefile.am:86: warning: '%'-style pattern rules are a GNU make extension
addressbook/libedata-book/Makefile.am:101: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libedata-book-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/libedata-book/Makefile.am:13:   while processing Libtool library 'libedata-book-1.2.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebook-test-utils.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
addressbook/tests/ebook/Makefile.am:1:   while processing Libtool library 'libebook-test-utils.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendcaldav.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/caldav/Makefile.am:1:   while processing Libtool library 'libecalbackendcaldav.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendcontacts.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/contacts/Makefile.am:1:   while processing Libtool library 'libecalbackendcontacts.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendfile.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/file/Makefile.am:1:   while processing Libtool library 'libecalbackendfile.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendgoogle.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/google/Makefile.am:1:   while processing Libtool library 'libecalbackendgoogle.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendgroupwise.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/groupwise/Makefile.am:1:   while processing Libtool library 'libecalbackendgroupwise.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendhttp.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/http/Makefile.am:1:   while processing Libtool library 'libecalbackendhttp.la'
calendar/backends/weather/Makefile.am:44: warning: '%'-style pattern rules are a GNU make extension
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecalbackendweather.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/backends/weather/Makefile.am:1:   while processing Libtool library 'libecalbackendweather.la'
calendar/libecal/Makefile.am:53: warning: '%'-style pattern rules are a GNU make extension
calendar/libecal/Makefile.am:61: warning: '%'-style pattern rules are a GNU make extension
calendar/libecal/Makefile.am:62: warning: subst -,_,$*: non-POSIX variable name
calendar/libecal/Makefile.am:62: (probably a GNU make extension)
calendar/libecal/Makefile.am:68: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecal-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/libecal/Makefile.am:6:   while processing Libtool library 'libecal-1.2.la'
calendar/libedata-cal/Makefile.am:5: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:6: warning: subst -,_,$*: non-POSIX variable name
calendar/libedata-cal/Makefile.am:6: (probably a GNU make extension)
glib-gen.mak:9: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:13: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:18: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:26: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:38: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
glib-gen.mak:41: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:8:   'glib-gen.mak' included from here
calendar/libedata-cal/Makefile.am:71: warning: '%'-style pattern rules are a GNU make extension
calendar/libedata-cal/Makefile.am:86: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libedata-cal-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/libedata-cal/Makefile.am:16:   while processing Libtool library 'libedata-cal-1.2.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libecal-test-utils.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
calendar/tests/ecal/Makefile.am:1:   while processing Libtool library 'libecal-test-utils.la'
camel/Makefile.am:17: warning: '%'-style pattern rules are a GNU make extension
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamel-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/Makefile.am:30:   while processing Libtool library 'libcamel-1.2.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamel-provider-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/Makefile.am:30:   while processing Libtool library 'libcamel-provider-1.2.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelgroupwise.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/groupwise/Makefile.am:1:   while processing Libtool library 'libcamelgroupwise.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelhula.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/hula/Makefile.am:1:   while processing Libtool library 'libcamelhula.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelimap.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/imap/Makefile.am:1:   while processing Libtool library 'libcamelimap.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelimap4.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/imap4/Makefile.am:1:   while processing Libtool library 'libcamelimap4.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelimapx.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/imapx/Makefile.am:1:   while processing Libtool library 'libcamelimapx.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamellocal.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/local/Makefile.am:1:   while processing Libtool library 'libcamellocal.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelnntp.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/nntp/Makefile.am:1:   while processing Libtool library 'libcamelnntp.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelpop3.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/pop3/Makefile.am:1:   while processing Libtool library 'libcamelpop3.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelsendmail.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/sendmail/Makefile.am:1:   while processing Libtool library 'libcamelsendmail.la'
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libcamelsmtp.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/providers/smtp/Makefile.am:1:   while processing Libtool library 'libcamelsmtp.la'
/opt/local/share/automake-1.12/am/library.am: warning: 'libcameltest-provider.a': linking libraries using a non-POSIX
/opt/local/share/automake-1.12/am/library.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/tests/lib/Makefile.am:1:   while processing library 'libcameltest-provider.a'
/opt/local/share/automake-1.12/am/library.am: warning: 'libcameltest.a': linking libraries using a non-POSIX
/opt/local/share/automake-1.12/am/library.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
camel/tests/lib/Makefile.am:1:   while processing library 'libcameltest.a'
libebackend/Makefile.am:35: warning: '%'-style pattern rules are a GNU make extension
libebackend/Makefile.am:41: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libebackend-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
libebackend/Makefile.am:1:   while processing Libtool library 'libebackend-1.2.la'
libedataserver/Makefile.am:91: warning: '%'-style pattern rules are a GNU make extension
libedataserver/Makefile.am:97: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libedataserver-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
libedataserver/Makefile.am:1:   while processing Libtool library 'libedataserver-1.2.la'
libedataserverui/Makefile.am:108: warning: '%'-style pattern rules are a GNU make extension
libedataserverui/Makefile.am:118: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libedataserverui-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
libedataserverui/Makefile.am:5:   while processing Libtool library 'libedataserverui-1.2.la'
servers/google/libgdata-google/Makefile.am:27: warning: '%'-style pattern rules are a GNU make extension
servers/google/libgdata-google/Makefile.am:33: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libgdata-google-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
servers/google/libgdata-google/Makefile.am:1:   while processing Libtool library 'libgdata-google-1.2.la'
servers/google/libgdata/Makefile.am:31: warning: '%'-style pattern rules are a GNU make extension
servers/google/libgdata/Makefile.am:37: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libgdata-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
servers/google/libgdata/Makefile.am:1:   while processing Libtool library 'libgdata-1.2.la'
servers/groupwise/Makefile.am:85: warning: '%'-style pattern rules are a GNU make extension
servers/groupwise/Makefile.am:91: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
/opt/local/share/automake-1.12/am/ltlibrary.am: warning: 'libegroupwise-1.2.la': linking libtool libraries using a non-POSIX
/opt/local/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
servers/groupwise/Makefile.am:32:   while processing Libtool library 'libegroupwise-1.2.la'
autoreconf: automake failed with exit status: 1
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_evolution-data-server/evolution-data-server/work/evolution-data-server-2.30.3" && autoreconf --install -fvi 
Exit code: 1
Error: org.macports.configure for port evolution-data-server returned: autoreconf failure: command execution failed
Warning: targets not executed for evolution-data-server: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Please see the log file for port evolution-data-server for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_evolution-data-server/evolution-data-server/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port evolution-data-server failed

The log will be attached.

Changed 9 years ago by trog24 (Frank J. R. Hanstick)

Attachment: main.log added

Failed build log.

comment:12 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

automake: warnings are treated as errors

You don't have the change.

comment:13 Changed 9 years ago by trog24 (Frank J. R. Hanstick)

What change and why does the port not deal with the change?

comment:14 in reply to:  13 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Replying to trog24@…:

What change and why does the port not deal with the change?

r94167

You need to 'port sync'

comment:15 Changed 9 years ago by trog24 (Frank J. R. Hanstick)

The 'port sync' worked which raises an issue outside of this report. Thank you.

comment:16 Changed 9 years ago by jmroot (Joshua Root)

Cc: mww@… added
Owner: changed from mww@… to jim@…
Port: evolution-data-server added; automake removed
Summary: automake-1.12 fails to build evolution-data-serverevolution-data-server fails to autoreconf with automake-1.12

I don't see how this can be considered a bug in automake, given that they're asking it to treat warnings as errors.

comment:17 Changed 8 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

As stated above, fixed since r94167.

Note: See TracTickets for help on using tickets.