Opened 8 years ago

Closed 7 years ago

#34636 closed defect (fixed)

podofo: error: call to function 'operator<<' that is neither visible in the template definition nor found by argument-dependent lookup

Reported by: jose.exposito89@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: Cc: stmstm
Port: podofo

Description

OS: OS X Lion 10.7.4
Arch: x86_64
Xcode: 4.3.2
MacPorts version: 2.1.1

$ sudo port install podofo
--->  Computing dependencies for podofo
--->  Building podofo
Error: org.macports.build for port podofo returned: command execution failed
Please see the log file for port podofo for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_podofo/podofo/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port podofo failed

The log is attached

Attachments (3)

main.log (115.1 KB) - added by jose.exposito89@… 8 years ago.
Build log
Portfile (2.0 KB) - added by jose.exposito89@… 8 years ago.
ML_main.log (407.4 KB) - added by fleason (Fred Leason) 7 years ago.
Mountain Lion main.log

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by jose.exposito89@…

Attachment: main.log added

Build log

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to devans@…
Port: podofo added

In the future, please fill in the Port field and Cc the maintainer(s).

This is not a complete log. Please clean the port and try again. If it fails, attach the new log.

comment:2 Changed 8 years ago by jose.exposito89@…

Hi!

The problem is with the CppUnit test included with PoDoFo, that really are not necessaries. I don't know how to make this in a Portfile, but I hope that something can change the current PoDoFo Portfile to solve the bug.

Compile is easiest than:

# Download and extract the source code
$ curl -O http://ignum.dl.sourceforge.net/project/podofo/podofo/0.9/podofo-0.9.1.tar.gz
$ tar -zxvf podofo-0.9.1.tar.gz

# Make the build directory
$ cd podofo-0.9.1
$ mkdir build
$ cd build

# Compile (replace /opt/local with ${prefix} in the Portfile)
$ cmake -G "Unix Makefiles" -DWANT_FONTCONFIG:BOOL=TRUE -DPODOFO_BUILD_SHARED:BOOL=TRUE -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_INCLUDE_PATH=/opt/local/include -DCMAKE_LIBRARY_PATH=/opt/local/lib -DCMAKE_BUILD_TYPE=RELEASE ..
$ make podofo_shared
$ sudo make install

I don't know how to do "make podofo_shared" in the Portfile :S If someone can help me to do this or fix the port....

comment:3 Changed 8 years ago by jose.exposito89@…

Ah! For the +debug variant replace

-DCMAKE_BUILD_TYPE=RELEASE

with

-DCMAKE_BUILD_TYPE=DEBUG

And if you want to make PoDoFo as static library make only remove the "-DPODOFO_BUILD_SHARED:BOOL=TRUE" option and make with "make podofo_static":

$ cmake -G "Unix Makefiles" -DWANT_FONTCONFIG:BOOL=TRUE -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_INCLUDE_PATH=/opt/local/include -DCMAKE_LIBRARY_PATH=/opt/local/lib -DCMAKE_BUILD_TYPE=RELEASE ..
$ make podofo_static

comment:4 Changed 8 years ago by jose.exposito89@…

Oops I forgot to put that, to only install the PoDoFo library, you need to cd in the "src" directory before install:

$ cd src
$ sudo make install

comment:5 Changed 8 years ago by jose.exposito89@…

Finally I have made a Portfile (attached) for PoDoFo and looks like all is OK. I think that the "destroot" is not the better option, but works :P

Changed 8 years ago by jose.exposito89@…

Attachment: Portfile added

comment:6 Changed 7 years ago by fleason (Fred Leason)

Same issue in Mountain Lion

System Version:OS X 10.8 (12A269) Kernel Version:Darwin 12.0.0

08:05 AM ~ $ sudo port install scribus +python27 +podofo
--->  Computing dependencies for scribus
--->  Dependencies to be installed: podofo
--->  Fetching archive for podofo
--->  Attempting to fetch podofo-0.9.1_0.darwin_12.x86_64.tbz2 from http://packages.macports.org/podofo
--->  Attempting to fetch podofo-0.9.1_0.darwin_12.x86_64.tbz2 from http://macports.packages.ionic.de/podofo
--->  Fetching distfiles for podofo
--->  Verifying checksum(s) for podofo
--->  Extracting podofo
--->  Configuring podofo
--->  Building podofo
Error: org.macports.build for port podofo returned: command execution failed
Error: Failed to install podofo
Please see the log file for port podofo for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_podofo/podofo/main.log
Error: The following dependencies were not installed: podofo
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port scribus failed

main.log uploaded as ML_mail.log above.

Changed 7 years ago by fleason (Fred Leason)

Attachment: ML_main.log added

Mountain Lion main.log

comment:7 Changed 7 years ago by fleason (Fred Leason)

By the way, tclIndex is at /System/Library/Frameworks/Tk.framework/Versions/8.5/Resources/Scripts/tclIndex

comment:8 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: stmstmstmster@… added
Summary: podofo @0.9.1 - Build errorpodofo: error: call to function 'operator<<' that is neither visible in the template definition nor found by argument-dependent lookup

jose, please attach a unified diff of your changes instead of a complete portfile.

fleason, please ignore the tclIndex error message; it is not relevant.

Has duplicate #36035.

comment:9 Changed 7 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Sorry for the delay in getting round to this!

Fix committed in r97600 that forces the port to avoid using clang which fixes the problem for me on Lion and (I'm guessing) ML.

I think that the rest of the comments/changes are irrelevant to the build problem but if you feel additional changes should be made, please file a new ticket concerning those.

Thanks.

Note: See TracTickets for help on using tickets.