Opened 9 years ago

Closed 9 years ago

#34664 closed defect (duplicate)

otcl build hangs on Lion

Reported by: jursonovicst@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: Cc:
Port: otcl

Description

It seems to me that it does not find tcl.tk however it is installed...

$ sudo port install tcl
--->  Cleaning tcl
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.
$ sudo port install tk
--->  Computing dependencies for tk
--->  Cleaning tk
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.
$ sudo macport install tcl
sudo: macport: command not found
ubulka:~ jursonovicst$ sudo port install tcl
--->  Cleaning tcl
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.
ubulka:~ jursonovicst$ sudo port install tk
--->  Computing dependencies for tk
--->  Cleaning tk
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.
ubulka:~ jursonovicst$ sudo port install otcl
--->  Computing dependencies for otcl
--->  Configuring otcl
Error: org.macports.configure for port otcl returned: configure failure: command execution failed
Please see the log file for port otcl for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_otcl/otcl/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port otcl failed
:info:configure checking for Tcl.h... -I/opt/local/include
:info:configure checking for libTcl... -L/opt/local/lib -lTcl
:info:configure checking for tk.h... -I/opt/local/include
:info:configure checking for libtk8.4... -L/opt/local/lib -ltk
:info:configure checking for tk.tcl... no
:info:configure configure: error: Installation of tk seems incomplete or can't be found automatically.
:info:configure Please correct the problem by telling configure where tk is
:info:configure using the argument --with-tk=/path/to/package
:info:configure (perhaps after installing it),
:info:configure or the package is not required, disable it with --with-tk=no.
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_otcl/otcl/work/otcl-1.9" && ./configure --prefix=/opt/local --with-Tcl=/opt/local --with-Tcl-ver=8.4 --with-tk=/opt/local --with-tk-ver=8.4 --prefix=/opt/local CPPFLAGS='-I/opt/local/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_otcl/otcl/work/tcl8.4.9/generic/' CFLAGS='-I/opt/local/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_otcl/otcl/work/tcl8.4.9/generic/' LDFLAGS='-L/opt/local/lib' 
:info:configure Exit code: 1
:error:configure org.macports.configure for port otcl returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"$procedure $targetname"
:info:configure Warning: targets not executed for otcl: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Please see the log file for port otcl for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_otcl/otcl/main.log

Change History (2)

comment:1 Changed 9 years ago by jursonovicst@…

Maybe the version of the tcl/tk is incorrect?

macport tcl version: 8.5.11 macport tk version: 8.5.11

macport otcl assumes tcl/tk 8.4?!

... ./configure --prefix=/opt/local --with-Tcl=/opt/local --with-Tcl-ver=8.4 --with-tk=/opt/local --with-tk-ver=8.4 --prefix=/opt/local ...

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #14888.

Note: See TracTickets for help on using tickets.