Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#34824 closed defect (worksforme)

"error: Could not find a working Foundation implementation" during selfupdate

Reported by: p736m3dmht7t (John) Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: base Version: 2.1.1
Keywords: Cc: cooljeanius (Eric Gallager)
Port:

Description (last modified by neverpanic (Clemens Lang))

I am running Mac OS X 10.7.4 and MacPorts base version 2.0.4. Running sudo port self update produces the following result:

Computer:~ john$ sudo port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.0.4 installed,
MacPorts base version 2.1.1 downloaded.
--->  Updating the ports tree
--->  MacPorts base is outdated, installing new version 2.1.1
Installing new MacPorts release in /opt/local as root:admin; permissions 0755; Tcl-Package in /Library/Tcl

Error: /opt/local/bin/port: port selfupdate failed: Error installing new MacPorts base: shell command failed (see log for details)
Computer:~ john$ 

Attachments (1)

config.log (48.7 KB) - added by p736m3dmht7t (John) 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by neverpanic (Clemens Lang)

Component: portsbase
Description: modified (diff)
Keywords: selfupdate failed removed

Please remember to use WikiFormatting and preview your post when writing in Trac.

Please re-run with -d: sudo port -d selfupdate and attach the output.

comment:2 in reply to:  1 Changed 9 years ago by p736m3dmht7t (John)

Replying to cal@…:

Please remember to use WikiFormatting and preview your post when writing in Trac.

Please re-run with -d: sudo port -d selfupdate and attach the output.

Here is the result of sudo port -d self update

Computer:~ john$ sudo port -d selfupdate
Password:
DEBUG: Copying /Users/john/Library/Preferences/com.apple.dt.Xcode.plist to /opt/local/var/macports/home/Library/Preferences
DEBUG: MacPorts sources location: /opt/local/var/macports/sources/rsync.macports.org/release/base
--->  Updating MacPorts base sources using rsync
receiving file list ... done
./
deleting config.log

sent 42 bytes  received 7247 bytes  2082.57 bytes/sec
total size is 3260213  speedup is 447.28
MacPorts base version 2.0.4 installed,
DEBUG: Rebuilding and reinstalling MacPorts if needed
MacPorts base version 2.1.1 downloaded.
--->  Updating the ports tree
DEBUG: Synchronizing ports tree(s)
Synchronizing local ports tree from rsync://rsync.macports.org/release/ports/
DEBUG: /usr/bin/rsync -rtzv --delete-after '--exclude=/PortIndex*' rsync://rsync.macports.org/release/ports/ /opt/local/var/macports/sources/rsync.macports.org/release/ports
receiving file list ... done
aqua/qlipper/
aqua/qlipper/Portfile
databases/sqlite3/
databases/sqlite3/Portfile
devel/cctools/
devel/cctools/Portfile
devel/cctools/files/
devel/jubatus/
devel/jubatus/Portfile
devel/ocaml-pxp/
devel/ocaml-pxp/Portfile
devel/pficommon/
devel/pficommon/Portfile
devel/pficommon/files/
devel/pficommon/files/patch-wscript.diff
devel/qtc-qtsharp/
devel/qtc-qtsharp/Portfile
devel/qtsharp/
devel/qtsharp/Portfile
editors/emacs22/
editors/emacs22/Portfile
games/qstat/
games/qstat/Portfile
gnome/evolution-data-server/
gnome/evolution-data-server/Portfile
lang/gcc48/
lang/gcc48/Portfile
mail/imapfilter/
mail/imapfilter/Portfile
math/pspp-devel/
math/pspp-devel/Portfile
multimedia/VLC/
multimedia/VLC/Portfile
net/honeyd/
net/honeyd/Portfile
net/honeyd/files/
net/honeyd/files/configure.patch
net/honeyd/files/darwin_rlimit.patch
net/honeyd/files/dpkt_Makefile.patch
python/py-ply/
python/py-ply/Portfile
python/py-tables/
python/py-tables/Portfile
python/py27-pypdf/
python/py27-pypdf/Portfile
python/py27-simpletal/
python/py27-simpletal/Portfile
security/md5deep/
security/md5deep/Portfile
www/webkit-gtk/
www/webkit-gtk/Portfile
x11/
x11/xtermcontrol/
x11/xtermcontrol/Portfile
deleting devel/cctools/files/patch-misc_libtool.c.diff
deleting devel/cctools/files/PR-11136237-698.1.patch

sent 1487 bytes  received 614213 bytes  72435.29 bytes/sec
total size is 35294640  speedup is 57.32
DEBUG: /usr/bin/rsync -rtzv --delete-after rsync://rsync.macports.org/release/ports/PortIndex_darwin_11_i386/PortIndex /opt/local/var/macports/sources/rsync.macports.org/release/ports
receiving file list ... done
PortIndex

sent 17068 bytes  received 16083 bytes  13260.40 bytes/sec
total size is 8026898  speedup is 242.13
--->  MacPorts base is outdated, installing new version 2.1.1
DEBUG: Permissions OK
Installing new MacPorts release in /opt/local as root:admin; permissions 0755; Tcl-Package in /Library/Tcl

checking build system type... x86_64-apple-darwin11.4.0
checking host system type... x86_64-apple-darwin11.4.0
checking target system type... x86_64-apple-darwin11.4.0
checking MacPorts version... 2.1.1
checking for sw_vers... /usr/bin/sw_vers
checking for defaults... /usr/bin/defaults
checking for xcode-select... /usr/bin/xcode-select
checking Mac OS X version... 10.7.4
checking Xcode location... /Applications/Xcode.app/Contents/Developer
checking Xcode version... 4.3.2
checking for gcc... /usr/bin/cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/cc accepts -g... yes
checking for /usr/bin/cc option to accept ISO C89... none needed
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether we are using the GNU Objective C compiler... yes
checking whether gcc accepts -g... yes
checking for bsdmake... no
checking for pmake... no
checking for bzip2... /usr/bin/bzip2
checking for bzr... no
checking for chown... /usr/sbin/chown
checking for cp... /bin/cp
checking for cpio... /usr/bin/cpio
checking for cvs... /usr/bin/cvs
checking for diff... /usr/bin/diff
checking for dscl... /usr/bin/dscl
checking for dseditgroup... /usr/sbin/dseditgroup
checking for file... /usr/bin/file
checking for git... /usr/bin/git
checking for gnumake... /usr/bin/gnumake
checking for gnupatch... no
checking for gpatch... no
checking for gnutar... /usr/bin/gnutar
checking for gzip... /usr/bin/gzip
checking for hdiutil... /usr/bin/hdiutil
checking for hg... no
checking for launchctl... /bin/launchctl
checking for lipo... /usr/bin/lipo
checking for lsbom... /usr/bin/lsbom
checking for lzma... no
checking for make... /usr/bin/make
checking for mdfind... /usr/bin/mdfind
checking for mdls... /usr/bin/mdls
checking for mkbom... /usr/bin/mkbom
checking for mtree... /usr/sbin/mtree
checking for open... /usr/bin/open
checking for openssl... /usr/bin/openssl
checking for patch... /usr/bin/patch
checking for pax... /bin/pax
checking for rmdir... /bin/rmdir
checking for rsync... /usr/bin/rsync
checking for sed... /usr/bin/sed
checking for svn... /usr/bin/svn
checking for swig... no
checking for tar... /usr/bin/tar
checking for unzip... /usr/bin/unzip
checking for xar... /usr/bin/xar
checking for xcodebuild... /usr/bin/xcodebuild
checking for xcrun... /usr/bin/xcrun
checking for xz... no
checking for zip... /usr/bin/zip
checking for launchd... yes
checking for sed... (cached) /usr/bin/sed
checking which sed flag to use for extended regexp... -E (BSD)
checking for tar... (cached) /usr/bin/tar
checking whether tar supports -q... yes (bsdtar)
checking for tar... (cached) /usr/bin/tar
checking for gnutar... (cached) /usr/bin/gnutar
checking for which tar variant to use... /usr/bin/gnutar
checking for /usr/bin/gnutar --no-same-owner support... yes
checking for patch... (cached) /usr/bin/patch
checking for gpatch... no
checking for GNU (FSF) patch... /usr/bin/patch
checking how to mark unused variables... 
checking for gcc symbol visibility attribute... __attribute__((visibility("hidden")))
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... -D_THREAD_SAFE
checking how to run the Objective C preprocessor... gcc -E
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking objc/objc.h usability... yes
checking objc/objc.h presence... yes
checking for objc/objc.h... yes
checking if linking libobjc requires pthreads... no
checking for Apple Objective-C runtime... yes
checking for GNU Objective C runtime... no
configure: Using Apple Objective-C runtime
checking for Apple Foundation library... no
configure: WARNING: GNUSTEP_SYSTEM_ROOT is not defined in your environment, preventing the use of GNUstep's Foundation library
configure: error: Could not find a working Foundation implementation
shell command "cd /opt/local/var/macports/sources/rsync.macports.org/release/base && CC=/usr/bin/cc ./configure --prefix=/opt/local --with-tclpackage=/Library/Tcl --with-install-user=root --with-install-group=admin --with-directory-mode=0755 --enable-readline && make && make install SELFUPDATING=1" returned error 1
DEBUG: Error installing new MacPorts base: shell command failed (see log for details)
    while executing
"macports::selfupdate [array get global_options] base_updated"
Error: /opt/local/bin/port: port selfupdate failed: Error installing new MacPorts base: shell command failed (see log for details)
Computer:~ john$

John

comment:3 Changed 9 years ago by neverpanic (Clemens Lang)

Owner: changed from macports-tickets@… to cal@…
Status: newassigned
Summary: port selfupdate failed"error: Could not find a working Foundation implementation" during selfupdate

Thank you. Can you also attach /opt/local/var/macports/sources/rsync.macports.org/release/base/config.log?

Changed 9 years ago by p736m3dmht7t (John)

Attachment: config.log added

comment:4 Changed 9 years ago by neverpanic (Clemens Lang)

Resolution: worksforme
Status: assignedclosed

So the problem is essentially caused by

/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/CarbonCore.h:33:31: error: CarbonCore/Finder.h: No such file or directory

and

/System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Headers/Metadata.h:10:29: error: Metadata/MDItem.h: No such file or directory

I have no idea why you are missing these files. Try to restore them from a backup, re-install Xcode or even re-install OS X.

comment:5 Changed 9 years ago by p736m3dmht7t (John)

Is there any explanation as to how 2.0.4 worked fine and 2.1.1 fails? Is the reliance upon the CarbonCore.h and Metadata.h header files new with 2.1.1?

comment:6 Changed 9 years ago by p736m3dmht7t (John)

I found that both files are in their proper locations. The statement "No such file or directory" is itself an error.

comment:7 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.