Opened 10 years ago

Closed 8 years ago

#34953 closed update (wontfix)

py-libmemcached: update to 0.40, add py27 subport, deprecate py25

Reported by: ryandesign (Ryan Schmidt) Owned by: petrrr
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: cooljeanius (Eric Gallager)
Port: py25-libmemcached

Change History (10)

comment:1 Changed 9 years ago by petrrr

Cc: Peter.Danecek@… added

Cc Me!

comment:2 Changed 8 years ago by mf2k (Frank Schima)

Owner: changed from akitada@… to macports-tickets@…

This port is no longer maintained. See #43692.

comment:3 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:4 Changed 8 years ago by petrrr

Cc: petr@… added

Cc Me!

comment:5 Changed 8 years ago by petrrr

Summary: py25-libmemcached: update to 0.40-r1py-libmemcached: update to 0.40, add py27 subport, deprecate py25

Python 2.5 is deprecated! Add py27 subport instead.

comment:6 Changed 8 years ago by petrrr

Cc: Peter.Danecek@… removed

comment:7 Changed 8 years ago by petrrr

Owner: changed from macports-tickets@… to petr@…
Status: newassigned

comment:8 Changed 8 years ago by petrrr

Cc: petr@… removed

Cc Me!

comment:9 Changed 8 years ago by petrrr

I am wondering if we should not just get rid of this port.

The port itself was not maintained for quite some time, apart for some general changes. The py27 subport does not build and there are no dependencies. Upstream the code is apparently dead as well and not available at the sources specified in the Portfile. There are no dependent ports.

py-libmc seems to be functionally equivalent and maintained upstream. The last version 1.4.1 is Py3 compatible.

I would propose to delete this port without any deprecations measures.

comment:10 Changed 8 years ago by petrrr

Resolution: wontfix
Status: assignedclosed

Port removed in r135318.

Note: See TracTickets for help on using tickets.