Opened 9 years ago

Closed 9 years ago

#35187 closed defect (duplicate)

Pallet: Growl malformed object (unknown load command 5)

Reported by: michael@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: Cc:
Port: Pallet

Description

Having trouble tracking the log file down for port Pallet; Here's what I got when checking the main.log file:

:info:build Checking Dependencies...
:info:build 
:info:build PBXCp build/Release/Pallet.app/Contents/Frameworks/Growl.framework Growl-1.2.1-Framework/Growl.framework
:info:build     cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/work/Pallet
:info:build     /Developer/Library/PrivateFrameworks/DevToolsCore.framework/Resources/pbxcp -exclude .DS_Store -exclude CVS -exclude .svn -strip-debug-symbols -resolve-src-symlinks /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/work/Pallet/Growl-1.2.1-Framework/Growl.framework /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/work/Pallet/build/Release/Pallet.app/Contents/Frameworks
:info:build strip: for architecture x86_64 object: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/work/Pallet/Growl-1.2.1-Framework/Growl.framework/Versions/A/Growl malformed object (unknown load command 5)
:info:build pbxcp: warning: couldn't strip: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/work/Pallet/build/Release/Pallet.app/Contents/Frameworks/Growl.framework/Versions/A/Growl: No such file or directory
:info:build ** BUILD FAILED **
:info:build 
:info:build The following build commands failed:
:info:build Pallet:
:info:build 	PBXCp build/Release/Pallet.app/Contents/Frameworks/Growl.framework Growl-1.2.1-Framework/Growl.framework
:info:build (1 failure)
:info:build 
:info:build Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/work/Pallet" && /usr/bin/xcodebuild  -target "Pallet" -configuration Release build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.5 ARCHS=ppc SDKROOT="" GCC_VERSION=4.0 FRAMEWORK_SEARCH_PATHS='/opt/local/Library/Frameworks Growl-1.2.1-Framework'
:info:build Exit code: 1
:error:build org.macports.build for port Pallet returned: command execution failed
:debug:build Error code: NONE
:debug:build Backtrace: command execution failed
    while executing
"$procedure $targetname"
:info:build Warning: targets not executed for Pallet: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port Pallet for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/main.log

Any suggestions? I prefer not to use the command line (I'm lazy, but I'm not apologizing!) and I don't know if I have skipped a step... basically I launched the Pallet installer right on the heals of the MacPorts installation. Did I skip a step>

Change History (2)

comment:1 Changed 9 years ago by michael@…

Quick amendment: my message begins by stating that I had trouble tracking down the main.log file; this is, obviously, not true, as I've provided a huge chunk of the tail of said mail.log file, so disregard that statement.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Port: Pallet added
Resolution: duplicate
Status: newclosed
Summary: port Pallet returned: command execution failedPallet: Growl malformed object (unknown load command 5)

Duplicate of #27180.

Note: See TracTickets for help on using tickets.