Opened 11 years ago

Closed 11 years ago

#35475 closed defect (duplicate)

VLC @2.0.2 fails to rebuild or install

Reported by: nonstop.server@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: VLC

Description

Port VLC got rebuild after upgrading ffmpeg and gave the following error:

configure: error: No package 'libpostproc' found. Pass --disable-postproc to ignore this error.
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.2" && ./configure --prefix=/opt/local --with-contrib=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.2/contrib --disable-debug --disable-update-check --enable-gnutls --disable-notify --disable-telepathy --disable-dbus --disable-growl --enable-libproxy --enable-lua --enable-dvdnav --enable-dvdread --disable-smb --disable-vcdx --disable-macosx-qtkit --disable-macosx-eyetv --disable-realrtsp --enable-sftp --disable-dvbpsi --enable-ogg --enable-mux_ogg --enable-mkv --disable-shout --enable-a52 --enable-faad --enable-flac --disable-live555 --enable-vorbis --enable-ogg --enable-mad --disable-libass --enable-dca --enable-png --disable-quicktime --enable-twolame --disable-speex --enable-theora --enable-x264 --enable-postproc --enable-avcodec --enable-avformat --enable-swscale --enable-fluidsynth --disable-caca --disable-sdl --without-x --disable-xcb --disable-xvideo --disable-glx --disable-fribidi --disable-svg --disable-jack --enable-samplerate --disable-qt4 --enable-ncurses --disable-skins2 --disable-goom --enable-bonjour --enable-upnp --enable-macosx-vout --enable-macosx-audio --with-macosx-sdk=/ --enable-macosx-vlc-app --enable-mod --enable-mpc --enable-freetype --enable-fontconfig --enable-macosx --enable-macosx-dialog-provider 
Exit code: 1
Error: org.macports.configure for port VLC returned: configure failure: command execution failed
DEBUG: Error code: NONE

After this error port VLC was uninstalled and was no longer available for activation.
I was unable to install the port again, it returned the same error.
Version Information:

Mac OS Version:
Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386

Xcode Version:
Xcode 3.1.4
Component versions: DevToolsCore-1204.0; DevToolsSupport-1186.0
BuildVersion: 9M2809

Macports Version:
Version: 2.1.2

PS I have the tty output of the ffmpeg upgrade available if needed.
PPS New version 2.0.3 is released for VLC. ;)

Attachments (1)

main.log (55.4 KB) - added by nonstop.server@… 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by nonstop.server@…

Attachment: main.log added

comment:1 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #35473.

Note: See TracTickets for help on using tickets.