Opened 9 years ago

Closed 3 years ago

#35709 closed defect (fixed)

mutt-devel: No rule to make target `wcscasecmp@U@.o'

Reported by: tkren@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: pkutzner+macports@…, macports@…, doug@…, stanislav.markovic@…
Port: mutt-devel

Description

Trying to install mutt-devel with variants +gdbm+gpgme+headercache+imap+pop+sasl+smtp+ssl+trash+xlabel fails:

:info:build make[2]: *** No rule to make target `wcscasecmp@U@.o', needed by `mutt'.  Stop.

It seems that automake/autoconf did not set variable U, the Makefile contains:

U = @U@

Attachments (1)

main.log.gz (12.9 KB) - added by tkren@… 9 years ago.

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by tkren@…

Attachment: main.log.gz added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to mnick@…
Priority: HighNormal
Summary: No rule to make target `wcscasecmp@U@.o'mnick@macports.org: No rule to make target `wcscasecmp@U@.o'

So far I'm unable to reproduce the problem, but I'm on Mountain Lion and I see you're on Snow Leopard.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Summary: mnick@macports.org: No rule to make target `wcscasecmp@U@.o'mutt-devel: No rule to make target `wcscasecmp@U@.o'

comment:3 Changed 9 years ago by pkutzner+macports@…

Cc: pkutzner+macports@… added

Cc Me!

comment:4 Changed 8 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:5 Changed 8 years ago by macportsraf

It's happening for me too (macosx-10.6.8). But it's only just started now for some reason.

comment:6 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: doug@… added

Has duplicate #39002.

comment:7 Changed 8 years ago by mopihopi

I had the same problem attempting to install mutt-devel 1.5.21_4, even with the default variants (+gdbm+imap+pop), on Mac OS X 10.6.8. Adding "use_autoreconf yes" to the Portfile (as suggested by http://marc.info/?l=macports-dev&m=136183588504972&w=2) fixed it. Adding the +compress variant also works, as that also sets use_autoreconf.

comment:8 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: stanislav.markovic@… added

Has duplicate #40780.

comment:9 Changed 7 years ago by mf2k (Frank Schima)

Owner: changed from mnick@… to macports-tickets@…

mnick has retired.

comment:10 Changed 3 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

mutt-devel has been replaced by neomutt.

Note: See TracTickets for help on using tickets.