Opened 7 years ago

Closed 7 years ago

#35749 closed defect (fixed)

webkit-gtk: AuthenticationManagerMessageReceiver.cpp: No such file or directory

Reported by: ryandesign (Ryan Schmidt) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: webkit-gtk

Description

webkit-gtk 1.8.2 fails to build (upgrade, universal) on my Snow Leopard system with Xcode 3.2.6.

  GEN      DerivedSources/WebKit2/AuthenticationManagerMessageReceiver.cpp
/bin/sh: DerivedSources/WebKit2/AuthenticationManagerMessageReceiver.cpp: No such file or directory

Attachments (1)

main.log (74.5 KB) - added by ryandesign (Ryan Schmidt) 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by ryandesign (Ryan Schmidt)

Attachment: main.log added

comment:1 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

It looks like that should only be built if configured with --enable-webkit2, but your log shows:

:info:configure checking whether to build Webkit2... no

Hmm...

comment:2 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

comment:3 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed

I am able to reproduce this with one of my systems.

There is a path missing which is causing the problem. The paths are created by running ./configure so long as it was built with --enable-dependency-tracking, but +universal builds add --disable-dependency-tracking

https://bugs.webkit.org/show_bug.cgi?id=94488

r96867

Note: See TracTickets for help on using tickets.