New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #35885 (closed defect: fixed)

Opened 3 years ago

Last modified 3 months ago

lmms @0.4.12 Build error - Undefined symbol _waveguide_nl_process (gong_1424 dependency)

Reported by: marcelo.farias@… Owned by: ryandesign@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: clang Cc: deesto@…
Port: lmms

Description (last modified by ryandesign@…) (diff)

Build error while installing lmms 0.4.14 on OS X Lion (full build log attached):

:info:build cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_lmms/lmms/work/lmms-0.4.12/plugins/ladspa_effect/swh && /opt/local/bin/cmake -E cmake_link_script CMakeFiles/gong_1424.dir/link.txt --verbose=1
:info:build /usr/bin/clang   -O2 -g -Wall -pipe -O2 -arch x86_64  -O3 -DNDEBUG -arch x86_64 -bundle -Wl,-headerpad_max_install_names  -Bsymbolic -lm  -L/opt/local/lib -arch x86_64 -o gong_1424.so CMakeFiles/gong_1424.dir/gong_1424.o -L/opt/local/lib -lfftw3f 
:info:build Undefined symbols for architecture x86_64:
:info:build   "_waveguide_nl_process", referenced from:
:info:build       _runGong in gong_1424.o
:info:build       _runAddingGong in gong_1424.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make[2]: *** [plugins/ladspa_effect/swh/gong_1424.so] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_lmms/lmms/work/lmms-0.4.12'
:info:build make[1]: *** [plugins/ladspa_effect/swh/CMakeFiles/gong_1424.dir/all] Error 2
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_lmms/lmms/work/lmms-0.4.12'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_lmms/lmms/work/lmms-0.4.12'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_lmms/lmms/work/lmms-0.4.12" && /usr/bin/make -w all 
:info:build Exit code: 2
:error:build org.macports.build for port lmms returned: command execution failed
:debug:build Error code: CHILDSTATUS 10337 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for lmms: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port lmms for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_lmms/lmms/main.log

Attachments

main.log (233.7 KB) - added by marcelo.farias@… 3 years ago.
Full build log

Change History

Changed 3 years ago by marcelo.farias@…

Full build log

comment:1 Changed 3 years ago by ryandesign@…

  • Description modified (diff)

comment:2 Changed 3 years ago by ryandesign@…

  • Keywords clang added
  • Status changed from new to assigned
  • Owner changed from macports-tickets@… to ryandesign@…

I can reproduce this on Mountain Lion with Xcode 4.4, which like Xcode 4.2 and up on Lion and Snow Leopard uses clang as the default compiler.

comment:3 follow-up: ↓ 4 Changed 3 years ago by ryandesign@…

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed in r97201 by using llvm-gcc-4.2 instead. Filed upstream bug report.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 3 years ago by deesto@…

Replying to ryandesign@…:

Fixed in r97201 by using llvm-gcc-4.2 instead. Filed upstream bug report.

Is this workaround now live, or should we still see this error in 10.6 with the latest ports? I'm getting this error now.

...
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_trunk_dports_multimedia_     lmms/lmms/work/lmms-0.4.13/plugins/zynaddsubfx/ZynAddSubFx.cpp: In member function ‘void ZynAddSubFxInstrument::inn
     itPlugin()’:
4811 :info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_trunk_dports_multimedia_     lmms/lmms/work/lmms-0.4.13/plugins/zynaddsubfx/ZynAddSubFx.cpp:430: error: ‘QDir’ was not declared in this scope
4812 :info:build make[2]: *** [plugins/zynaddsubfx/CMakeFiles/zynaddsubfx.dir/ZynAddSubFx.o] Error 1
4813 :info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.     org_trunk_dports_multimedia_lmms/lmms/work/lmms-0.4.13'
4814 :info:build make[1]: *** [plugins/zynaddsubfx/CMakeFiles/zynaddsubfx.dir/all] Error 2
4815 :info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.     org_trunk_dports_multimedia_lmms/lmms/work/lmms-0.4.13'
4816 :info:build make: *** [all] Error 2
4817 :info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org     _trunk_dports_multimedia_lmms/lmms/work/lmms-0.4.13'
4818 :info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_tru     nk_dports_multimedia_lmms/lmms/work/lmms-0.4.13" && /usr/bin/make -w all 
4819 :info:build Exit code: 2
4820 :error:build org.macports.build for port lmms returned: command execution failed
4821 :debug:build Error code: CHILDSTATUS 9693 2
4822 :debug:build Backtrace: command execution failed
4823     while executing
4824 "system -nice 0 $fullcmdstring"
4825     ("eval" body line 1)
4826     invoked from within
4827 "eval system $notty $nice \$fullcmdstring"
4828     invoked from within
4829 "command_exec build"
4830     (procedure "portbuild::build_main" line 8)
4831     invoked from within
4832 "$procedure $targetname"
....

Thanks!

comment:5 Changed 3 years ago by deesto@…

  • Cc deesto@… added

Cc Me!

comment:6 in reply to: ↑ 4 Changed 3 years ago by ryandesign@…

Replying to deesto@…:

Replying to ryandesign@…:

Fixed in r97201 by using llvm-gcc-4.2 instead. Filed upstream bug report.

Is this workaround now live,

It was live four weeks ago when I committed r97201. Make sure you've run "sudo port selfupdate" to receive the fix.

or should we still see this error in 10.6 with the latest ports?

You're not seeing "this error" (Undefined symbol _waveguide_nl_process) but a different error; please file a new bug report and attach a complete main.log file.

comment:7 Changed 2 years ago by jmr@…

This probably just assumes gnu89 inline semantics?

comment:8 Changed 3 months ago by ryandesign@…

We switched to -std=gnu89 in r110625. I removed it in r135968 when I updated the port to 1.1.3 because it didn't seem to be needed anymore, but then I discovered it was still needed for older versions of clang so I reinstated it in r136280.

The issue tracker in which I had filed the upstream bug report no longer exists. I may have to re-file the issue at github.

Note: See TracTickets for help on using tickets.