Opened 8 years ago

Closed 8 years ago

#36057 closed defect (invalid)

libedit: error: libcurses or libncurses are required

Reported by: maartenversteegh@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: libedit

Description

Hi, I'm trying to upgrade libedit (well, python really) and it keeps failing as in log. Have done clean and self-update.

Attachments (2)

main.log (25.5 KB) - added by maartenversteegh@… 8 years ago.
config.log (40.1 KB) - added by maartenversteegh@… 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by maartenversteegh@…

Attachment: main.log added

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Owner: changed from macports-tickets@… to mcalhoun@…
Summary: libedit problem - configure failure: command execution failedlibedit: error: libcurses or libncurses are required

Hmm, the main.log shows that the configure phase of the x86_64 part of the universal build went fine, specifically it said:

:info:configure checking for tgetent in -ltinfo... no
:info:configure checking for tgetent in -lterminfo... no
:info:configure checking for tgetent in -ltermcap... yes

But the i386 part failed with:

:info:configure checking for tgetent in -ltinfo... no
:info:configure checking for tgetent in -lterminfo... no
:info:configure checking for tgetent in -ltermcap... no
:info:configure checking for tgetent in -ltermlib... no
:info:configure checking for tgetent in -lcurses... no
:info:configure checking for tgetent in -lncurses... no
:info:configure configure: error: libcurses or libncurses are required!

This suggests that maybe your ncurses port is not installed universal, or that something went wrong during its installation. Rebuilding the ncurses port may be needed. Before you do that though, could you please attach the file /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libedit/libedit/work/libedit-20120601-3.0-i386/config.log? Also, what is the output of the commands:

port -v installed ncurses
lipo -info /opt/local/lib/libtermcap.dylib

Changed 8 years ago by maartenversteegh@…

Attachment: config.log added

comment:2 Changed 8 years ago by maartenversteegh@…

Thanks! Attached config.log.

Output from port -v installed ncurses:

The following ports are currently installed:
  ncurses @5.9_1+universal (active) platform='darwin 10' archs='i386 x86_64'

Output from lipo -info /opt/local/lib/libtermcap.dylib:

Non-fat file: /opt/local/lib/libtermcap.dylib is architecture: x86_64

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Ok, that confirms that, although MacPorts believes it has installed ncurses universal, it hasn't. I confirmed on my Snow Leopard machine that ncurses can be properly built universal, and I also checked the pre-built archive on our packages server and it's fine too, so something must have gone wrong on your system. Please try rebuilding ncurses:

sudo port clean ncurses
sudo port -n upgrade --force ncurses

Does that change the output of the lipo command above? If so, can you then clean libedit and try building it again?

comment:4 Changed 8 years ago by maartenversteegh@…

Rebuilding ncurses did the trick. lipo now shows i386 as well and the rebuild of libedit seems to be going well (lots of dependencies rebuilding, so taking a while)

Thanks so much for the help!

comment:5 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

Great! Glad that worked.

Note: See TracTickets for help on using tickets.