Opened 8 years ago

Closed 8 years ago

#36080 closed defect (fixed)

MacVim +python25: Build Error

Reported by: SlaunchaMan (Jeff Kelley) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: anddam (Andrea D'Amore)
Port: MacVim

Description

Running on OS X 10.8.1. Build log attached.

Attachments (1)

main.log (67.1 KB) - added by SlaunchaMan (Jeff Kelley) 8 years ago.
Build Log.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by SlaunchaMan (Jeff Kelley)

Attachment: main.log added

Build Log.

comment:1 Changed 8 years ago by SlaunchaMan (Jeff Kelley)

Cc: SlaunchaMan@… added

Cc Me!

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: SlaunchaMan@… removed
Owner: changed from macports-tickets@… to raimue@…

comment:3 Changed 8 years ago by raimue (Rainer Müller)

Status: newassigned
Summary: MacVim Build ErrorMacVim +python25: Build Error

The problem is related to +python. Do you need specifically python 2.5? For example, try with +python27 instead.

sudo port clean MacVim
sudo port install MacVim +python27 +ruby

comment:4 Changed 8 years ago by SlaunchaMan (Jeff Kelley)

That worked. My old configuration was, somehow, MacVim @7.3.snapshot64_0+python+python25+ruby.

comment:5 Changed 8 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added

I'm experiencing the very same error using +python26 variant.

comment:6 Changed 8 years ago by anddam (Andrea D'Amore)

Further info: Python <= 2.6 only had CObject API to interface with C extensions, 2.7 introduced Capsules API therefore offering two APIs and then 3.2 dropped CObject leaving only Capsules.

The issue we're experiencing is simply due to the fact that Python 2.6 and 2.5 lack Capsules' symbols and those symbols are being used in the MacVim snapshot that is currently in ports.

Seems a patch to build with 2.5 has been committed in build 579, that should work with 2.6 as well.

Port MacVim's current state is snapshot 65 from Björn Winckler's macvim repository that is based on Vim's 277 build according to file src/version.h.

I think the solution is simply to disable python25 and python26 variants until MacVim snapshot will merge with Vim's build 579.

I'm attaching the simple patch to comment out pre-2.7 variants, in the same patch I've edited PYTHON build argument from python25 and python26 to be coherent with each variant.

comment:7 Changed 8 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: assignedclosed

I would say src/version.h is wrong. In src/version.c you can clearly see that more patches have been applied, in snapshot 65 up to 7.3.646. See also :version when running MacVim.

I identified the real problem to be the way Python.h was included which lead to use of the system header instead of the one provided in the -I include search path.

Fix committed in r97692.

Note: See TracTickets for help on using tickets.