Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#36648 closed defect (worksforme)

apple-gcc42 defect: build fails (Leopard, ppc64 slice)

Reported by: petrrr Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: leopard Cc:
Port: apple-gcc42

Description

The port does build on my system Mac OS X, ver 10.5.8.

OS version: Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386

Xcode 3.1.4 Component versions: DevToolsCore-1204.0; DevToolsSupport-1186.0 BuildVersion: 9M2809

Attachments (1)

apple-gcc42.main.log (11.1 MB) - added by petrrr 8 years ago.

Change History (16)

Changed 8 years ago by petrrr

Attachment: apple-gcc42.main.log added

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to jeremyhu@…

comment:2 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: invalid
Status: newclosed

Update to XCode 3.1.6 and try again.

comment:3 in reply to:  2 Changed 8 years ago by petrrr

Replying to jeremyhu@…:

Update to XCode 3.1.6 and try again.

Has anybody a pointer to this version, I can't find it.

And maybe the docu should be updated. See http://guide.macports.org/#installing.xcode.other

Thanks!

comment:4 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Sorry, I had an off-by-one moment. 3.2.6 is the last 3.2.x for SL. 3.1.4 is the last 3.1.x for Leopard. You're on the right version.

comment:5 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

:info:build + /opt/local/bin/strip -x -c ./opt/local/lib/apple-gcc42/gcc/i686-apple-darwin9/4.2.1/libstdc++.dylib
:info:build /opt/local/bin/strip: the __LINKEDIT segment does not cover the end of the file (can't be processed) in: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_apple-gcc42/apple-gcc42/work/destroot/opt/local/lib/apple-gcc42/gcc/i686-apple-darwin9/4.2.1/libstdc++.dylib (for architecture ppc64)
:info:build + exit 1

Does it work if you try using /usr/bin/strip?

comment:6 in reply to:  5 Changed 8 years ago by petrrr

Replying to jeremyhu@…:

Does it work if you try using /usr/bin/strip?

Negative! The same error message.

[urquell:apple-gcc42/work/destroot] petr% pwd
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_apple-gcc42/apple-gcc42/work/destroot
[urquell:apple-gcc42/work/destroot] petr% /usr/bin/strip -x -c ./opt/local/lib/apple-gcc42/gcc/i686-apple-darwin9/4.2.1/libstdc++.dylib
/usr/bin/strip: the __LINKEDIT segment does not cover the end of the file (can't be processed) in: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_apple-gcc42/apple-gcc42/work/destroot/opt/local/lib/apple-gcc42/gcc/i686-apple-darwin9/4.2.1/libstdc++.dylib (for architecture ppc64)
[urquell:apple-gcc42/work/destroot] petr% /opt/local/bin/strip -x -c ./opt/local/lib/apple-gcc42/gcc/i686-apple-darwin9/4.2.1/libstdc++.dylib
/opt/local/bin/strip: the __LINKEDIT segment does not cover the end of the file (can't be processed) in: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_apple-gcc42/apple-gcc42/work/destroot/opt/local/lib/apple-gcc42/gcc/i686-apple-darwin9/4.2.1/libstdc++.dylib (for architecture ppc64)

I noted something else that might be relevant. The library above seems not to have been created put only copied there. Does it then make sense to strip it?

[urquell:gcc/i686-apple-darwin9/4.2.1] petr% pwd
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_apple-gcc42/apple-gcc42/work/destroot/opt/local/lib/apple-gcc42/gcc/i686-apple-darwin9/4.2.1
[urquell:gcc/i686-apple-darwin9/4.2.1] petr% ls -la
total 4536
drwxr-xr-x  15 macports  admin      510 18 Oct 19:34 .
drwxr-xr-x   3 macports  admin      102 17 Oct 23:03 ..
-rw-r--r--   1 macports  admin    10624 18 Oct 19:34 crt3.o
drwxr-xr-x   2 macports  admin       68 17 Oct 23:03 finclude
drwxr-xr-x  28 macports  admin      952 18 Oct 19:34 include
drwxr-xr-x   6 macports  admin      204 18 Oct 19:34 install-tools
-rw-r--r--   1 macports  admin   641432 18 Oct 19:34 libcc_kext.a
-rw-r--r--   1 macports  admin   280856 18 Oct 19:34 libgcc.a
-rw-r--r--   1 macports  admin   115448 18 Oct 19:34 libgcc_eh.a
-rw-r--r--   1 macports  admin   272488 18 Oct 19:34 libgcc_static.a
-rw-r--r--   1 macports  admin    85560 18 Oct 19:34 libgcov.a
-rw-r--r--   1 macports  admin   182888 18 Oct 19:34 libgomp.a
-rw-r--r--   1 macports  admin      165 18 Oct 19:34 libgomp.spec
-rwxr-xr-x   1 macports  admin  3035296 27 Jun  2008 libstdc++.dylib
drwxr-xr-x   8 macports  admin      272 18 Oct 19:34 x86_64
Last edited 8 years ago by petrrr (previous) (diff)

comment:7 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: invalid
Status: closedreopened

Just a few days ago, I installed Leopard fresh on a 32bit intel Mac I had lying around, and apple-gcc42 built fine. I really don't know what might be at issue here. =/

comment:8 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Note that I would highly recommend you update to Snow Leopard given that you're on an Intel mac. Leopard support in MacPorts is quickly fading. We don't intentionally break things, but it's not one of the top supported platforms. Our main supported OS versions right now are Lion and Mountain Lion, but enough people still use Snow Leopard that it continues to function well. =/

comment:9 in reply to:  8 Changed 8 years ago by petrrr

Replying to jeremyhu@…:

Note that I would highly recommend you update to Snow Leopard given that you're on an Intel mac. Leopard support in MacPorts is quickly fading. We don't intentionally break things, but it's not one of the top supported platforms. Our main supported OS versions right now are Lion and Mountain Lion, but enough people still use Snow Leopard that it continues to function well. =/

You are of cause right, Leopard is somewhat obsolete. I probably will update hardware as well in the next months. Then I will consider to update the old computer to SL. Will check if the version is available at our organization.

comment:10 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Keywords: ppc64 added
Summary: apple-gcc42 defect: build failsapple-gcc42 defect: build fails (Leopard, ppc64 slice)

comment:11 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Keywords: leopard added

comment:12 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Keywords: ppc64 removed

comment:13 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: worksforme
Status: reopenedclosed

Please reopen if this is still an issue. I wasn't able to reproduce it last year.

comment:14 in reply to:  13 Changed 7 years ago by petrrr

Replying to jeremyhu@…:

Please reopen if this is still an issue. I wasn't able to reproduce it last year.

I have no problems to build it on Mac OS X 10.8. I tried to rebuild the port on the 10.5 system. and it still fails on that system. The problem seems to be exactly the same as one year ago. Do you want me to attach an updated main.log?

comment:15 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Well, it worked for me a year or so ago, so unless you have more data or a patch, there's not much I can do =/

Note: See TracTickets for help on using tickets.