Opened 9 years ago

Closed 6 years ago

#36672 closed defect (fixed)

netatalk: fatal error: 'netat/appletalk.h' file not found

Reported by: benedikt.hielscher@… Owned by: ralph@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: mountainlion lion haspatch Cc: ryandesign (Ryan Schmidt), cooljeanius (Eric Gallager)
Port: netatalk

Description

I tried to install netatalk, but I always get this error message:

:error:build org.macports.build for port netatalk returned: command execution failed
:debug:build Error code: CHILDSTATUS 14388 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"

Attachments (3)

main.log (17.8 KB) - added by benedikt.hielscher@… 9 years ago.
logfile
main.2.log (44.9 KB) - added by ryandesign (Ryan Schmidt) 9 years ago.
netatalk.diff (1.6 KB) - added by ryandesign (Ryan Schmidt) 9 years ago.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by benedikt.hielscher@…

Attachment: main.log added

logfile

comment:1 Changed 9 years ago by benedikt.hielscher@…

Sorry, forgot to mention the following: Xcode version is 4.5.1, I'm using OS X 10.8.2 Mountain Lion

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: mountainlion lion added; netatalk removed
Owner: changed from macports-tickets@… to ralph@…
Summary: netatalk @2.0.5, Revision 3 fails to buildnetatalk: fatal error: 'netat/appletalk.h' file not found

Your log was not from a clean build attempt, but I can reproduce the problem on my system so I'm attaching my log which is from a clean attempt.

The problem is the port wants to include appletalk.h but that doesn't exist anymore. This was reported on IRC about Lion as well. This had previously been reported about Snow Leopard in #21159. AppleTalk doesn't exist in Snow Leopard and up so r57161 disabled the port completely on Snow Leopard and up. r60660 changed it to offer a "noat" variant to disable AppleTalk, and then included a block to do the same unconditionally on Snow Leopard only.

Variant names should not begin with "no", and code should not be duplicated. The best solution is to have an "appletalk" variant, make it on by default on Leopard and below, and ensure that it cannot be enabled on Snow Leopard and above.

Changed 9 years ago by ryandesign (Ryan Schmidt)

Attachment: main.2.log added

Changed 9 years ago by ryandesign (Ryan Schmidt)

Attachment: netatalk.diff added

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

I'm attaching a patch to make these changes. It still doesn't build though. Maybe updating the port would help.

We should also ask ourselves why we want to give the user the choice to disable AppleTalk on supported systems in the first place. #22529 caused the "noat" variant to be added but does not explain why. It would be simpler if the port would enable or disable AppleTalk as appropriate for the OS X version and not give the user a choice.

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

Keywords: haspatch added

comment:5 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:6 Changed 6 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

r133417 (maintainer timeout)

Note: See TracTickets for help on using tickets.