Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#36877 closed defect (fixed)

ffmpeg @1.0+gpl2 install failure on Tiger

Reported by: ultrajoe@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: ffmpeg

Description

After recovering from the shock of all the new dependencies in ffmpeg, it fails in the configure step; the -disable-mmx2 option is not supported.

Haven't had time to track it down yet, nor have I tried any of the patches, assuming they wouldn't affect a PPC Tiger release. Correct me if I'm wrong.

Attachments (1)

main.log (9.9 KB) - added by ultrajoe@… 7 years ago.
Log file showing error.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by ultrajoe@…

Attachment: main.log added

Log file showing error.

comment:1 Changed 7 years ago by ultrajoe@…

Should note that I'm using the default variants (+gpl2, -mmx).

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: jeremyhu@… added
Owner: changed from macports-tickets@… to devans@…
Port: ffmpeg added

comment:3 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed

comment:4 Changed 7 years ago by ccarey@…

Although #36890 (which is specifically for PPC Tiger) has been marked as a duplicate of this ticket, it includes features that the r99418 changeset above does not have. Its fixes are also simpler than those in r99418.

comment:5 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

The additional change (--enable-freetype) was added in a subsequent revision r99425).

The changes in r99418 are preferred. We should just use the detection in configure. Since the only place it's broken is on Tiger and Tiger is no longer supported, just disable asm on Tiger.

comment:6 Changed 7 years ago by ccarey@…

The disabling of asm on Tiger doesn’t provide the missing “-lstdc++” that the “enabled libmodplug” line in ffmpeg’s configure needs to successfully build on PPC Tiger. It also doesn’t take advantage of configure’s ability to detect Altivec support, which a few extra lines in the Portfile patch of #36890 provides.

If the r99418 changes are preferred, that’s fine by me — I only ask that the features above be incorporated also, so that ffmpeg on PPC Tiger continues to be buildable, and will perform as efficiently as readily possible.

comment:7 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Please open a new ticket for your additional issues, and include a main.log showing your failure case. Adding '-lstdc++' to a link line is not the right fix. That should be included by the compiler's front end when calling the linker. Is it using $CC instead of $CXX? The fix would be to get it to use $CXX instead.

comment:8 Changed 7 years ago by ccarey@…

The new ticket is #36942, and although it applies primarily to ffmpeg 1.0_2, its changes are equally applicable to ffmpeg 1.0_1. My reasons for preferring to add -lstdc++ can be found in that ticket’s description. If you do not consider it to be the right fix, I encourage you to provide your preferred alternative.

Note: See TracTickets for help on using tickets.