Opened 8 years ago

Closed 8 years ago

#36966 closed defect (duplicate)

mplayer2 port fails to compile

Reported by: pmetzger (Perry E. Metzger) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: neverpanic (Clemens Lang)
Port: mplayer2

Description (last modified by ryandesign (Ryan Schmidt))

This error (and a couple of others) pop up while trying to compile mplayer2

libmpcodecs/vf_lavc.c:79:34: error: no member named 'encode' in 'struct AVCodec'; did you mean 'encode2'?
    if (lavc_venc_context.codec->encode == NULL) {
                                 ^~~~~~
                                 encode2

Change History (1)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: cal@… added
Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #36793.

Remember to use WikiFormatting when writing in Trac.

Note: See TracTickets for help on using tickets.