Opened 9 years ago

Closed 9 years ago

#36971 closed defect (duplicate)

phonon: in /opt/local/lib/libxml2.2.dylib, file was built for unsupported file format which is not the architecture being linked

Reported by: laochiv@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: michaelld (Michael Dickens)
Port: phonon

Description

When Trying to install phonon I get this error:

Error: org.macports.build for port phonon returned: command execution failed
Please see the log file for port phonon for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_audio_phonon/phonon/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port phonon failed

Inside the log file, I believe the issue is summarized:

:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_audio_phonon/phonon/work/phonon-4.6.0" && /usr/bin/make -j4 -w all 

however, I have attached a copy of the entire file as well. I have tried to clean and reinstall it already. This hasn't worked. Thanks

Attachments (1)

fail.txt (191.7 KB) - added by laochiv@… 9 years ago.
Failure Log File

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by laochiv@…

Attachment: fail.txt added

Failure Log File

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: michaelld@… added
Keywords: phonon removed
Port: phonon added; Phonon removed
Resolution: duplicate
Status: newclosed
Summary: Phonon fails to change directory which kills the installphonon: in /opt/local/lib/libxml2.2.dylib, file was built for unsupported file format which is not the architecture being linked

The relevant error in the log is:

:info:build ld: in /opt/local/lib/libxml2.2.dylib, file was built for unsupported file format which is not the architecture being linked (i386) for architecture i386

This is a duplicate of #36438.

Note: See TracTickets for help on using tickets.