Opened 11 years ago

Closed 10 years ago

Last modified 11 months ago

#37164 closed defect (fixed)

docbook-utils: "..." is not a function name

Reported by: ryandesign (Ryan Carsten Schmidt) Owned by: lockhart (Thomas Lockhart)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: cooljeanius (Eric Gallager)
Port: docbook-utils

Description

Building docbook-utils @0.6.14_1 fails for me. The log has lines like these:

:info:build onsgmls:/opt/local/share/xml/docbook/4.1.2/ent/iso-amsa.ent:8:19:E: "X21B6" is not a function name
:info:build onsgmls:/opt/local/share/xml/docbook/4.1.2/ent/iso-amsa.ent:8:19:E: "X21B6" is not a function name
:info:build onsgmls:/opt/local/share/xml/docbook/4.1.2/ent/iso-amsa.ent:8:19:E: "X21B6" is not a function name
:info:build onsgmls:/opt/local/share/xml/docbook/4.1.2/ent/iso-amsa.ent:8:19:E: "X21B6" is not a function name
:info:build onsgmls:/opt/local/share/xml/docbook/4.1.2/ent/iso-amsa.ent:8:19:E: "X21B6" is not a function name
:info:build onsgmls:/opt/local/share/xml/docbook/4.1.2/ent/iso-amsa.ent:9:19:E: "X21B7" is not a function name
:info:build onsgmls:/opt/local/share/xml/docbook/4.1.2/ent/iso-amsa.ent:9:19:E: "X21B7" is not a function name
:info:build onsgmls:/opt/local/share/xml/docbook/4.1.2/ent/iso-amsa.ent:9:19:E: "X21B7" is not a function name
[snip]

And so on (7500 more lines like these).

Attachments (1)

main.log.bz2 (16.6 KB) - added by ryandesign (Ryan Carsten Schmidt) 11 years ago.

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by ryandesign (Ryan Carsten Schmidt)

Attachment: main.log.bz2 added

comment:1 Changed 11 years ago by ryandesign (Ryan Carsten Schmidt)

Deactivating docbook-xml-4.1.2 for the duration of the docbook-utils works.

comment:2 Changed 11 years ago by ryandesign (Ryan Carsten Schmidt)

And now, after resolving #37131 (which was the reason I was trying to install docbook-utils at all), I can't reproduce the problem—even if I revert the change I made to fix that ticket. I don't really understand why. Maybe my docbook xml catalog just needed to rebuilt—which happened when I deactivated/reactivated docbook-xml-4.1.2.

comment:3 in reply to:  2 ; Changed 11 years ago by lockhart (Thomas Lockhart)

Replying to ryandesign@…:

And now, after resolving #37131 (which was the reason I was trying to install docbook-utils at all), I can't reproduce the problem—even if I revert the change I made to fix that ticket. I don't really understand why. Maybe my docbook xml catalog just needed to rebuilt—which happened when I deactivated/reactivated docbook-xml-4.1.2.

The problem is with the package textproc/iso8879, which needs to have been installed before the docbook-sgml-4.2 package so that the catalog entry for iso8879 appears before the specific docbook entries in the global catalog file /opt/local/etc/sgml/catalog. I think a from-scratch installation may get things in the right order, but I've noticed problems when installing and de-installing packages. I'm working on restructuring the docbook and related packages to try to guarantee order and to consolidate common code (there were almost a dozen packages trying to create that global catalog if it did not exist), and pixilla has been helpful in giving advice on the approach to take.

comment:4 Changed 10 years ago by davidfavor (David Favor)

Fresh install of docbook-utils throws same error for me.

comment:5 Changed 10 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:6 in reply to:  3 Changed 10 years ago by cooljeanius (Eric Gallager)

Replying to lockhart@…:

Replying to ryandesign@…:

And now, after resolving #37131 (which was the reason I was trying to install docbook-utils at all), I can't reproduce the problem—even if I revert the change I made to fix that ticket. I don't really understand why. Maybe my docbook xml catalog just needed to rebuilt—which happened when I deactivated/reactivated docbook-xml-4.1.2.

The problem is with the package textproc/iso8879, which needs to have been installed before the docbook-sgml-4.2 package so that the catalog entry for iso8879 appears before the specific docbook entries in the global catalog file /opt/local/etc/sgml/catalog. I think a from-scratch installation may get things in the right order, but I've noticed problems when installing and de-installing packages.

docbook-sgml-4.2 currently lists iso8879 as a runtime dependency, does the buildbot install those? If not then it should probably be listed as a build dependency as well.

Edit: actually I still get this issue even after installing the above in the correct order, so maybe it is something else?

Double edit: deactivating docbook-xml-4.1.2 allowed it to build successfully, so maybe the conflicts_build 1.0 PortGroup could be used to add a conflicts_build on docbook-xml-4.1.2?

Last edited 10 years ago by cooljeanius (Eric Gallager) (previous) (diff)

comment:7 Changed 10 years ago by lockhart (Thomas Lockhart)

This should be resolved by recent consolidation of xml and sgml catalog support around the xmlcatalog portgroup.

comment:8 Changed 10 years ago by pixilla (Bradley Giesbrecht)

Resolution: fixed
Status: newclosed

Newer patches should have addressed the symptom.

comment:9 Changed 3 years ago by jeremyhu (Jeremy Huddleston Sequoia)

I don't think this was ever fixed. I remember this being a problem the last time I tried to build documentation for XQuartz 5 years ago, and it's biting me again now. #62354.

comment:10 in reply to:  9 Changed 11 months ago by Lisias (Lisias)

Replying to jeremyhu:

I don't think this was ever fixed. I remember this being a problem the last time I tried to build documentation for XQuartz 5 years ago, and it's biting me again now. #62354.

This problem had bitten me in the… back… today. Looking for it, I found a fix!!!

sudo port uninstall docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 iso8879 docbook-xml-4.2 openjade docbook-sgml-4.2 docbook-utils p5.22-sgmlspm docbook-dsssl docbook-xml-5.0 docbook-xsl docbook-xsl-ns sgml-common
sudo rm -rf /opt/local/etc/sgml /opt/local/etc/xml
sudo port install -s docbook-utils

source: ticket:48297#comment:4

Note: See TracTickets for help on using tickets.