Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#37258 closed defect (fixed)

py27-graph-tool: error: pycairo headers not found

Reported by: cpdiehl@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: count0 (Tiago de Paula Peixoto), mamoll (Mark Moll), g5pw (Aljaž Srebrnič)
Port: py27-graph-tool

Description

Still struggling to install py27-graph-tool on one of my machines. Here's what I'm seeing.

$ sudo port install py27-graph-tool--->  Computing dependencies for py27-graph-tool
--->  Fetching archive for py27-graph-tool
--->  Attempting to fetch py27-graph-tool-2.2.18_2.darwin_11.x86_64.tbz2 from http://packages.macports.org/py27-graph-tool
--->  Attempting to fetch py27-graph-tool-2.2.18_2.darwin_11.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/py27-graph-tool
--->  Attempting to fetch py27-graph-tool-2.2.18_2.darwin_11.x86_64.tbz2 from http://lil.fr.packages.macports.org/py27-graph-tool
--->  Fetching distfiles for py27-graph-tool
--->  Attempting to fetch graph-tool-2.2.18.tar.bz2 from http://distfiles.macports.org/py-graph-tool
--->  Verifying checksum(s) for py27-graph-tool
--->  Extracting py27-graph-tool
--->  Configuring py27-graph-tool
Error: org.macports.configure for port py27-graph-tool returned: configure failure: command execution failed
Please see the log file for port py27-graph-tool for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-graph-tool/py27-graph-tool/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port py27-graph-tool failed

Digging into the log file, I see the place where things go off the rails.

:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-graph-tool/py27-graph-tool/work/graph-tool-2.2.18" && ./configure --prefix=/opt/local --with-boost=/opt/local 
:info:configure Exit code: 1
:error:configure org.macports.configure for port py27-graph-tool returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"$procedure $targetname"
:info:configure Warning: targets not executed for py27-graph-tool: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Please see the log file for port py27-graph-tool for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-graph-tool/py27-graph-tool/main.log

Running those commands myself, I see the following from the configure statement:

...
================
Detecting python
================
checking for a Python interpreter with version >= 2.6... python
checking for python... /opt/local/bin/python
checking for python version... 2.7
checking for python platform... darwin
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking for python2.7... (cached) /opt/local/bin/python
checking for a version of Python >= '2.1.0'... yes
checking for a version of Python == '2.7.1'... yes
checking for the distutils Python package... yes
checking for Python include path... -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7
checking for Python library path... -L/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config -lpython2.7
checking for Python site-packages path... /Library/Python/2.7/site-packages
checking python extra libraries...  -ldl  -framework CoreFoundation
checking python extra linking flags... -u _PyMac_Error /System/Library/Frameworks/Python.framework/Versions/2.7/Python
checking consistency of all components of python development environment... yes
===========================
Using python version: 2.7.1
===========================
checking for boostlib >= 1.38.0... yes
checking whether the Boost::Python library is available... no
configure: error: No usable boost::python found

Here are the py27-graph-tool dependencies that are active on my machine:

The following ports are currently installed:
  boost @1.52.0_1+no_single+no_static+python27 (active)
  cairomm @1.10.0_1 (active)
  cgal @4.1_0 (active)
  expat @2.1.0_0 (active)
  graphviz @2.28.0_9 (active)
  pkgconfig @0.27.1_1 (active)
  py27-gobject3 @3.2.2_0 (active)
  py27-numpy @1.6.2_1 (active)
  py27-scipy @0.11.0_0+gcc45 (active)
  python27 @2.7.3_1 (active)

I tried uninstalling and reinstalling boost different ways and to no avail. Definitely out of ideas. Any pointers would be greatly appreciated!

Attachments (1)

main.log (134.6 KB) - added by cpdiehl@… 6 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 6 years ago by neverpanic (Clemens Lang)

Please attach the complete main.log. Running the failing command manually does not necessarily give the same output because MacPorts runs them as a different user and sets quite a list of environment variables.

comment:2 Changed 6 years ago by neverpanic (Clemens Lang)

Cc: tiago@… mmoll@… added
Port: py27-graph-tool added

Also please set the port field and Cc the maintainer, if any.

Changed 6 years ago by cpdiehl@…

Attachment: main.log added

comment:3 Changed 6 years ago by cpdiehl@…

Just attached main.log as requested. Thanks for taking a look.

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: g5pw@… added
Summary: py27-graph-tool installation problem under osx 10.7.5py27-graph-tool: error: pycairo headers not found

py-cairo was recently unified; perhaps files have moved and py-graph-tool needs to be updated to find them.

comment:5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Since py-graph-tool is itself looking for py-cairo, py-graph-tool probably needs its own dependency on py-cairo, for orderly housekeeping. That probably doesn't change the error however.

comment:6 Changed 6 years ago by mamoll (Mark Moll)

Resolution: fixed
Status: newclosed

Fixed in r100371.

comment:7 in reply to:  6 ; Changed 6 years ago by cpdiehl@…

FYI. Doing a 'sudo port clean --all py27-graph-tool' and 'sudo port install py27-graph-tool' caused the system to still break in the same spot. Given the previous reference to py-cairo, on a whim, I did a 'sudo port install py-cairo' and then repeated the above. It got past the configuration stage and is now building. So adding that dependency seems like it would help.

comment:8 Changed 6 years ago by mamoll (Mark Moll)

That is very odd, since py-cairo doesn't install anything useful for building code:

> port contents py-cairo
Port py-cairo contains:
  /opt/local/share/doc/py-cairo/README

comment:9 Changed 6 years ago by mamoll (Mark Moll)

comment:10 Changed 6 years ago by cpdiehl@…

Very bizarre. I honestly don't know what changed then.

comment:11 in reply to:  7 Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to cpdiehl@…:

FYI. Doing a 'sudo port clean --all py27-graph-tool' and 'sudo port install py27-graph-tool' caused the system to still break in the same spot. Given the previous reference to py-cairo, on a whim, I did a 'sudo port install py-cairo' and then repeated the above. It got past the configuration stage and is now building. So adding that dependency seems like it would help.

The dependency on py${python.version}-cairo was added in r100371. Please attach a main.log of the build failure if you can still reproduce it.

comment:12 in reply to:  9 Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to mmoll@…:

It compiles fine on the buildbot, too: https://build.macports.org/builders/buildports-lion-x86_64/builds/6371/steps/status/logs/portstatus

On the Lion buildbot yes. But the Snow Leopard buildbot oddly got stuck and the build aborted: https://build.macports.org/builders/buildports-snowleopard-x86_64/builds/12885/steps/compile/logs/stdio ("command timed out: 1200 seconds without output, attempting to kill")

comment:13 Changed 6 years ago by mamoll (Mark Moll)

It's not *that* odd. Graph-tool needs massive amounts of memory. The compilation process probably starts swapping at some point. Even if the buildbots for the different os versions are configured the same, it is possible that the compiler on snow leapord uses even more memory and starts swapping even sooner.

Note: See TracTickets for help on using tickets.