Opened 6 years ago

Closed 6 years ago

#37394 closed defect (duplicate)

tcl @8.6.0_1 +corefoundation+threads Patch to allow successful build on Tiger

Reported by: ccarey@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: haspatch tiger Cc: mww@…, g5pw (Aljaž Srebrnič)
Port: tcl

Description

The tcl @8.6.0_1 +corefoundation+threads port does not successfully build on Tiger because of

:info:build Building package 'sqlite3.7.15.1'
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/unix/pkgs/sqlite3.7.15.1'
:info:build /usr/bin/gcc-4.0 -DPACKAGE_NAME=\"sqlite\" -DPACKAGE_TARNAME=\"sqlite\" -DPACKAGE_VERSION=\"3.7.15.1\" -DPACKAGE_STRING=\"sqlite\ 3.7.15.1\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -E_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DWORDS_BIGENDIAN=1 -DNO_VALUES_H=1 -DHAVE_LIMITS_H=1 -DHAVE_SYS_PARAM_H=1 -DUSE_THREAD_ALLOC=1  -D_REENTRANT=1 -D_THREAD_SAFE=1 -DTCL_THREADS=1 -DSQLITE_THREADSAFE=1 -DMODULE_SCOPE=extern\ __attribute__\(\(__visibility__\(\"hidden\"\)\)\) -DTCL_WIDE_INT_TYPE=long\ long -DUSE_TCL_STUBS=1 -Dfdatasync=fsync -DHAVE_DECL_STRERROR_R=1 -E_STRERROR_R=1 -DSQLITE_ENABLE_FTS3=1 -DSQLITE_3_SUFFIX_ONLY=1 -TREE=1 -DSQLITE_OMIT_DEPRECATED=1 -I"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/pkgs/sqlite3.7.15.1/generic" -I"/opt/local/var/macports/build/orts_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/generic" -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/pkgs/sqlite3.7.15.1/..    -pipe -2 -arch ppc -pipe  -Os -Wall -fno-common   -c `echo /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/pkgs/sqlite3.7.15.1/generic/tclsqlite3.c` -o tclsqlite3.o
:info:build In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/pkgs/sqlite3.7.15.1/generic/tclsqlite3.c:4:
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/pkgs/sqlite3.7.15.1/generic/sqlite3.c: In function ‘sqlite3MemInit’:
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/pkgs/sqlite3.7.15.1/generic/sqlite3.c:15667: warning: implicit declaration of function SwapPtrBarrier’eAndd
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/pkgs/sqlite3.7.15.1/generic/sqlite3.c: In function ‘fts3FilterMethod’:
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/tcl8.6.0/pkgs/sqlite3.7.15.1/generic/sqlite3.c:119945: warning: ‘rc’ may be used uninitialized in this function
:info:build rm -f libsqlite3.7.15.1.dylib
:info:build /usr/bin/gcc-4.0 -dynamiclib -pipe -O2 -arch ppc -pipe  -Os -Wall -fno-common   -arch ppc -headerpad_max_install_names -Wl,-search_paths_first  -Wl,-single_module -current_version 3.7.15 -compatibility_version 3.7.15 -o libsqlite3.7.15.1.dylib tclsqlite3.o -lpthread  -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/6.0/unix -ltclstub8.6
:info:build Undefined symbols:
:info:build   "_OSAtomicCompareAndSwapPtrBarrier", referenced from:
:info:build       _sqlite3MemInit in tclsqlite3.o
:info:build ld: symbol(s) not found
:info:build /usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool: internal link  edit command failed
:info:build make[1]: *** [libsqlite3.7.15.1.dylib] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/tcl/work/0/unix/pkgs/sqlite3.7.15.1'
:info:build make: *** [packages] Error 2

This problem, dealing with the sqlite3 component of tcl, was previously diagnosed in #32930. The attached Portfile patch makes use of the solution in #32930 to solve the problem here.

Attachments (1)

Portfile.tcl_8.6.0_1.diff (408 bytes) - added by ccarey@… 6 years ago.
patch to the Portfile to allow tcl @8.6.0_1 +corefoundation+threads to build successfully on Tiger

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by ccarey@…

Attachment: Portfile.tcl_8.6.0_1.diff added

patch to the Portfile to allow tcl @8.6.0_1 +corefoundation+threads to build successfully on Tiger

comment:1 Changed 6 years ago by g5pw (Aljaž Srebrnič)

Thanks for this! I'll commit it ASAP.

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #37369.

Note: See TracTickets for help on using tickets.