Opened 8 years ago

Closed 7 years ago

#37442 closed defect (invalid)

py27-celery @3.0.12: pkg_resources.DistributionNotFound: amqp>=1.0.5,<1.1.0

Reported by: marcop@… Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: petrrr
Port: py-celery

Description

I installed py27-celery @3.0.12. py27-amqp @1.2.0 is installed as a dependency.

When I launch celery I get the error below. It seems that celery is looking for an older version of amqp. I installed a compatible version of amqp (1.0.2) but unfortunately I wasn't able to solve the problem. As an attachment I provide the celeryconfig.py I'm using.

Traceback (most recent call last):
  File "/opt/local/bin/celeryd", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources.py", line 2811, in <module>
    parse_requirements(__requires__), Environment()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: amqp>=1.0.5,<1.1.0

Thank you for support and suggestions. Marco

Attachments (1)

celeryconfig.py (2.2 KB) - added by marcop@… 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by marcop@…

Attachment: celeryconfig.py added

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to stromnov@…

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Summary: py27-celery @3.0.12 DistributionNotFound errorpy27-celery @3.0.12: pkg_resources.DistributionNotFound: amqp>=1.0.5,<1.1.0

comment:3 Changed 7 years ago by petrrr

Cc: Peter.Danecek@… added

Cc Me!

comment:4 Changed 7 years ago by petrrr

Is this ticket still relevant? py-celery is now @3.1.11.

comment:5 in reply to:  4 Changed 7 years ago by stromnov (Andrew Stromnov)

Resolution: invalid
Status: newclosed

Replying to Peter.Danecek@…:

Is this ticket still relevant? py-celery is now @3.1.11.

Looks like old bug in old celery.

Note: See TracTickets for help on using tickets.