Opened 8 years ago

Closed 8 years ago

#37530 closed defect (duplicate)

OpenCV 2.4.3 fails to build on fresh install of Mountain Lion

Reported by: macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: opencv

Description

I'm on a freshly installed Mountain Lion with all current updates installed (Mac OS X 10.8.2), including a current XCode with Unix commandline tools (i.e. clang, etc) installed. I've installed MacPorts from the *.mpkg binary installer, issued "sudo port selfupdate" and installed just three packages (automake, autoconf, libtool) and then tried to install opencv including the Python 2.7 wrappers.

"sudo port install opencv +python27" fetched all dependencies, downloaded and extracted the OpenCV tarball, but failed configuring it. The error is (see attached logfile) stated below. Cleaning and trying again did result in an identical error.

:info:configure -- The CXX compiler identification is GNU 4.2.1
:info:configure -- The C compiler identification is GNU 4.2.1
:info:configure CMake Error at /opt/local/share/cmake-2.8/Modules/Platform/Darwin.cmake:190 (message):
:info:configure   CMAKE_OSX_DEPLOYMENT_TARGET is '10.8' but CMAKE_OSX_SYSROOT:
:info:configure 
:info:configure    "/"
:info:configure 
:info:configure   is not set to a MacOSX SDK with a recognized version.  Either set
:info:configure   CMAKE_OSX_SYSROOT to a valid SDK or set CMAKE_OSX_DEPLOYMENT_TARGET to
:info:configure   empty.
:info:configure Call Stack (most recent call first):
:info:configure   /opt/local/share/cmake-2.8/Modules/CMakeSystemSpecificInformation.cmake:36 (include)
:info:configure   CMakeLists.txt:61 (project)
:info:configure 
:info:configure 
:info:configure -- Configuring incomplete, errors occurred!
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/OpenCV-2.4.3" && cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DCMAKE_MODULE_PATH=/opt/local/share/cmake/modules -Wno-dev -DWITH_1394=OFF -DWITH_CARBON=OFF -DWITH_CUBLAS=OFF -DWITH_CUDA=OFF -DWITH_CUFFT=OFF -DWITH_EIGEN=OFF -DWITH_FFMPEG=ON -DWITH_GSTREAMER=OFF -DWITH_GTK=OFF -DWITH_IMAGEIO=OFF -DWITH_IPP=OFF -DWITH_JASPER=ON -DWITH_JPEG=ON -DWITH_OPENEXR=ON -DWITH_OPENGL=ON -DWITH_OPENNI=OFF -DWITH_PNG=ON -DWITH_PVAPI=OFF -DWITH_GIGEAPI=OFF -DWITH_QT=OFF -DWITH_QUICKTIME=OFF -DWITH_TBB=OFF -DWITH_CSTRIPES=OFF -DWITH_TIFF=ON -DWITH_UNICAP=OFF -DWITH_V4L=OFF -DWITH_VIDEOINPUT=OFF -DWITH_XIMEA=OFF -DWITH_XINE=OFF -DWITH_OPENCL=OFF -DWITH_OPENCLAMDFFT=OFF -DWITH_OPENCLAMDBLAS=OFF -DBUILD_SHARED_LIBS=ON -DBUILD_DOCS=OFF -DBUILD_EXAMPLES=OFF -DBUILD_PERF_TESTS=OFF -DBUILD_TESTS=OFF -DBUILD_ZLIB=OFF -DBUILD_TIFF=OFF -DBUILD_JASPER=OFF -DBUILD_JPEG=OFF -DBUILD_PNG=OFF -DBUILD_OPENEXR=OFF -DINSTALL_C_EXAMPLES=OFF -DENABLE_PRECOMPILED_HEADERS=ON -DCMAKE_VERBOSE=ON -DZLIB_LIBRARY=/opt/local/lib/libz.dylib -DBZIP2_LIBRARIES=/opt/local/lib/libbz2.dylib -DINSTALL_PYTHON_EXAMPLES=ON -DPYTHON_EXECUTABLE=/opt/local/bin/python2.7 -DPYTHON_LIBRARY=/opt/local/lib/libpython2.7.dylib -DPYTHON_INCLUDE_DIR=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/Headers -DPYTHON_PACKAGES_PATH=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages -DCMAKE_OSX_ARCHITECTURES="x86_64" -DCMAKE_OSX_SYSROOT=/ -DOPENCV_LINKER_LIBS="-Wl,-headerpad_max_install_names" 
:info:configure Exit code: 1

A short web search resulted in the info that this might be due to a broken cmake. This is what I found:
MacPorts cmake ticket #37527
http://public.kitware.com/Bug/print_bug_page.php?bug_id=9959
http://cmake.3232098.n2.nabble.com/OSX-deployment-target-confusion-for-2-8-10-td7582284.html

Attachments (1)

main_log_original (84.3 KB) - added by macports@… 8 years ago.
log file from initial run (including dependency installation)

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by macports@…

Attachment: main_log_original added

log file from initial run (including dependency installation)

comment:1 Changed 8 years ago by macports@…

I must add, that "sudo port clean opencv" plus "sudo port install opencv" works (i.e., building without Python). I suspect the problem to be Mountain Lion platform python (no mac ports python installed).

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #37527.

Note: See TracTickets for help on using tickets.