Opened 8 years ago

Closed 8 years ago

#37679 closed defect (worksforme)

textmate2@2.0.9347 fails to build

Reported by: fyrefiend@… Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: textmate2

Description

Forgive me as I am not a programmer so I don't really know what I should put here but please feel free to ask if there is anything I can supply to help. Attached is the build log

Attachments (1)

main.log (778.3 KB) - added by fyrefiend@… 8 years ago.
log from a clean attempt

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by fyrefiend@…

Cc: fyrefiend@… added

Cc Me!

comment:2 Changed 8 years ago by ci42

Cc: fyrefiend@… removed
Owner: changed from macports-tickets@… to cal@…
Port: textmate2 added
Priority: HighNormal
Summary: textmate2 2.0.9347 fails to buildtextmate2@2.0.9347 fails to build

This was not a clean attempt. Please try again and attach the log file if it fails:

$ sudo port clean textmate2
$ sudo port install textmate2

You don't need to Cc yourself if you're the ticket creator. But do Cc the maintainer. Please note that priority high is reserverd for MacPorts team members.

comment:3 Changed 8 years ago by fyrefiend@…

Thank you for replying. I'm sorry I had not filed the report correctly. I cleaned and tried reinstalling and it still failed. I've replaced the log with one from a clean attempt.

Changed 8 years ago by fyrefiend@…

Attachment: main.log added

log from a clean attempt

comment:4 Changed 8 years ago by neverpanic (Clemens Lang)

I can't reproduce this myself. What version is your /usr/bin/clang? Which version of Xcode are you running? Are you on 10.8?

comment:5 Changed 8 years ago by fyrefiend@…

Sorry for the delay on replying. I've got Xcode 4.5.2 on OS 10.8.2. clang version 4.1 (tags/Apple/clang-421.11.66) (based on LLVM 3.1svn)

comment:6 Changed 8 years ago by fyrefiend@…

And now it's working. I'm sorry for wasting your time. It must have been something my end.

Last edited 8 years ago by fyrefiend@… (previous) (diff)

comment:7 Changed 8 years ago by neverpanic (Clemens Lang)

Can you give me the output of

locale

on your system?

comment:8 Changed 8 years ago by fyrefiend@…

Sure:

LANG="en_US.UTF-8" LC_COLLATE="en_US.UTF-8" LC_CTYPE="en_US.UTF-8" LC_MESSAGES="en_US.UTF-8" LC_MONETARY="en_US.UTF-8" LC_NUMERIC="en_US.UTF-8" LC_TIME="en_US.UTF-8" LC_ALL=

comment:9 Changed 8 years ago by neverpanic (Clemens Lang)

So it's not the locale settings (I'm running the same). Does this still happen with the latest version?

comment:10 Changed 8 years ago by fyrefiend@…

Nope, It's installing fine now. Thank you.

comment:11 Changed 8 years ago by neverpanic (Clemens Lang)

Resolution: worksforme
Status: newclosed

*shrug*

Note: See TracTickets for help on using tickets.