Opened 8 years ago

Closed 8 years ago

#37751 closed defect (duplicate)

tesseract: error: 'AM_CONFIG_HEADER': this macro is obsolete

Reported by: jack.rueter@… Owned by: markemer (Mark Anderson)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: tesseract

Description (last modified by ryandesign (Ryan Schmidt))

"Sudo port install tesseract" fails

$ sudo port install tesseract
--->  Computing dependencies for tesseract
--->  Configuring tesseract
Error: org.macports.configure for port tesseract returned: autoreconf failure: command execution failed
Please see the log file for port tesseract for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_tesseract/tesseract/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port tesseract failed
dhcp-eduroam-hy-137-129:~ rueter$ l /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_tesseract/tesseract/main.log

Attachments (1)

main.log (49.9 KB) - added by jack.rueter@… 8 years ago.
log file

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by jack.rueter@…

Attachment: main.log added

log file

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Keywords: autoreconf removed
Owner: changed from macports-tickets@… to emer@…
Summary: Mac OS 10.8.2: sudo port install tesseract: Error: org.macports.configure for port tesseract returned: autoreconf failure: command execution failedtesseract: error: 'AM_CONFIG_HEADER': this macro is obsolete

The usual automake 1.13/1.13.1 incompatibility. automake 1.13.2 will reduce this from an error to a warning but upstream should definitely fix this; this macro has been deprecated for a decade.

comment:2 Changed 8 years ago by markemer (Mark Anderson)

This is a duplicate of 37751, where I have included a patch and a fixed port file. Can you take a look and commit the fixes over there?

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Ah yes. You mean #37429.

Note: See TracTickets for help on using tickets.