Opened 8 years ago

Closed 8 years ago

#37819 closed defect (fixed)

wxWidgets should be removed / replaced_by wxWidgets-3.0

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: cooljeanius (Eric Gallager), mojca (Mojca Miklavec), nospam2000@…, afb@…, raimue (Rainer Müller), usami-k@…, jyrkiwahlstedt, michaelld (Michael Dickens), ryandesign (Ryan Schmidt), bfulgham@…, tenomoto (Takeshi Enomoto), jameskyle@…, neurodroid (Christoph Schmidt-Hieber), macports@…, hvdwolf@…, bugcutt@…, rudloff@…, jjstickel (Jonathan Stickel)
Port: wxWidgets wxWidgets-python

Description (last modified by mojca (Mojca Miklavec))

wxWidgets is 32bit only and doesn't build on Lion or later. This is causing dependent ports to fail to build packages on buildbot. Please update the port to "just work" better on our currently supported platforms. Based on the instructions in the ticket, it sounds like we should just transition to wxWidgets-3.0 (or wxWidgets-2.8 for ports that don't compile with 2.9).

Change History (9)

comment:1 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:2 Changed 8 years ago by jmroot (Joshua Root)

Port: wxWidgets-python added

comment:3 in reply to:  2 Changed 8 years ago by cooljeanius (Eric Gallager)

Replying to jmr@…:

While you're at it, add the rest of the wxWidgets ports, too

comment:4 Changed 8 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:5 Changed 8 years ago by mf2k (Frank Schima)

Last edited 8 years ago by mf2k (Frank Schima) (previous) (diff)

comment:6 Changed 8 years ago by nospam2000@…

Cc: nospam2000@… added

Cc Me!

comment:7 Changed 8 years ago by mojca (Mojca Miklavec)

Cc: afb@… raimue@… usami-k@… jwa@… michaelld@… ryandesign@… bfulgham@… takeshi@… jameskyle@… christsc@… macports@… hvdwolf@… bugcutt@… rudloff@… jjstickel@… added
Description: modified (diff)
Summary: wxWidgets should be removed / replaced_by wxWidgets30wxWidgets should be removed / replaced_by wxWidgets-3.0
Version: 2.1.2

I started working on this, see browser:users/mojca/wxports. The PortGroup doesn't work yet, but I hope on some help from community. The idea would be to replace wxWidgets by wxWidgets-2.8, wxWidgets-devel and wxWidgets30 by wxWidgets-3.0 (naming scheme consistent with ports like llvm, clang, ... cleaner than no dots in numbers). The ports wxWidgets-2.8 and wxWidgets-3.0 can already be installed side-by-side, but more testing is needed and ports need to be adapted once the PortGroup is done.

The problem is that I have no clue about the zillion of python variants and I'm also not sure if wxgtk is needed or working. Any help with those highly appreciated.

My wishlist for the PortGroup:

  • allow the port to specify an incompatibility with a certain version of wxWidgets; suggestions welcome
  • set wxWidgets version to 3.0 by default
  • if 2.8 is requested (because port doesn't support 2.9), automatically set supported_archs i386 ppc & universal_variant no, blacklist clang
  • if 10.8 is used or Xcode >= 4.4 on 10.7, don't even attempt to compile the port which depends on 2.8 (throw an error)
  • I'm not sure if this is needed, but on 10.4 one should either set 2.8 by default, or deprecate installation of any wxWidgets dependency on Tiger (I believe that 10.5 should be supported, I'm not sure why the Portfile for wxWidgets30 asks for 10.6)
  • set ${wxWidgets.confpath} variable to ${prefix}/libexec/wxWidgets/${version}; suggestions for a better name welcome

Here's a list of dependencies on wx* that need to be adapted along with wxWidgets (most probably lacking some ports, for wxPython in particular), please fill the list if you spot any:

wxWidgets, wxWidgets-devel, wxWidgets30
- devel/poedit [req] (on SL autoreplace 2.8 with 3.0) {raimue openmaintainer}
- math/gnuplot [+wxwidgets/devel/30]                  {mojca openmaintainer}
- math/wxMaxima [required/+wxwidgets-devel/30]        {usami-k openmaintainer}

only with wxWidgets30:
- aqua/pgAdmin3 [no option, required]                 {jwa}
- gis/grass [+wxwidgets]                              {nomaintainer}
- multimedia/mkvtoolnix [+wxwidgets]                  {nomaintainer}
- perl/p5-alien-wxwidgets  [required]                 {nomaintainer}
  - perl/p5-wx (depends on p5-alien-wxwidgets)        {nomaintainer}
- perl/p5-graphics-gnuplotif (depends on gnuplot)     {nomaintainer}
- science/gnuradio [+wxgui] (wxwidgets-devel)         {michaelld openmaintainer}
- science/plplot                                      {takeshi openmaintainer}
- science/stimfit  [required]                         {gmx.de:christsc}

currenty only depends on wxWidgets 2.8:
- cross/usbprog                                       {lilalinux.net:macports}
- devel/codeblocks (+wxgtk [freebsd])                 {afb}
- devel/wxd                                           {usami-k openmaintainer}
- devel/wxstedit (+wxgtk [freebsd])                   {afb}
  - graphics/wxLua (depends on wxstdedit)
- emulators/lisaem                                    {ryandesign}
- lang/erlang [+wxwidgets, optional]                  {bfulgham}
  - graphics/esdl (depends on erlang)                 {bfulgham}
- graphics/hugin-app [no option, required]            {gmail.com:hvdwolf}
- graphics/rt-volume-rendering [no option, required]  {gmail.com:bugcutt}
- math/fityk                                          {nomaintainer}

known not to be compatible with 2.9 (requires more work):
- security/otrproxy [no option, required]             {nomaintainer}
- www/FileZilla [no option, required]                 {strasweb.fr:rudloff openmaintainer}

not working:
- math/gnudatalanguage (not functional yet)           {takeshi}
- kde/digikam (would depend if it could)

core:
- cross/wxmsw                                         {nomaintainer}
- x11/wxgtk                                           {nomaintainer}
- graphics/wxWidgets                                  {jwa}
- graphics/wxWidgets-devel                            {jwa}
- graphics/wxWidgets30                                {jwa}
- graphics/wxWidgets-python                           {nomaintainer}

python core:
- py-wxpython                                         {nomaintainer}
  > py-wxpython@2.8.12.1
  > py24-wxpython@2.8.12.1  [python24, wxWidgets]
  > py25-wxpython@2.8.12.1  [python25, wxWidgets]
  > py27-wxpython@2.8.12.1  [python27, wxWidgets]
- py26-wxpython                                       {jameskyle}
  > py26-wxpython@2.8.10.1  [python26, wxWidgets-python]
- py-wxpython30                                       {jwa}
  > py-wxpython30  @2.9.4.9 [py27-wxpython30]
  > py27-wxpython30@2.9.4.0 [python27, wxWidgets30]
- py27-wxpython-devel                                 {jwa}
  > py27-wxpython-devel@2.9.4.9 [wxWidgets30]

python:
- py-dsv                    [pyXY-wxpython]           {nomaintainer}
- py-pyface                 [pyXY-wxpython]           {gmail.com:jjstickel openmaintainer}
- py-robotframework-ride    [pyXY-wxpython(30)]       {jwa}
- py-winpdb                 [pyXY-wxpython-devel]     {eborisch}
- py26-pyphant              [py26-wxpython & ...]     {fmf.uni-freiburg.de:klaus.zimmermann, rowue}
- gis/grass                 [py27-wxpython30]         {nomaintainer}

But cleanup is needed on the PortGroup first, only then should ports be changed - to prevent double or triple effort.

Last edited 8 years ago by mojca (Mojca Miklavec) (previous) (diff)

comment:8 Changed 8 years ago by tenomoto (Takeshi Enomoto)

Added wxWidgets variant in plplot (r108837). Made wxWidgets variant deprecated (r108838) because it does not build and wxWidget support is not actively developed.

comment:9 Changed 8 years ago by mojca (Mojca Miklavec)

Resolution: fixed
Status: newclosed

Old wxWidgets ports deprecated in r110280.

Note: See TracTickets for help on using tickets.