Opened 14 years ago

Closed 14 years ago

#3797 closed defect (fixed)

py-xml 0.8.3 cannot be used with python 2.4

Reported by: k_karanikolas@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

Py-xml cannot be used with python 2.4 since it expects version 0.8.4 upwards

For example:

import xml.dom.ext

Traceback (most recent call last):

File "<stdin>", line 1, in ?

ImportError: No module named ext

Investigation: Py-xml installs as module _xmlplus in /opt/local/lib/python2.4/site-packages/

When the xml module is imported from the python standard lib, a check is made in /Library/ Frameworks/Python.framework/Versions/Current/lib/python2.4/xml/init.py if module _xmlplus of a minimum version of 0.8.4 exists, then that module is imported instead. Otherwise the standard library xml support is imported

Suggested fixes:

  1. (Recommended) Upgrade py-xml to 0.8.4 (it's has been out since 2004-11, so it should be fairly

stable)

  1. Patch .../lib/python2.4/xml/init.py to require the py-xml 0.8.3

Change History (1)

comment:1 Changed 14 years ago by mww@…

Resolution: fixed
Status: newclosed

sounds like a good idea... just updated to 0.8.4;

Note: See TracTickets for help on using tickets.