Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#38136 closed defect (fixed)

bmake @20121212 installs to /usr/local instead of the configured prefix

Reported by: cooljeanius (Eric Gallager) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: mfeiri, g5pw (Aljaž Srebrnič)
Port: bmake

Description

This could be fixed by adding a destroot.violate_mtree yes to the portfile if this is intended behavior, but g5pw said on irc that it's a bug, so it'd probably be better just to actually fix it.

Change History (6)

comment:1 Changed 7 years ago by g5pw (Aljaž Srebrnič)

Resolution: fixed
Status: newclosed

Hehe, I just fixed this in r103296. Thanks for reporting it though!

comment:2 Changed 7 years ago by cooljeanius (Eric Gallager)

Wait I take back what I said in irc about this being properly fixed now... it actually still installs to /usr/local

comment:3 Changed 7 years ago by larryv (Lawrence Velázquez)

The boot strap script does not pass DESTDIR along to the makefile. I think you have to set INSTALL_DESTDIR=${destroot} in destroot.env.

comment:4 in reply to:  3 Changed 7 years ago by g5pw (Aljaž Srebrnič)

Replying to larryv@…:

The boot strap script does not pass DESTDIR along to the makefile. I think you have to set INSTALL_DESTDIR=${destroot} in destroot.env.

No, I'm pretty sure it's just because I forgot to update the revision so the buildbot didn't build it again... r103339 should fix that.

Last edited 7 years ago by g5pw (Aljaž Srebrnič) (previous) (diff)

comment:5 Changed 7 years ago by cooljeanius (Eric Gallager)

Oh wait I just realized my local copy of the portfile is blocking the upstream one... never mind what I said about it not being properly fixed, I was actually right the first time...

comment:6 Changed 7 years ago by larryv (Lawrence Velázquez)

Hm, yeah maybe I should have actually tried building it before saying anything…

Note: See TracTickets for help on using tickets.