Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#38141 closed defect (fixed)

ffmpeg compilation: "run out of registers" on 10.6.8

Reported by: aszoz@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: dbevans (David B. Evans), cooljeanius (Eric Gallager)
Port: ffmpeg

Description (last modified by larryv (Lawrence Velázquez))

While trying to compile ffmpeg I got this error on x86_64 (I was just upgrading ports): Please let me know if more info will can be helpful.

:info:build /usr/bin/clang -I. -I./ -I/opt/local/include -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DPIC -DHAVE_AV_CONFIG_H -O2 -DHAVE_LRINTF -I/opt/local/include -arch i386   -std=c99 -fomit-frame-pointer -fPIC -I/opt/local/include/freetype2 -I/opt/local/include -I/opt/local/include/opus -I/opt/local/include/schroedinger-1.0 -I/opt/local/include/orc-0.4 -D_GNU_SOURCE=1 -D_THREAD_SAFE -I/opt/local/include/SDL -g -Wdeclaration-after-statement -Wall -Wno-parentheses -Wno-switch -Wno-format-zero-length -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wno-pointer-sign -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wno-pointer-to-int-cast -Wstrict-prototypes -O3 -fno-math-errno -fno-signed-zeros -mllvm -stack-alignment=16 -Qunused-arguments -Werror=implicit-function-declaration -Werror=missing-prototypes  -MMD -c -o libavcodec/h264_cabac.o libavcodec/h264_cabac.c
:info:build fatal error: error in backend: Ran out of registers during register allocation!

Attachments (1)

main.log.bz2 (41.4 KB) - added by aszoz@… 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by larryv (Lawrence Velázquez)

Cc: devans@… added
Description: modified (diff)
Owner: changed from macports-tickets@… to jeremyhu@…
Port: ffmpeg added

Thanks for the ticket. In the future, please Cc relevant port maintainers.

This looks similar to #37802, but that particular problem only showed up when compiling for i386. Please run the following; if it still fails, attach the entire main.log, which will be mentioned in the failure message.

sudo port clean ffmpeg && sudo port install ffmpeg

comment:2 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Also, what is your version of clang (/usr/bin/clang --version)?

comment:3 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

This error *is* with i386 (see -arch i386 in the compilation line).

Does ffmpeg-devel build?

comment:4 in reply to:  3 Changed 7 years ago by larryv (Lawrence Velázquez)

Replying to jeremyhu@…:

This error *is* with i386 (see -arch i386 in the compilation line).

Womp. Brain shut off at “I got this error on x86_64”.

Changed 7 years ago by aszoz@…

Attachment: main.log.bz2 added

comment:5 Changed 7 years ago by aszoz@…

Yep the error is i386, I meant to say that my machine is 64bit unlike a similar error on 32bit here #30137 I have compiled ffmpeg with gcc (configure.compiler=apple-gcc-4.2), but just reproduced the error for your benefit with "port clean ffmpeg && port install ffmpeg". I was actually updating opencv, when this error popped up, so it looks like something broken, never happend to me in 3 years since I use ports.

clang -version
clang version 3.0 (tags/RELEASE_30/final)
Target: x86_64-apple-darwin10.8.0
Thread model: posix
Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:6 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

I need to know /usr/bin/clang --version and not clang --version ... thanks.

comment:7 Changed 7 years ago by aszoz@…

Yes, it's different. Is it the cause?

/usr/bin/clang --version
Apple clang version 2.0 (tags/Apple/clang-139) (based on LLVM 2.9svn)
Target: x86_64-apple-darwin10
Thread model: posix

comment:8 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Them being different is not the cause. You having an old clang is part of the problem. =)

comment:9 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

It looks like you have XCode 4.0.x ... clang-137 was in 4.0.0 and clang-163.7.1 is in 4.1.0. I'll blacklist < 163.7.1. You should probably update to a newer Xcode, too =).

comment:10 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed

comment:11 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.