Opened 7 years ago

Closed 6 years ago

#38202 closed defect (fixed)

tiff @4.0.3_1 install_name_tool fails and suggest -headerpad_max_install_names

Reported by: julien.malik@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: tiff

Description (last modified by ryandesign (Ryan Schmidt))

After an upgrade today, I had libtiff upgraded from 3.9.7_0 to 4.0.3_1. System is

Since that, install_name_tool fails when I make a bundle of an app of mine :

install_name_tool: changing install names or rpaths can't be redone for: /Users/otbval/Dashboard/nightly/Monteverdi2-Release/build/_CPack_Packages/Darwin/Bundle/Monteverdi2-0.1.0-Darwin/Monteverdi2-0.1.app/Contents/Resources/MacOS/libtiff.5.dylib (for architecture x86_64) because larger updated load commands do not fit (the program must be relinked, and you may need to use -headerpad or -headerpad_max_install_names)

Never seen this message before. I successfully ran install_name_tool on libtiff coming from macport, since a long time. So this is a regression to me.

How about putting this -headerpad_max_install_names link flag in the port?

Change History (8)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Ok. We've also talked about maybe adding that flag globally, but I can't find the ticket right now.

comment:2 Changed 7 years ago by julien.malik@…

See also #36841 (fix applied) and #23372 (won't fix).

comment:4 Changed 7 years ago by julien.malik@…

I have forked the 4.0.3_1 version of tiff port in a local port index, added "configure.ldflags-append -headerpad_max_install_names" into the "platform macosx {}" section, and can confirm it solves my issue.

comment:5 in reply to:  1 Changed 7 years ago by su-v

Replying to ryandesign@…:

Ok. We've also talked about maybe adding that flag globally, but I can't find the ticket right now.

See #29838 “Generate shared libraries what can be processed with install_name_tool (one step toward shared library relocation)”

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Thanks! I've adjusted the title of that ticket to help find it in the future.

comment:7 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

MacPorts base now does use -headerpad_max_install_names by default. Has that fixed this problem?

comment:8 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Resolution: fixed
Status: newclosed

Assuming it has been.

Note: See TracTickets for help on using tickets.