Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#38436 closed defect (fixed)

hs-pandoc-types: command execution failed

Reported by: sam.kuper@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: i386 32-bit Cc: cooljeanius (Eric Gallager)
Port: hs-pandoc-types

Description

On a Mac Mini Core Duo 1.66GHz w/2GB RAM under OS X 10.6.8 Snow Leopard, running:

sudo port install pandoc

initially ran into #38427. Once #38427 was fixed, running:

sudo port -f clean --all all; sudo port install pandoc

seemed to go fine (downloading, building and installing dependencies smoothly), until it yielded the following error messages and quit:

--->  Fetching archive for hs-pandoc-types
--->  Attempting to fetch hs-pandoc-types-1.8_0.darwin_10.i386.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/hs-pandoc-types
--->  Attempting to fetch hs-pandoc-types-1.8_0.darwin_10.i386.tbz2 from http://lil.fr.packages.macports.org/hs-pandoc-types
--->  Attempting to fetch hs-pandoc-types-1.8_0.darwin_10.i386.tbz2 from http://packages.macports.org/hs-pandoc-types
--->  Fetching distfiles for hs-pandoc-types
--->  Attempting to fetch pandoc-types-1.8.tar.gz from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/hs-pandoc-types
--->  Verifying checksum(s) for hs-pandoc-types
--->  Extracting hs-pandoc-types
--->  Configuring hs-pandoc-types
Error: org.macports.configure for port hs-pandoc-types returned: configure failure: command execution failed
Error: Failed to install hs-pandoc-types
Please see the log file for port hs-pandoc-types for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_hs-pandoc-types/hs-pandoc-types/main.log
Error: The following dependencies were not installed: hs-citeproc hs-pandoc-types hs-utf8-string hs-xml hs-dlist hs-haddock hs-ghc-paths hs-http hs-network hs-parsec hs-text hs-tagsoup hs-texmath hs-zip-archive hs-binary hs-digest hs-zlib
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port pandoc failed

Attachments (2)

main.log (7.9 KB) - added by sam.kuper@… 6 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_hs-pandoc-types/hs-pandoc-types/main.log
main.2.log (12.3 KB) - added by sam.kuper@… 6 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_hs-pandoc-types/hs-pandoc-types/main.log

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by sam.kuper@…

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_hs-pandoc-types/hs-pandoc-types/main.log

comment:1 Changed 6 years ago by neverpanic (Clemens Lang)

64	:info:configure Setup: At least the following dependencies are missing:
65	:info:configure syb -any

hs-pandoc-types as well as the pandoc port (and some other haskell ports) needs some love and updates. If you're feeling up to the task I'd welcome a couple of tested patches against old portfiles. Updating haskell ports should be rather easy: See source:trunk/dports/devel/hs-parsec/Portfile for an example of a clean and simplistic Portfile. The information needed can usually be obtained from http://hackage.haskell.org/package/${name}, e.g. http://hackage.haskell.org/package/parsec in this case.

comment:2 Changed 6 years ago by sam.kuper@…

I patched the Portfile for hs-pandoc-types by appending the line:

depends_lib port:hs-platform-syb

I then re-ran sudo port install pandoc, which produced the following output:

--->  Computing dependencies for pandoc
--->  Dependencies to be installed: hs-citeproc hs-pandoc-types hs-platform-syb hs-utf8-string hs-xml hs-dlist hs-haddock hs-ghc-paths hs-http hs-network hs-parsec hs-text hs-tagsoup hs-texmath hs-zip-archive hs-binary hs-digest hs-zlib
--->  Fetching archive for hs-platform-syb
--->  Attempting to fetch hs-platform-syb-0.3.7_0.darwin_10.i386.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/hs-platform-syb
--->  Attempting to fetch hs-platform-syb-0.3.7_0.darwin_10.i386.tbz2 from http://lil.fr.packages.macports.org/hs-platform-syb
--->  Attempting to fetch hs-platform-syb-0.3.7_0.darwin_10.i386.tbz2 from http://packages.macports.org/hs-platform-syb
--->  Fetching distfiles for hs-platform-syb
--->  Attempting to fetch syb-0.3.7.tar.gz from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/hs-platform-syb
--->  Verifying checksum(s) for hs-platform-syb
--->  Extracting hs-platform-syb
--->  Configuring hs-platform-syb
--->  Building hs-platform-syb
--->  Staging hs-platform-syb into destroot
--->  Installing hs-platform-syb @0.3.7_0
--->  Activating hs-platform-syb @0.3.7_0
--->  Cleaning hs-platform-syb
Portfile changed since last build; discarding previous state.
--->  Fetching archive for hs-pandoc-types
--->  Attempting to fetch hs-pandoc-types-1.8_0.darwin_10.i386.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/hs-pandoc-types
--->  Attempting to fetch hs-pandoc-types-1.8_0.darwin_10.i386.tbz2 from http://lil.fr.packages.macports.org/hs-pandoc-types
--->  Attempting to fetch hs-pandoc-types-1.8_0.darwin_10.i386.tbz2 from http://packages.macports.org/hs-pandoc-types
--->  Fetching distfiles for hs-pandoc-types
--->  Verifying checksum(s) for hs-pandoc-types
--->  Extracting hs-pandoc-types
--->  Configuring hs-pandoc-types
--->  Building hs-pandoc-types
Error: org.macports.build for port hs-pandoc-types returned: command execution failed
Error: Failed to install hs-pandoc-types
Please see the log file for port hs-pandoc-types for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_hs-pandoc-types/hs-pandoc-types/main.log
Error: The following dependencies were not installed: hs-citeproc hs-pandoc-types hs-utf8-string hs-xml hs-dlist hs-haddock hs-ghc-paths hs-http hs-network hs-parsec hs-text hs-tagsoup hs-texmath hs-zip-archive hs-binary hs-digest hs-zlib
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port pandoc failed

I will attach the new version of /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_hs-pandoc-types/hs-pandoc-types/main.log

Changed 6 years ago by sam.kuper@…

Attachment: main.2.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_hs-pandoc-types/hs-pandoc-types/main.log

comment:3 Changed 6 years ago by seanfarley (Sean Farley)

I am actively working on the patch for this today so if others could hold off on patching until I push my changes, that'd be great. I'll try to incorporate this change (if I haven't already) as well.

comment:4 Changed 6 years ago by neverpanic (Clemens Lang)

That's #37403. Updating hs-pandoc-types might help. Also relevant and basically a duplicate of this ticket: #36608.

comment:5 in reply to:  4 Changed 6 years ago by seanfarley (Sean Farley)

Resolution: fixed
Status: newclosed

Replying to cal@…:

That's #37403. Updating hs-pandoc-types might help. Also relevant and basically a duplicate of this ticket: #36608.

This should be fixed with the new updates to pandoc in r104342 (and friends), so I'm going to close this for now.

comment:6 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.