New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #38992 (closed defect: worksforme)

Opened 12 months ago

Last modified 11 months ago

rubygem 2.0 can't communicate with remote sources http://rubygems.org/

Reported by: frederic.leger@… Owned by: kimuraw@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc:
Port: ruby20

Description (last modified by ciserlohn@…) (diff)

I try to use Ruby 2.0 on my MAC OSX Mountain Lion with macports. The "sudo port install ruby2.0" and "sudo port select --set ruby ruby2.0" was success. But when I try to install gem package I have these errors:

sudo gem list --remote -V --backtrace
Password:
*** REMOTE GEMS ***
GET http://rubygems.org/latest_specs.4.8.gz
302 Moved Temporarily GET http://production.s3.rubygems.org/latest_specs.4.8.gz
connection reset after 1 requests, retrying
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
connection reset after 1 requests, retrying

Some others informations:

$ sudo gem environment
RubyGems Environment:
 - RUBYGEMS VERSION: 2.0.0 
 - RUBY VERSION: 2.0.0 (2013-02-24 patchlevel 0) [x86_64-darwin12] 
 - INSTALLATION DIRECTORY: /opt/local/lib/ruby2.0/gems/2.0.0 
 - RUBY EXECUTABLE: /opt/local/bin/ruby2.0 
 - EXECUTABLE DIRECTORY: /opt/local/bin 
 - RUBYGEMS PLATFORMS: - ruby - x86_64-darwin-12 
 - GEM PATHS: - /opt/local/lib/ruby2.0/gems/2.0.0 - /Users/fred/.gem/ruby/2.0.0 
 - GEM CONFIGURATION: - :update_sources => true - :verbose => true - :backtrace => false - :bulk_threshold => 1000 
 - REMOTE SOURCES: - http://rubygems.org/ 
$ sudo gem list -d 
*** LOCAL GEMS ***
bigdecimal (1.2.0) Authors: Kenta Murata, Shigeo Kobayashi Homepage: http://www.ruby-lang.org Installed at (default): /opt/local/lib/ruby2.0/gems/2.0.0 Arbitrary-precision decimal floating-point number library.
io-console (0.4.2) Author: Nobu Nakada Homepage: http://www.ruby-lang.org License: ruby Installed at (default): /opt/local/lib/ruby2.0/gems/2.0.0 Console interface 
json (1.7.7) Author: Installed at (default): /opt/local/lib/ruby2.0/gems/2.0.0 This json is bundled with Ruby
minitest (4.3.2) Author: Installed at (default): /opt/local/lib/ruby2.0/gems/2.0.0 This minitest is bundled with Ruby
psych (2.0.0) Author: Aaron Patterson Homepage: http://github.com/tenderlove/psych Installed at (default): /opt/local/lib/ruby2.0/gems/2.0.0 Psych is a YAML parser and emitter 
rake (0.9.6) Author: Installed at (default): /opt/local/lib/ruby2.0/gems/2.0.0 This rake is bundled with Ruby
rdoc (4.0.0) Author: Installed at (default): /opt/local/lib/ruby2.0/gems/2.0.0 This rdoc is bundled with Ruby
test-unit (2.0.0.0) Author: Shota Fukumori Homepage: http://www.ruby-lang.org Installed at (default): /opt/local/lib/ruby2.0/gems/2.0.0 test/unit compatible API testing framework 

Workaround : I uninstall all macports ruby packages. And install RVM (https://rvm.io/rvm/). Activate ruby 2.0.0-p0 by rvm. And now, the "gem list -r" is fully functionnal. So, we have a bug with gem in macport, not a network problem.

Change History

comment:1 Changed 12 months ago by ciserlohn@…

  • Keywords ruby gem remote removed
  • Owner changed from macports-tickets@… to kimuraw@…
  • Description modified (diff)
  • Port set to ruby20

In the future please use WikiFormatting, Cc' the maintainer and fill in the port field.

comment:2 Changed 12 months ago by kimuraw@…

I reproduced this error at 2013-04-24 with port:ruby20 and port:ruby19 from your github issue https://github.com/rubygems/rubygems/issues/543.

but now works for me.

% file /opt/local/bin/gem
/opt/local/bin/gem: symbolic link to `/opt/local/bin/gem2.0'
% sudo gem list --remote -V --backtrace

HEAD http://rubygems.org/latest_specs.4.8.gz
302 Moved Temporarily
HEAD http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
GET http://rubygems.org/latest_specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
GET http://rubygems.org/quick/Marshal.4.8/aasm-3.0.17.gemspec.rz
302 Moved Temporarily
GET http://tokyo-m.rubygems.org/quick/Marshal.4.8/aasm-3.0.17.gemspec.rz
200 OK
  :
% sudo gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 2.0.0
  - RUBY VERSION: 2.0.0 (2013-02-24 patchlevel 0) [x86_64-darwin12]
  - INSTALLATION DIRECTORY: /opt/local/lib/ruby2.0/gems/2.0.0
  - RUBY EXECUTABLE: /opt/local/bin/ruby2.0
  - EXECUTABLE DIRECTORY: /opt/local/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-darwin-12
  - GEM PATHS:
     - /opt/local/lib/ruby2.0/gems/2.0.0
     - /Users/kimuraw/.gem/ruby/2.0.0
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/

comment:3 Changed 11 months ago by kimuraw@…

  • Status changed from new to closed
  • Resolution set to worksforme

I cannot reproduce this problem in this week. I'll close this ticket as "worksforme".

reopen this ticket if your problem not solved.

Note: See TracTickets for help on using tickets.