Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#39333 closed defect (fixed)

scotch build error, mpicc not found

Reported by: petrrr Owned by: mkae (Marko Käning)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: mkae (Marko Käning), pixilla (Bradley Giesbrecht), wimmer@…, petrrr
Port: scotch

Description

I guess the problem is here:

[...]
mpicc -O3 -Drestrict=__restrict -DCOMMON_PTHREAD -DCOMMON_RANDOM_FIXED_SEED -DCOMMON_TIMING_OLD -DSCOTCH_PTHREAD -DSCOTCH_RENAME -DSCOTCH_RENAME_PARSER -DSCOTCH_PTSCOTCH -DSCOTCH_VERSION=5 -DSCOTCH_RELEASE=1 -DSCOTCH_PATCHLEVEL=10 dummysizes.c -o dummysizes -lm
make[2]: mpicc: No such file or directory
[...]

The path should be given explicitly. Usually, this probably isn't noted, because there are some link or similar around, but on my freshly installed system its not set yet.

Attachments (3)

scotch.main.log (101.2 KB) - added by petrrr 4 years ago.
The main.log file.
Portfile (3.1 KB) - added by wimmer@… 4 years ago.
Portfile with explicit path to openmpicc
Portfile-scotch.diff (398 bytes) - added by wimmer@… 4 years ago.
Replace mpicc with explicit path to openmpicc

Download all attachments as: .zip

Change History (18)

Changed 4 years ago by petrrr

The main.log file.

comment:1 follow-up: Changed 4 years ago by petrrr

By the way, maybe this is a good occasion to update this port?

comment:2 follow-up: Changed 4 years ago by mkae (Marko Käning)

  • Owner changed from macports-tickets@… to mk@…

Hmmm, I actually thought about abandoning it, because I introduced it back then only in order to build something else which I never pursued any further.

Also this port doesn't work for newer compilers.

So, perhaps it's the time to get rid of it?

comment:3 in reply to: ↑ 2 Changed 4 years ago by petrrr

Replying to mk@…:

Hmmm, I actually thought about abandoning it, because I introduced it back then only in order to build something else which I never pursued any further.

Well, I would vote for keeping it, it's useful for other purposes. I used it to build other software already and had the impression it worked fine for that purpose.

Also this port doesn't work for newer compilers.

What is the issue here? Is blacklisting an option?

So, perhaps it's the time to get rid of it?

Well ...

comment:4 Changed 4 years ago by mf2k (Frank Schima)

@Peter.Danecek: If you are interested in keeping this port, then please step up and volunteer to maintain it.

comment:5 Changed 4 years ago by mkae (Marko Käning)

Hi Peter,

I also think that you could provide a patch to solve this issue. I'm willing to commit your suggestions, but I since I am not using this port at all and never really have done so I am not competent enough to do more about it.

If you're interested in maintaing this port, let me know. I am happy handing it over to you.

Greets, Marko

comment:6 Changed 4 years ago by petrrr

Fine, will try to fix it in the near future, not immediately though (need to finish some stuff first). Maintainer? Well, first let's see if I get it fixed ;-)

comment:7 Changed 4 years ago by mkae (Marko Käning)

Great, I am happy that there is at least one user of this port! :-)

comment:8 Changed 4 years ago by mkae (Marko Käning)

BTW, there is a new version out there: 5.1.12!

Changed 4 years ago by wimmer@…

Portfile with explicit path to openmpicc

comment:9 follow-up: Changed 4 years ago by wimmer@…

I have added a Portfile that solves the mpicc issue.

It turns out that I need this package, in particular because it is a prerequisite of another package I'd like to get to MacPorts (the MUMPS sparse solver, http://graal.ens-lyon.fr/MUMPS/ ). Hence I can look a bit into updating this port.

In particular, I'd need the version from the SCOTCH website that ends with "_esmumps". That version adds an additional wrapper library used by MUMPS. Is there any reason to not directly include that additional wrapper? Making a variant seems a bit exaggerated with a port very few people use. If that's ok, I'll add a portfile with a recent version and including the "esmumps" wrapper.

Last edited 4 years ago by wimmer@… (previous) (diff)

comment:10 Changed 4 years ago by wimmer@…

  • Cc wimmer@… added

Cc Me!

comment:11 in reply to: ↑ 9 ; follow-up: Changed 4 years ago by mf2k (Frank Schima)

Replying to wimmer@…:

I have added a Portfile that solves the mpicc issue.

Per the guide, please instead attach a unified diff of the Portfile.

Changed 4 years ago by wimmer@…

Replace mpicc with explicit path to openmpicc

comment:12 in reply to: ↑ 11 Changed 4 years ago by wimmer@…

Replying to macsforever2000@…:

Replying to wimmer@…:

I have added a Portfile that solves the mpicc issue.

Per the guide, please instead attach a unified diff of the Portfile.

Sorry, was misguided there. I hope the proper format is there now.

comment:13 Changed 4 years ago by mkae (Marko Käning)

  • Resolution set to fixed
  • Status changed from new to closed

Thanks!

Committed in r108309.

comment:14 in reply to: ↑ 1 Changed 4 years ago by mkae (Marko Käning)

Replying to Peter.Danecek@…:

By the way, maybe this is a good occasion to update this port?

See #39813. :-)

comment:15 Changed 3 years ago by petrrr

  • Cc petr@… added

Cc Me!

Note: See TracTickets for help on using tickets.