Opened 7 years ago

Closed 6 years ago

#39797 closed defect (fixed)

alioth.debian.org rearranged their URLs

Reported by: sharon.dagan@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: ryandesign (Ryan Schmidt), ci42, master@…, aguynamedryan+sane@…, davidstuartbruce@…, cgilles (HumanDynamo)
Port: axel minicom t4k_common tuxmath tuxtype sane-backends pinfo

Description (last modified by ci42)

...
:debug:checksum checksum phase started at Thu Jul 18 21:50:24 IDT 2013
:notice:checksum --->  Verifying checksum(s) for axel
:debug:checksum Executing org.macports.checksum (axel)
:info:checksum --->  Checksumming axel-2.4.tar.gz
:error:checksum Checksum (sha1) mismatch for axel-2.4.tar.gz
:info:checksum Portfile checksum: axel-2.4.tar.gz sha1 6d89a7ce797ddf4c23a210036d640d013fe843ca
:info:checksum Distfile checksum: axel-2.4.tar.gz sha1 da39a3ee5e6b4b0d3255bfef95601890afd80709
:info:checksum The correct checksum line may be:
:info:checksum checksums           sha1    da39a3ee5e6b4b0d3255bfef95601890afd80709
:error:checksum org.macports.checksum for port axel returned: Unable to verify file checksums
:debug:checksum Error code: NONE
:debug:checksum Backtrace: Unable to verify file checksums
    while executing
"$procedure $targetname"
:info:checksum Warning: targets not executed for axel: org.macports.activate org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
...

Attachments (1)

sane-backends.diff (936 bytes) - added by opensource@… 7 years ago.
Sane-backends diff

Download all attachments as: .zip

Change History (27)

comment:1 Changed 7 years ago by ci42

Description: modified (diff)
Port: axel added
Summary: axel-2.4 checksumaxel @ 2.4 checksum mismatch

In the future please remember to use WikiFormatting and fill in the port field.

comment:2 Changed 7 years ago by ci42

Resolution: fixed
Status: newclosed

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: closedreopened

Why were the checksums wrong? Was this a stealth update?

In fact it seems the new distfile that these checksums match is 0 bytes. That cannot be right. Did you test that the port installs properly after this change? It cannot possibly do so.

The correct distfile matching the old checksums is located on our mirror servers. Well, it was; changing the checksums like this will cause it to begin to be deleted from the mirror servers.

comment:4 Changed 7 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ciserlohn@…
Status: reopenednew

comment:5 Changed 7 years ago by ci42

Owner: changed from ciserlohn@… to macports-tickets@…
Summary: axel @ 2.4 checksum mismatchaxel @ 2.4 distfile download unstable

Reverted in r108321. I mistakenly put in the wrong checksums while trying to find out why the aforementioned checksum mismatch occurs (I was able to reproduce it).

The distfile download is somewhat unstable, have a look a the buildbot logs from r108319 and r108321:

Sometimes it downloads the correct distfile, sometime a zero length distfile.

Last edited 7 years ago by ci42 (previous) (diff)

comment:6 Changed 7 years ago by ci42

Cc: ciserlohn@… added

Cc Me!

comment:7 in reply to:  3 ; Changed 7 years ago by ci42

Replying to ryandesign@…:

The correct distfile matching the old checksums is located on our mirror servers. Well, it was; changing the checksums like this will cause it to begin to be deleted from the mirror servers.

The mirror servers had no distfile for axel 2.4, only for axel 2.3. I've checked that before the r108319 commit.

comment:8 in reply to:  7 Changed 7 years ago by ryandesign (Ryan Schmidt)

Replying to ciserlohn@…:

The distfile download is somewhat unstable, have a look a the buildbot logs from r108319 and r108321:

Here, the old correct 50704-byte distfile was downloaded from distfiles.macports.org.

Sometimes it downloads the correct distfile, sometime a zero length distfile.

By this time, the primary distfiles mirror had noticed that the new checksums in the portfile did not match the old distfile, so it deleted the old distfile and replaced it with the new 0-byte distfile from upstream.

Replying to ciserlohn@…:

The mirror servers had no distfile for axel 2.4, only for axel 2.3. I've checked that before the r108319 commit.

Sure they do. For example: http://sea.us.distfiles.macports.org/macports/distfiles/axel/axel-2.4.tar.gz; I checked this before reopening the ticket.

comment:9 Changed 7 years ago by ryandesign (Ryan Schmidt)

Looks like the download URL should be http://alioth.debian.org/frs/download.php/file/3015/axel-2.4.tar.gz not http://alioth.debian.org/frs/download.php/3015/axel-2.4.tar.gz. Additionally, we could switch to the bz2 distfile to be slightly smaller.

comment:10 Changed 7 years ago by ryandesign (Ryan Schmidt)

I guess this affects all ports downloading from alioth.debian.org; I guess they've rearranged their URLs.

comment:11 in reply to:  10 Changed 7 years ago by ci42

Replying to ryandesign@…:

I guess this affects all ports downloading from alioth.debian.org; I guess they've rearranged their URLs.

You're right. A short grep and port -v checksum revealed that the following ports are also affected:

  • minicom
  • t4k_common
  • tuxmath
  • tuxtype
  • sane-backends
  • pinfo

comment:12 Changed 7 years ago by ci42

Cc: master@… aguynamedryan+sane@… davidstuartbruce@… added
Port: minicom t4k_common tuxmath tuxtype sane-backends pinfo added
Summary: axel @ 2.4 distfile download unstablealioth.debian.org rearranged their URLs

comment:13 Changed 7 years ago by ryandesign (Ryan Schmidt)

alioth is powered by fusionforge. Maybe this URL change is part of fusionforge 5.2 to which alioth seems to have updated. There are other sites powered by fusionforge from which we download files in MacPorts (grep for "frs/download.php") so we'll have to watch out for them updating their installations as well.

comment:14 Changed 7 years ago by ci42

Changed 7 years ago by opensource@…

Attachment: sane-backends.diff added

Sane-backends diff

comment:15 Changed 7 years ago by larryv (Lawrence Velázquez)

Has duplicate #39543 for sane-backends, fixed in r108351.

comment:16 Changed 6 years ago by cgilles (HumanDynamo)

Problem still here about sane-backends. I uninstalled macports from whole computer and re-installed it as well.

MacBook-Pro-de-Gilles:~ gilles$ sudo port install digikam
Password:
--->  Computing dependencies for digikam
--->  Dependencies to be installed: libksane sane-backends liblqr marble gpsd libkdeedu opencv qt4-mac-sqlite3-plugin
--->  Verifying checksums for sane-backends
Error: Checksum (md5) mismatch for sane-backends-1.0.22.tar.gz
Error: Checksum (sha1) mismatch for sane-backends-1.0.22.tar.gz
Error: Checksum (rmd160) mismatch for sane-backends-1.0.22.tar.gz
Error: org.macports.checksum for port sane-backends returned: Unable to verify file checksums
Error: Failed to install sane-backends
Please see the log file for port sane-backends for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_sane-backends/sane-backends/main.log
Error: The following dependencies were not installed: libksane sane-backends liblqr marble gpsd libkdeedu opencv qt4-mac-sqlite3-plugin
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port digikam failed
MacBook-Pro-de-Gilles:~ gilles$ 

Gilles Caulier

Last edited 6 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:17 in reply to:  16 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: caulier.gilles@… added

Replying to caulier.gilles@…:

Problem still here about sane-backends.

You are experiencing a different/new problem (perhaps caused by r120910); please file a new ticket (and Cc ciserlohn at macports dot org).

comment:18 in reply to:  16 ; Changed 6 years ago by ci42

Replying to caulier.gilles@…:

Problem still here about sane-backends. I uninstalled macports from whole computer and re-installed it as well.

Works for me:

bash-4.3$ sudo port -d checksum sane-backends
DEBUG: Copying /Users/ci/Library/Preferences/com.apple.dt.Xcode.plist to /opt/local/var/macports/home/Library/Preferences
DEBUG: Changing to port directory: /Users/ci/devel/repos/macports/trunk/dports/graphics/sane-backends
DEBUG: OS darwin/11.4.2 (Mac OS X 10.7) arch i386
DEBUG: adding the default universal variant
DEBUG: Reading variant descriptions from /Users/ci/devel/repos/macports/trunk/dports/_resources/port1.0/variant_descriptions.conf
DEBUG: Running callback portconfigure::add_automatic_compiler_dependencies
DEBUG: Finished running callback portconfigure::add_automatic_compiler_dependencies
DEBUG: Running callback portbuild::add_automatic_buildsystem_dependencies
DEBUG: Finished running callback portbuild::add_automatic_buildsystem_dependencies
DEBUG: Attempting ln -sf /opt/local/var/macports/build/_Users_ci_devel_repos_macports_trunk_dports_graphics_sane-backends/sane-backends/work /Users/ci/devel/repos/macports/trunk/dports/graphics/sane-backends/work
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
DEBUG: egid changed to: 501
DEBUG: euid changed to: 502
DEBUG: Starting logging for sane-backends
DEBUG: Executing org.macports.main (sane-backends)
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
DEBUG: egid changed to: 501
DEBUG: euid changed to: 502
DEBUG: fetch phase started at Wed Jun 25 22:44:06 CEST 2014
--->  Fetching distfiles for sane-backends
DEBUG: Can't run fetch on this port without elevated privileges. Escalating privileges back to root.
DEBUG: euid changed to: 0. egid changed to: 0.
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
DEBUG: egid changed to: 501
DEBUG: euid changed to: 502
DEBUG: Executing org.macports.fetch (sane-backends)
--->  sane-backends-1.0.22.tar.gz doesn't seem to exist in /opt/local/var/macports/distfiles/sane-backends
--->  Attempting to fetch sane-backends-1.0.22.tar.gz from http://nue.de.distfiles.macports.org/macports/distfiles/sane-backends
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 5029k  100 5029k    0     0   501k      0  0:00:10  0:00:10 --:--:--  258k
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: checksum phase started at Wed Jun 25 22:44:18 CEST 2014
--->  Verifying checksums for sane-backends
DEBUG: Executing org.macports.checksum (sane-backends)
--->  Checksumming sane-backends-1.0.22.tar.gz
DEBUG: Calculated (md5) is fadf56a60f4776bfb24491f66b617cf5
DEBUG: Correct (md5) checksum for sane-backends-1.0.22.tar.gz
DEBUG: Calculated (sha1) is dc04d6e6fd18791d8002c3fdb23e89fef3327135
DEBUG: Correct (sha1) checksum for sane-backends-1.0.22.tar.gz
DEBUG: Calculated (rmd160) is 524713474a819331d0179fa642fef710d073f1d1
DEBUG: Correct (rmd160) checksum for sane-backends-1.0.22.tar.gz

Please run:

$ sudo port clean --dist sane-backends
$ sudo port -d checksum sane-backends

and attach the output.

comment:19 Changed 6 years ago by cgilles (HumanDynamo)

bash-3.2$ date
Jeu 26 jui 2014 08:04:14 CEST
bash-3.2$ sudo port install sane-backends
Password:
--->  Computing dependencies for sane-backends
--->  Verifying checksums for sane-backends
Error: Checksum (md5) mismatch for sane-backends-1.0.22.tar.gz
Error: Checksum (sha1) mismatch for sane-backends-1.0.22.tar.gz
Error: Checksum (rmd160) mismatch for sane-backends-1.0.22.tar.gz
Error: org.macports.checksum for port sane-backends returned: Unable to verify file checksums
Please see the log file for port sane-backends for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_sane-backends/sane-backends/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port sane-backends failed
bash-3.2$ sudo port clean --dist sane-backends
--->  Cleaning sane-backends
bash-3.2$ sudo port -d checksum sane-backends
DEBUG: Copying /Users/gilles/Library/Preferences/com.apple.dt.Xcode.plist to /opt/local/var/macports/home/Library/Preferences
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/graphics/sane-backends
DEBUG: OS darwin/13.2.0 (Mac OS X 10.9) arch i386
DEBUG: adding the default universal variant
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: Running callback portconfigure::add_automatic_compiler_dependencies
DEBUG: Finished running callback portconfigure::add_automatic_compiler_dependencies
DEBUG: Running callback portbuild::add_automatic_buildsystem_dependencies
DEBUG: Finished running callback portbuild::add_automatic_buildsystem_dependencies
DEBUG: Attempting ln -sf /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_sane-backends/sane-backends/work /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/graphics/sane-backends/work
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
DEBUG: egid changed to: 501
DEBUG: euid changed to: 502
DEBUG: Starting logging for sane-backends
DEBUG: Executing org.macports.main (sane-backends)
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
DEBUG: egid changed to: 501
DEBUG: euid changed to: 502
DEBUG: fetch phase started at Thu Jun 26 08:05:39 CEST 2014
--->  Fetching distfiles for sane-backends
DEBUG: Can't run fetch on this port without elevated privileges. Escalating privileges back to root.
DEBUG: euid changed to: 0. egid changed to: 0.
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
DEBUG: egid changed to: 501
DEBUG: euid changed to: 502
DEBUG: Executing org.macports.fetch (sane-backends)
--->  sane-backends-1.0.22.tar.gz doesn't seem to exist in /opt/local/var/macports/distfiles/sane-backends
--->  Attempting to fetch sane-backends-1.0.22.tar.gz from http://lil.fr.distfiles.macports.org/sane-backends
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 5029k  100 5029k    0     0   462k      0  0:00:10  0:00:10 --:--:--  554k
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: checksum phase started at Thu Jun 26 08:05:51 CEST 2014
--->  Verifying checksums for sane-backends
DEBUG: Executing org.macports.checksum (sane-backends)
--->  Checksumming sane-backends-1.0.22.tar.gz
DEBUG: Calculated (md5) is fadf56a60f4776bfb24491f66b617cf5
DEBUG: Correct (md5) checksum for sane-backends-1.0.22.tar.gz
DEBUG: Calculated (sha1) is dc04d6e6fd18791d8002c3fdb23e89fef3327135
DEBUG: Correct (sha1) checksum for sane-backends-1.0.22.tar.gz
DEBUG: Calculated (rmd160) is 524713474a819331d0179fa642fef710d073f1d1
DEBUG: Correct (rmd160) checksum for sane-backends-1.0.22.tar.gz
bash-3.2$ 

comment:20 Changed 6 years ago by cgilles (HumanDynamo)

bash-3.2$ sudo port install sane-backends
--->  Computing dependencies for sane-backends
--->  Fetching archive for sane-backends
--->  Attempting to fetch sane-backends-1.0.22_4.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/sane-backends
--->  Attempting to fetch sane-backends-1.0.22_4.darwin_13.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/sane-backends
--->  Attempting to fetch sane-backends-1.0.22_4.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/sane-backends
--->  Extracting sane-backends
--->  Applying patches to sane-backends
--->  Configuring sane-backends
--->  Building sane-backends

Now this package can be installed without problem. Sorry for the noise...

comment:21 in reply to:  18 Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to ciserlohn@…:

Works for me:

Of course it works for you, because your download came from a MacPorts distfiles mirror, not from the upstream alioth.debian.org server.

As I said above, this new issue is totally separate from the one this ticket is about. Please see #43999 for this new issue and do not discuss it further in this unrelated ticket.

comment:22 Changed 6 years ago by ryandesign (Ryan Schmidt)

  • pinfo: r125703 (maintainer timeout)

comment:23 Changed 6 years ago by ryandesign (Ryan Schmidt)

  • t4k_common: r125875 (maintainer timeout)

comment:24 Changed 6 years ago by ryandesign (Ryan Schmidt)

  • tuxmath: r126010 (maintainer timeout)

comment:25 Changed 6 years ago by ryandesign (Ryan Schmidt)

  • tuxtype: r126076 (maintainer timeout)

comment:26 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.